ath5k breaks from resume? <sometimes>

N

nephilim

Guest
Now that my suspend feature works in Debian7 XFCE, just a few minutes ago I woke from suspend (for maybe the 10th time since the fix) and I had no wireless with dmesg reporting a repeating ath5k timeout.

I've seen this problem in #! with the 3.2 kernel which forced me to go with 3.6 or liquorix. Now that I fully shutdown the laptop and rebooted ath5k reports no more problems. I don't mind fixing little problems but I don't like intermittent ones, they piss me off.

I will update this later to report on anymore disabled wifi from resume. Also can someone tell me how to find the error log from a previous session. I can only find the logs from this boot. Thanks.
 


OP
D

DevynCJohnson

Guest
I have Ubuntu 13.1 using an Atheros wifi device. My suspend feature does not work correctly and if I am lucky enough to get suspend to work, my wifi device shuts off until a reboot. So, your problem may be some bug in Ubuntu or the drivers.
 
OP
N

nephilim

Guest
I've never compiled a kernel before, but I've seen your tutorials on this site. Do you think doing so would fix my intermittent wireless issues? I really don't know much about kernels besides that they connect the interface to the hardware. Maybe try to compile 3.12 on this laptop? Also if I mess something up I can always choose the original kernel in the GRUB menu at boot right?
 
OP
D

DevynCJohnson

Guest
I've never compiled a kernel before, but I've seen your tutorials on this site. Do you think doing so would fix my intermittent wireless issues? I really don't know much about kernels besides that they connect the interface to the hardware. Maybe try to compile 3.12 on this laptop? Also if I mess something up I can always choose the original kernel in the GRUB menu at boot right?

Yes, making your own kernel can help you, but you could also create new problems. So, do so with caution and knowledge. You may have better luck downloading a module for the wireless device (if one can be found), install it, and then load the module. Yes, you can boot into the previous kernel if needed.
 
OP
R

ryanvade

Guest
I have this issue with Ethernet cards also some times. It seems to be an issue with the kernel loading the module back into ram after the suspend.
 
$100 Digital Ocean Credit
Get a free VM to test out Linux!

Staff online

Members online


Top