Am I on the right track?


Hi all,
I recently got hold of a Dell optiplex 9020 sff and I'm configuring it to use as a home server.
I removed the hard drive and installed two SSDs, then I removed the optical drive and installed a third SSD.
The optical drive has its own SATA power and data cables that were in the machine. I don't know if the optical
drive worked when I bought this box.
Anyway, when I boot the system, either from the BIOS or a Linux stick, the system sees ONLY the two drives in
the old drive bay, and not the drive in the optical bay. I've opened it up and made sure everything was well seated
and tight. Everything seems fine.
So, what to do? I should mention that I have 0.11111111111 experience with hardware. Gaining more experience with hardware and getting more comfortable with it is one of the reasons I wanted to start upgrading my own boxes.
So I'm thinking there are three possibilities: either one of the cables is bad, the drive itself
is dead (it was brand new), the SSD is just incompatible with the system for some reason (any hints?), or there's a problem with the motherboard. Of those three I would order their likelyhood:
1) cables
2) drive dead or incompatible
3) mother board problem (I seriously doubt this - I haven't seen ANY other problem indications with the system)

So, any advice? Something I don't know that one of you more experienced hardware guys DO know? Do I seem to be on the
right track?




Staff member
Gold Supporter
My first thought would be to take one cable from one of the two recognized disks and put it in the drive in the bay, Two disks connected, one disk not connected. Now how many disks are recognized?


Well-Known Member
If swapping cables does not work for seeing the third SSD from boot, then check your /etc/fstab file to see if it's listed there.


Problem Solved.
Thanks for the help. I went in and replaced the SATA data cable. No change. I then removed the caddy that I had installed the SSD into, thinking I would remove the SDD and plug it directly in to eliminate the Caddy as a point of failure. That didn't work because the connections on the SSD did not match the SATA cables in the computer. However, when reinstalling the SSD back into the caddy I noticed that it seemed to be a little 'off' in its I played with it and made sure I got the SSD plugged into the caddy properly. Put everything back togetether and voila.....the disk was seen.

Staff online

Members online