After the usual "update" the sound output suddenly crackles (every second)

Jay Lee

New Member
Joined
Jul 29, 2020
Messages
29
Reaction score
10
Credits
275
Hello,

my Ubuntu "20.04.4 LTS" ran fine until the last update - but now the sound crackles, no matter which application, so it's a general problem. Since I have a dual boot system and everything sounds clean in Windows, there is no speaker or hardware problem.

However, I'm a bit overwhelmed when it comes to finding the cause or solving the problem, the Internet only gives instructions on how to proceed if you have no sound at all and/or Ubuntu doesn't want to/can't find the sound card. But that's not my problem...

How could I best proceed now to fix the sound?
:)
 


Condobloke

Well-Known Member
Joined
Apr 30, 2017
Messages
4,514
Reaction score
3,941
Credits
25,363
What was included in the update ?

Edit to Add : Do you have Timeshift set up ?
 

Brickwizard

Well-Known Member
Joined
Apr 28, 2021
Messages
2,561
Reaction score
1,707
Credits
19,216
Do you have Timeshift or similar on your Ubuntu installation?
If so, the quickest way is to roll back to before the update, if all is ok then run update again, check what the updates include and if there are any related to sound un-tick them and just install the rest,
 
OP
Jay Lee

Jay Lee

New Member
Joined
Jul 29, 2020
Messages
29
Reaction score
10
Credits
275
Hi,

I was on a "business trip" for a few weeks and when I started Ubuntu for the first time on Monday, that is yesterday, there was an update. Of course I don't know what's new in the last 3-4 weeks or how many "regular" updates took place... I only got the "concentrated" update due to the 3-4 week break.

Where can I find out what was changed yesterday?
 

Brickwizard

Well-Known Member
Joined
Apr 28, 2021
Messages
2,561
Reaction score
1,707
Credits
19,216
I don't know if this still works in Ubuntu, open update manager [synaptic] look through the drop-down boxes for show history and open [this use to be the easy way]
 

Brickwizard

Well-Known Member
Joined
Apr 28, 2021
Messages
2,561
Reaction score
1,707
Credits
19,216
@KGIII is our Ubuntu expert, he should be on in a couple of hours
 

KGIII

Super Moderator
Staff member
Gold Supporter
Joined
Jul 23, 2020
Messages
6,150
Reaction score
5,521
Credits
49,577
N

NorthWest

Guest
Jay Lee asked:
Where can I find out what was changed yesterday?
You could have a look at /var/log/dpkg.log which holds the changes to the system with dates and times.
You can grep through the file with the terms "install", "upgrade", "remove" to see what's happened and when.
 
OP
Jay Lee

Jay Lee

New Member
Joined
Jul 29, 2020
Messages
29
Reaction score
10
Credits
275
Thank you all for your replies.
Especially @KGIII - your provided links did it...

First I did try the pulseaudio-modifications, "tsched=0" e.g., because they seem the most easy way.
But this did not had any effect.

Then I did exchange "pulseaudio" with "pipewire"... and until yet... all sounds "sound" clear and perfect again.
:D
 
Last edited:
OP
Jay Lee

Jay Lee

New Member
Joined
Jul 29, 2020
Messages
29
Reaction score
10
Credits
275
Hello,

I have to make a small restriction ;)

I followed this guide step by step and disabled "pulseaudio" and installed "pipewire" instead:


Everything worked, great sound....
...until the restart (the next day, than today)... then the sound was choppy again.

A quick check revealed:
pulse.png.jpg


It's "german", but you can still tell that "Pulseaudio" was selected as the default sound system again when the system started (although the instructions linked above actually clearly deactivate "Pulseaudio" and activate "Pipewire" as the default).


So I carried out the two instructions from the linked manual again, to deactivate "Pulseaudio" and to activate "Pipewire"...

pulse2.png.jpg



... and the sound was immediately perfect again.

However, I now get the following message:

pulse3.png.jpg


It says:

Connection Error: Connection refused
pa_context_new() failed: Connection refused


Now I'm a bit confused...
o_O
 

KGIII

Super Moderator
Staff member
Gold Supporter
Joined
Jul 23, 2020
Messages
6,150
Reaction score
5,521
Credits
49,577
Now I'm a bit confused...

Me too. Alas, I'm out of ideas. My only ideas were links that I found searching.

Hmm... What else did you change yesterday? I don't suppose you thought to make a backup after it started working?
 
OP
Jay Lee

Jay Lee

New Member
Joined
Jul 29, 2020
Messages
29
Reaction score
10
Credits
275
I did change nothing, after I have done the instructions of the pipewire-manual.
Hm... maybe I should remove pulseaudio from my system?
 
OP
Jay Lee

Jay Lee

New Member
Joined
Jul 29, 2020
Messages
29
Reaction score
10
Credits
275
To come back to my problem...

After trying different things for a while now, I can summarize the following "facts":

  1. I didn't have any sound problems until March, then I was on a business trip for 3 weeks. After the (cumulative) Ubuntu updates that were then carried out, the sound "jerked" or "cracked".
  2. After some "sound problem" research, the only manual change I made was adding "tsched=0" to "default.pa" (but with no effect to the sound quality):

    nano /etc/pulse/default.pa => load-module module-udev-detect => load-module module-udev-detect tsched=0
  3. Then I installed "Pipewire" following this guide: https://linuxconfig.org/how-to-install-pipewire-on-ubuntu-linux =>
    this worked right after the installation, but after booting, "pulseaudio" was active again:
    p1.png.jpg
  4. Re-start "pulseaudio" with "killall pulseaudio" has no effect:
    p2.png.jpg
  5. Manually deactivating "Pulseaudio" and activating "Pipewire" delivers the following output in the terminal and a good soundquality again:
    p3.png.jpg

  6. Point 5 doesn't always seem to work. I will repeat procedure 5 again tomorrow.
 
OP
Jay Lee

Jay Lee

New Member
Joined
Jul 29, 2020
Messages
29
Reaction score
10
Credits
275
So... the day after...

p4.png.jpg

Again only Pulseaudio, no Pipewire.

Same procedure as yesterday...

p5.png.jpg


... but it failed.

Trying to enable pulseaudio again:

p6.png.jpg


Fail.

Trying to "kill" pulseaudio:

p7.png.jpg


Fail.

Yes, its german, but it just says: failure, error...

Funny side-effect: I can listen to mp3-music, using the "Strawberry" player... but I have zero sound from Firefox (no internet radio, no youtube... so I will restart my system yet)...
 
OP
Jay Lee

Jay Lee

New Member
Joined
Jul 29, 2020
Messages
29
Reaction score
10
Credits
275
After the restart... repeating the procedure from my post #16... the same results.
But instead of rebooting again... I did try:

p8.png.jpg

... the sound came back... and even, it is again "only" pulseaudio...

p9.png.jpg

... the sound is good yet... without "crackling" e.g.

o_O
 
OP
Jay Lee

Jay Lee

New Member
Joined
Jul 29, 2020
Messages
29
Reaction score
10
Credits
275
Next update:

No matter what I've done so far, after a "restart" the sound was always bad, with crackling and cracking.

Today I tried the following (and only) for the first time:
p10.png.jpg

And the sound was "nice" again.
However, I closed the terminal afterwards. To take the screenshot, I opened the terminal again and ran the command again.
...and then the sound was bad again.
Even further, multiple execution of the command has changed nothing, the sound remains the same (bad, crackling).

So I tried the following again:

pulse2.png.jpg


This time it even worked and I just got a good sound with "Pipewire":

p11.png.jpg


We'll just wait and see, what it looks like tomorrow...
 
OP
Jay Lee

Jay Lee

New Member
Joined
Jul 29, 2020
Messages
29
Reaction score
10
Credits
275
So I'm slowly going crazy with this sound topic...

Today, after switching on the PC and booting Ubuntu for the first time... the sound was perfect.

p12.png.jpg


Let's see how long he stays that way...
 
$100 Digital Ocean Credit
Get a free VM to test out Linux!

Members online


Latest posts

Top