Search results

  1. J

    [SOLVED] Changing refresh rate to 74.99 Hz causes black screen on login

    The problem was the HDMI cable. It appears theres some sort of bug in the latest 5.14.8 kernel that causes some issues with the latest ryzen chips (5700g in my case) and hdmi. I swapped the hdmi for a displayport cable and now everything works fine =)
  2. J

    [SOLVED] AMD 5700g screen flashes black for a second

    I fixed it! It was the HDMI cable. quite strange. I swapped it for a displayPort cable and now everything works fine. No more black screen flashing in mprime and i can set the resolution to 75 hz just fine. I had tried many different hdmi cables so it wasnt a broken cable. Appareantly...
  3. J

    [SOLVED] AMD 5700g screen flashes black for a second

    Maybe I should try installing the amdgpu-pro drivers? tho these perform worse ive heard.
  4. J

    [SOLVED] AMD 5700g screen flashes black for a second

    Already did that On Nix OS the equivalente is the following # Upadte microcode. hardware.cpu.amd.updateMicrocode = true; According to the documentatio, this does the following: Update the CPU microcode for AMD processors.
  5. J

    [SOLVED] AMD 5700g screen flashes black for a second

    Update. I got my hands on an AMD HD 7970 (very old) and ran mprime again. No screen flashing black now. And I can set the refresh rate to 75 hz no problem. I'm guessing it's a problem with the BIOS and these new Ryzen chips??? Or maybe there'll be better support with kernel 5.15?
  6. J

    [SOLVED] AMD 5700g screen flashes black for a second

    HERE: [[email protected]:~]$ lsb_release -rc Release: 21.05.3443.ee90403e147 Codename: okapi [[email protected]:~]$ uname -a Linux nixos 5.14.8 #1-NixOS SMP Sun Sep 26 12:10:25 UTC 2021 x86_64 GNU/Linux [[email protected]:~]$ lspci -nnv (only VGA compatible controller section) 0a:00.0 VGA compatible...
  7. J

    [SOLVED] AMD 5700g screen flashes black for a second

    I'm using Nix OS with kernel 5.14.8. and I'm loading the amdgpu drivers. I benchmarked the GPU and it's working fine. This problem isn't distro specific. I've tried arch and Ubuntu. Same problem. It's a desktop.
  8. J

    [SOLVED] AMD 5700g screen flashes black for a second

    Here you go [[email protected]:~]$ inxi -G Graphics: Message: No device data found. Display: x11 server: X.Org 1.20.11 driver: loaded: N/A resolution: 2560x1080~60Hz OpenGL: renderer: AMD RENOIR (DRM 3.42.0 5.14.8 LLVM 11.1.0) v: 4.6 Mesa 21.1.4
  9. J

    [SOLVED] AMD 5700g screen flashes black for a second

    I've been experiencing some CPU instability. (I think) Every once in a while my screen turns black for a second. I found out I can force this behaviour by running mprime. Firstly, mprime gets stuck at test 1 and shortly after the screen starts flashing black every 30 seconds or so. This...
  10. J

    [SOLVED] Changing refresh rate to 74.99 Hz causes black screen on login

    Nope. Im using the integrated vega graphics in the 5700g. the resolution is 2560x1080, nothing fancy. Besides, it can run at 75 hz. I can change the refresh rate to 74 hz and it runs fine. The problem happens once I try to login again with this refresh rate setting, I get a black screen...
  11. J

    [SOLVED] Changing refresh rate to 74.99 Hz causes black screen on login

    but I was running linux on my prev computer on this same monitor, same hdmi cable 75 hz. the monitor only has hdmi. its an LG ‎29WL500. on the website it says it support 75Hz and apparently has some sort of RADEON FreeSync technology.
  12. J

    [SOLVED] Changing refresh rate to 74.99 Hz causes black screen on login

    I think it's a kernel bug present in most distros. Anybody experiencing the same issue??
  13. J

    [SOLVED] Changing refresh rate to 74.99 Hz causes black screen on login

    I'm experiencing a weird problem with my new build. AMD Ryzen 5700G Fatal1ty B450 Gaming-ITX/ac (BIOS 4.60) Corsair vengeance CL16 3600 mhz PNY 500 GB NVME M.2 I've tried installing several distros: Pop OS Ubuntu Nix OS Manjaro I even tried with a different motherboard (gigabyte A520I AC)...
Top