Xubuntu Running on Asus - No sound from speakers, only headphones [solved with upgrade]

Discussion in 'Linux Audio / Video' started by Tweekville, May 5, 2014.

  1. Tweekville

    Tweekville New Member

    Messages:
    7
    Likes Received:
    0
    Trophy Points:
    1
    Hi,


    I just got a new laptop in the Asus K series. I've installed Xubuntu on it and the audio only works through the headphones even though pulse audio says it's playing. Prior to installing Xubuntu, I ran a OpenSuse, Debian and Backtrack live disks and none of them had sound either.

    Here are some outputs that might be helpful.
    lspci | grep Audio
    00:03.0 Audio device: Intel Corporation Device 0a0c (rev 09)
    00:1b.0 Audio device: Intel Corporation Lynx Point-LP HD Audio Controller (rev 04)

    cat /proc/asound/card1/codec* | grep Codec
    Codec: Realtek ID 233

    cat /proc/asound/card0/codec* | grep Codec
    Codec: Intel Haswell HDMI


    A few of the things that I've done are to reinstall pulse and alsa.
    I checked to see if alsa was muted.
    I added a few different lines to the /etc/modprobe.d/alsa-base.conf file.
    I've also played around with the settings in pulse.

    Any help would be much appreciated.
  2. GrumpyOldMan

    GrumpyOldMan Active Member

    Messages:
    136
    Likes Received:
    45
    Trophy Points:
    28
    You say it's new? Could it be that the speakers never got connected internally?
  3. Tweekville

    Tweekville New Member

    Messages:
    7
    Likes Received:
    0
    Trophy Points:
    1
    I'm not against opening it up, but I'd like to exhaust my other options first.
  4. ryanvade

    ryanvade Administrator Staff Member Staff Writer

    Messages:
    1,274
    Likes Received:
    431
    Trophy Points:
    83
    I think the audio is going to the HDMI out not the built in speakers. What is the output of:
    Code:
    lsmod | grep snd
    For example on my laptop Flash likes to send audio to the HDMI out and not the speakers. I use a ~/.asoundrc file.

    What is the output of this command also:
    Code:
    aplay -l
  5. Tweekville

    Tweekville New Member

    Messages:
    7
    Likes Received:
    0
    Trophy Points:
    1
    Thanks for getting back to me. Here are the outputs you asked for.

    Code:
     lsmod | grep snd
    snd_hda_codec_realtek    63829  0
    snd_hda_codec_hdmi    36143  1
    snd_seq_midi          13132  0
    snd_seq_midi_event    14475  1 snd_seq_midi
    snd_rawmidi            25114  1 snd_seq_midi
    snd_seq                51280  2 snd_seq_midi_event,snd_seq_midi
    snd_hda_intel          38307  3
    snd_hda_codec        117617  3 snd_hda_codec_realtek,snd_hda_codec_hdmi,snd_hda_intel
    snd_seq_device        14137  3 snd_seq,snd_rawmidi,snd_seq_midi
    snd_hwdep              13272  1 snd_hda_codec
    snd_pcm                80890  3 snd_hda_codec_hdmi,snd_hda_codec,snd_hda_intel
    snd_page_alloc        14230  2 snd_pcm,snd_hda_intel
    snd_timer              24411  2 snd_pcm,snd_seq
    snd                    56485  16 snd_hda_codec_realtek,snd_hwdep,snd_timer,snd_hda_codec_hdmi,snd_pcm,snd_seq,snd_rawmidi,snd_hda_codec,snd_hda_intel,snd_seq_device
    soundcore              12600  1 snd
    
    Code:
    $ aplay -l
    **** List of PLAYBACK Hardware Devices ****
    card 0: MID [HDA Intel MID], device 3: HDMI 0 [HDMI 0]
      Subdevices: 1/1
      Subdevice #0: subdevice #0
    card 1: PCH [HDA Intel PCH], device 0: HDA Generic [HDA Generic]
      Subdevices: 1/1
      Subdevice #0: subdevice #0
    
  6. GrumpyOldMan

    GrumpyOldMan Active Member

    Messages:
    136
    Likes Received:
    45
    Trophy Points:
    28
    If you think sound's going to hdmi interface, fire up alsamixer, and hit F6 - that will list sound cards, if there's two showing, and the hdmi is first, that's probably your problem. You can edit alsa.conf (probably in /usr/local/share/alsa) to make your sound defaults different. You'll need to change:

    defaults.ctl.card
    defaults.pcm.card

    There may be some other items to edit, but I'm not sure...
  7. Tweekville

    Tweekville New Member

    Messages:
    7
    Likes Received:
    0
    Trophy Points:
    1
    Hi, There are two cards and the hdmi is listed as device 0. I found the also.conf file, but there's quite alot there and I wasn't entirely sure what to change. If it will help, I can post the file.
  8. GrumpyOldMan

    GrumpyOldMan Active Member

    Messages:
    136
    Likes Received:
    45
    Trophy Points:
    28
    I don't think you need to post the file, they're quite a mess. Start by changing defaults.ctl.card to 1, and defaults.pcm.card to 1 also. Then reboot.
    ryanvade likes this.
  9. ryanvade

    ryanvade Administrator Staff Member Staff Writer

    Messages:
    1,274
    Likes Received:
    431
    Trophy Points:
    83
    Another option is a .asoundrc file in your home folder. For example:
    Code:
    pcm.!default {
        type hw
        card 1
        device 0
    }
    
    ctl.!default {
        type hw
        card 1
        device 0
    }
    
    would work for you.
  10. GrumpyOldMan

    GrumpyOldMan Active Member

    Messages:
    136
    Likes Received:
    45
    Trophy Points:
    28
    The advantage of this is that you don't need a restart - it gets loaded every time libasound gets opened by a program.
    ryanvade likes this.
  11. Tweekville

    Tweekville New Member

    Messages:
    7
    Likes Received:
    0
    Trophy Points:
    1
    Thank you guys for the responses. I'll try them out this evening and post the results back here.
  12. Tweekville

    Tweekville New Member

    Messages:
    7
    Likes Received:
    0
    Trophy Points:
    1
    Hello,

    Sorry I took so long getting back.

    So I changed both alsa.conf file and changed the

    defaults.ctl.card
    defaults.pcm.card

    from 0 to 1 and restarted.

    That didn't work so I then reverted the file and added the file .asoundrc to my home folder with the lines

    pcm.!default {
    type hw
    card 1
    device 0
    }

    ctl.!default {
    type hw
    card 1
    device 0
    }
    That didn't work either.

    I did notice that when I go into alsamixer the hdmi is set to default and if I change it, it will just change back when I exit and reopen alsamixer.

    I also came across a post on another forum that mentioned a mode = '*something*' setting that might need to be changed. Is that something anyone knows anything about?

  13. Tweekville

    Tweekville New Member

    Messages:
    7
    Likes Received:
    0
    Trophy Points:
    1
    Last night I upgraded to xubuntu 13.10 and that sorted out my sound issues. I'm not exactly sure what caused it, but I'd like to thank you guys for helping me out.

Share This Page