What setting to tweak to prevent Flash from crashing Firefox?

Discussion in 'Desktop / X' started by bloggeroo, Mar 1, 2012.

  1. bloggeroo

    bloggeroo New Member

    Messages:
    2
    Likes Received:
    0
    Trophy Points:
    0
    What Ubuntu setting do I need to tweak to prevent Flash from crashing Firefox? Or what do I need to do so I won't have to reboot my computer.


    My browser crashes everyday and I usually reboot to recover from what I was doing. Before, when playing Flash-based games on Facebook, my browser would crash first then on reboot, I could continue. But now, just opening a site using Flash would cause my browser to crash.
  2. Akendo

    Akendo New Member

    Messages:
    136
    Likes Received:
    7
    Trophy Points:
    0
    Do you have the Flash from Adobe installed? This sounds more like a Gnash. Normally is flash "quite" stable. Make sure you have the last version of FF/Flash.

    Try to update your system.
    Else we may need some info, like: Version of FF, Flashl, Ubuntu.

    so far
    Akendo
  3. bloggeroo

    bloggeroo New Member

    Messages:
    2
    Likes Received:
    0
    Trophy Points:
    0
    By Gnash, I presume you mean the Flash player that came with Ubuntu 11.04 together with Firefox 10.

    Anyway, I'm downloading the Flash Player from Adobe.com and try to see if that will solve the problem.
  4. DarthVader3257

    DarthVader3257 New Member

    Messages:
    45
    Likes Received:
    2
    Trophy Points:
    0
    I wasn't aware that Flash can cause crashing within Firefox on Linux. I would suggest a more stable version of Firefox, or if not, try downloading another browser. Flash is pretty big for internet users. Good luck with that.
  5. Victor Leigh

    Victor Leigh Member

    Messages:
    209
    Likes Received:
    8
    Trophy Points:
    18
    I had a problem with my Firefox hanging up on me before. Then I found that the problem was incompatibility with my graphics driver. Perhaps you can try updating your graphics driver and see whether the problem goes away.
  6. goodselfme

    goodselfme New Member

    Messages:
    11
    Likes Received:
    0
    Trophy Points:
    0
    Could this problem occur by not clearing the history? I ask since I had a similar event and then recalled I did not clean out my computer history for months.
  7. Akendo

    Akendo New Member

    Messages:
    136
    Likes Received:
    7
    Trophy Points:
    0
    That shouldn't be the problem. Flash has no access to your history. It has a own one. You can try to start Firefox via the terminal and wait till you come to the problem. It will print out to the sterr all problem that appear. So don't worry when you may see a lot in the begin. But FF is working fine. The Gcard Driver is more likely. What GCard driver do you use?

    so far
    akendo
  8. goodselfme

    goodselfme New Member

    Messages:
    11
    Likes Received:
    0
    Trophy Points:
    0
    Thank you for clearing that up for me. I won't pay it any attention next time.I appreciate you.
  9. Stefano Messicano

    Stefano Messicano New Member

    Messages:
    88
    Likes Received:
    1
    Trophy Points:
    0
    This allows Firefox to automatically prefetch (load) the contents of pages linked to by the page you are viewing e.g. this site uses prefetch to load the TechLogon homepage in the background, making it quicker for you to view next if you want to To take advantage of increased speed browsing websites which use prefetch, keep this setting at the Default which is True.

Share This Page