w3af error (can install anything)

Discussion in 'Command Line' started by woreek, Oct 7, 2013.

  1. woreek

    woreek New Member

    Messages:
    5
    Likes Received:
    1
    Trophy Points:
    1
    Hi guys, I need your help or I will have to delete a beautiful distribution (BackTrack).


    At first sorry for my english (I am Slovak).

    A few days ago I decided try Linux finally. After few problems (mostly with booting) everything is going good. BUT.. after I start working with this linux (fund some guide on internet about updating and soever) I tried to update system. First was update then upgrade and then pop up 2 errors (first fixed immediately) but second is some error called "w3af". I tried many guides founded on internet which should fix it but any of them works. So now I am looking for some help here. I will post here also a picture of that error.

    Linux BackTrack 5 R3

    root@bt:~# apt-get upgrade
    Reading package lists... Done
    Building dependency tree
    Reading state information... Done
    0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
    1 not fully installed or removed.
    After this operation, 0B of additional disk space will be used.
    Do you want to continue [Y/n]? y
    Setting up w3af (1.2-bt2) ...
    tar: pybloomfiltermmap-0.2.0.tar.gz: Cannot open: No such file or directory
    tar: Error is not recoverable: exiting now
    tar: Child returned status 2
    tar: Exiting with failure status due to previous errors
    /var/lib/dpkg/info/w3af.postinst: line 4: cd: pybloomfiltermmap-0.2.0: No such file or directory
    python: can't open file 'setup.py': [Errno 2] No such file or directory
    svn: Repository moved permanently to 'https://svn.code.sf.net/p/w3af/code/trunk'; please relocate
    dpkg: error processing w3af (--configure):
    subprocess installed post-installation script returned error exit status 1
    Errors were encountered while processing:
    w3af
    E: Sub-process /usr/bin/dpkg returned an error code (1)
  2. woreek

    woreek New Member

    Messages:
    5
    Likes Received:
    1
    Trophy Points:
    1
    I almost forget.. because of this error I am not able to install absolutely anything (any program any update )
  3. arochester

    arochester Active Member

    Messages:
    620
    Likes Received:
    193
    Trophy Points:
    43
    1) Backtrack has been replaced by Kali Linux http://distrowatch.com/table.php?distribution=kali

    2) Backtrack is based on Ubuntu. Ubuntu uses sudo and not Root. From your normal account (not Root) in a Terminal try:
    sudo apt-get update
    sudo apt-get upgrade
    sudo apt-get dist-upgrade

    What happens?
    DevynCJohnson likes this.
  4. woreek

    woreek New Member

    Messages:
    5
    Likes Received:
    1
    Trophy Points:
    1
    still the same
  5. arochester

    arochester Active Member

    Messages:
    620
    Likes Received:
    193
    Trophy Points:
    43
  6. woreek

    woreek New Member

    Messages:
    5
    Likes Received:
    1
    Trophy Points:
    1
    thx you man, this finaly help me ;) now I have just a little tiny problem... I installed vlc program for movies and it doesnt play any file or even doesnt start itself :/

    do you know help me with this?
  7. arochester

    arochester Active Member

    Messages:
    620
    Likes Received:
    193
    Trophy Points:
    43
  8. babylon88

    babylon88 New Member

    Messages:
    5
    Likes Received:
    0
    Trophy Points:
    1
    I'm having the same problem when i go to that location shown in on the othere site you suggested i cant find the url to change please help


    this is what my script says



    Code:
    #!/bin/sh -e
    #
    
    case "$1" in
      configure)
      update-alternatives --quiet --install /usr/bin/pager pager \
      /usr/bin/w3m 25 \
        --slave /usr/share/man/man1/pager.1.gz pager.1.gz \
        /usr/share/man/man1/w3m.1.gz
      update-alternatives --quiet --install /usr/bin/ \
      /usr/bin/w3m 25 \
        --slave /usr/share/man/man1/ \
        /usr/share/man/man1/w3m.1.gz
      # upgrade old config file to new config file
      if test -e /etc/w3m/w3mconfig; then
        mv -f /etc/w3m/w3mconfig /etc/w3m/w3mconfig.dpkg-tmp
        tmp=$(tempfile -p w3m.subst.)
        trap "rm -f $tmp" 0
        while read opt val
        do
        val0=$(sed -ne 's/^'$opt'[[:space:]]*//p' /etc/w3m/w3mconfig.dpkg-tmp)
        if [ "$val0" != "" ] && [ "$val" != "$val0" ]; then
          echo 's/^'$opt'[[:space:]]*.*/'$opt' '$val0'/' >> $tmp
        fi
        done < /etc/w3m/config
        if test -s $tmp; then
        mv -f /etc/w3m/config /etc/w3m/config.dpkg-tmp
        sed -f $tmp /etc/w3m/config.dpkg-tmp > /etc/w3m/config
        rm -f $tmp
        rm -f /etc/w3m/config.dpkg-tmp
        fi
        rm -f /etc/w3m/w3mconfig /etc/w3m/w3mconfig.dpkg-tmp
      fi
      ;;
      *)
    esac
    
    # Automatically added by dh_installmenu
    if [ "$1" = "configure" ] && [ -x "`which update-menus 2>/dev/null`" ]; then
       update-menus
    fi
    # End automatically added section
    # Automatically added by dh_installmime
    if [ "$1" = "configure" ] && [ -x "`which update-mime 2>/dev/null`" ]; then
       update-mime
    fi
    # End automatically added section
    
  9. babylon88

    babylon88 New Member

    Messages:
    5
    Likes Received:
    0
    Trophy Points:
    1
    i had to delete 3 wuuw - browser.1.gz to post the script
  10. DevynCJohnson

    DevynCJohnson Super Moderator Staff Member Staff Writer

    Messages:
    973
    Likes Received:
    857
    Trophy Points:
    93
    Remember to put code inside of tags using the "Code" button. Thanks.
    Haider92 likes this.
  11. babylon88

    babylon88 New Member

    Messages:
    5
    Likes Received:
    0
    Trophy Points:
    1
    I worked out what I was doing wrong there are 2 files with the same name
  12. woreek

    woreek New Member

    Messages:
    5
    Likes Received:
    1
    Trophy Points:
    1
    well, I was not able to play movies with vlc but other program played them succesfuly so my problems are solved :) thx for help to arochester... but after solving my problems I find out that Backtrack is actualy out of date :D I didnt know that earlier because they change his name to Kali so all my work was useless because now Im gonna reinstall it to Kali :D
    DevynCJohnson likes this.
  13. babylon88

    babylon88 New Member

    Messages:
    5
    Likes Received:
    0
    Trophy Points:
    1
    erable: exiting now
    tar: Child returned status 2
    tar: Exiting with failure status due to previous errors
    /var/lib/dpkg/info/w3af.postinst: line 4: cd: pybloomfiltermmap-0.2.0: No such file or directory
    python: can't open file 'setup.py': [Errno 2] No such file or directory
    svn: Working copy 'w3af' locked
    svn: run 'svn cleanup' to remove locks (type 'svn help cleanup' for details)
    dpkg: error processing w3af (--configure):
    subprocess installed post-installation script returned error exit status 1
    Errors were encountered while processing:
    w3af
    E: Sub-process /usr/bin/dpkg returned an error code (1)
    Code:
    erable: exiting now
    tar: Child returned status 2
    tar: Exiting with failure status due to previous errors
    /var/lib/dpkg/info/w3af.postinst: line 4: cd: pybloomfiltermmap-0.2.0: No such file or directory
    python: can't open file 'setup.py': [Errno 2] No such file or directory
    svn: Working copy 'w3af' locked
    svn: run 'svn cleanup' to remove locks (type 'svn help cleanup' for details)
    dpkg: error processing w3af (--configure):
    subprocess installed post-installation script returned error exit status 1
    Errors were encountered while processing:
    w3af
    E: Sub-process /usr/bin/dpkg returned an error code (1)
    
    is the error i'm getting please help
  14. DevynCJohnson

    DevynCJohnson Super Moderator Staff Member Staff Writer

    Messages:
    973
    Likes Received:
    857
    Trophy Points:
    93
    Ask your question in a new thread for maximum help. Plus, it is against this forums rules to "hijack" a thread:eek:.
    Haider92 likes this.
  15. lobo

    lobo Active Member

    Messages:
    134
    Likes Received:
    81
    Trophy Points:
    28
    DevynCJohnson likes this.
  16. babylon88

    babylon88 New Member

    Messages:
    5
    Likes Received:
    0
    Trophy Points:
    1
    after running upgrade and getting w3af installed i get this message when trying to run w3af gui please help im running backtrack 5r3 gnome
    its updated to the latest
    Code:
    You're using a very old, outdated and buggy version of the w3af framework. Please follow these links to get the latest:
    
    with to website address 

Share This Page