Strange issue with access rights - "Permission denied" and own folder

Discussion in 'Web Server' started by maundma, Feb 17, 2013.

  1. maundma

    maundma New Member

    Messages:
    1
    Likes Received:
    0
    Trophy Points:
    0
    Hi,
    I am trying to use a MyBook-Live NAS-Drive as a Web-Server. I did manage to do this and it works fine. However, I would now like to shift the content directory from /var/www/ to one of the shares under /shares/...

    And this is where the problems start. For some reason, the apache user www-data doesn't have access to the target folder even though the attributes for the folder seem to be right (rwxrwxr-x). I tried also using rwxrwxrwx and even tryed to chown chgrp the folder to the www-data user. No matter what I try I get the same result.


    Code:
    MyBookLive:/shares# su www-data
    MyBookLive:/shares# ls -l
    total 256
    drwxrwxrwx 3 www-data www-data 65536 Feb 16 18:39 4Webserver
    drwxrwxrwx 9 root share 65536 Nov  4  2011 Public
    MyBookLive:/shares# su www-data
    MyBookLive:/shares$ cd 4Webserver/
    sh: **cd: 4Webserver/: Permission denied**
    I am running out of ideas what may be the reason for this. What other control mechanism can block the access to the 4Webserber directory???

Share This Page