SSH - connection closes as soon as I log in

Discussion in 'Linux Networking' started by brick2, Feb 28, 2014.

  1. brick2

    brick2 New Member

    Messages:
    19
    Likes Received:
    2
    Trophy Points:
    3
    I got a Cygwin ssh on a windows 8 machine and am using fedora 20 KDE on my machine.
    After encountering several problems with ssh on a windows machine I finally got it to accept the log in, but as soon as I log in the connection closes.
    Could anybody shed some light on this, been trying to get it to work for about two days.


    Thank you all for your time.
  2. MikeyD

    MikeyD Active Member

    Messages:
    219
    Likes Received:
    105
    Trophy Points:
    43
    To help we'll probably need a lot more information:

    1.) Are you trying to connect TO the Win 8 machine? Or ssh from there to the Fedora machine?

    2.) How did you install the sshd (daemon)? Is there a guide you followed?

    3.) Is there an error or a message you get when it disconnects you? Something like "Connection closed by foreign host"?

    I'll assume you're trying to run the sshd on Win8 and connect to that OS remotely. The most likely reasons would be either a.) no user account is set up for incoming ssh requests to use or b.) "ntsec" isn't set to the CYGWIN environment variable to allow NT authentication.

    These are just guesses, but are two common mistakes when setting up sshd on Windows. The guides below address these issues.

    Here are a couple tutorials on setting up sshd for hosting ssh connections via Windows:
    http://cygwin.wikia.com/wiki/Sshd

    Two in-depth Oracle guides:
    http://docs.oracle.com/cd/E24628_01/install.121/e22624/preinstall_req_cygwin_ssh.htm
    http://docs.oracle.com/cd/E18930_01/html/821-2426/gksiy.html
  3. brick2

    brick2 New Member

    Messages:
    19
    Likes Received:
    2
    Trophy Points:
    3
    I am trying to log into my windows machine from fedora machine.

    I did follow a guide on the net it seamed pretty straight forward.
    Link is in the next thread due to forum rules.

    No there are not error messages just:
    connection to host 192.168.0.3 closed

    The two computers are in lan on the same switch.

    The user has been set up ad it prompts me for password i give it it takes it and logs me in and than logs me out.

    Now I have tried with COPSSH same story. As far as I can see the user is set up, as I mentioned before I do log in it just logs me out straight away.

    I came to suspect that it has something to do with the windows firewall so I shut it down, nothing....

    Ok just out of curiosity I tried to tenet from one windows machine to another does not work either.

    I ve been at it for a while now, anything that anyone can suggest, anythigng at all, cuz I am running out of ideas, it is times like these that I remember why I switched from this cra$ called windows, never had such problems on linux it is like 10000000000 simpler to set up remote control and file exchange.

    Thx guys for all your time and effort.
  4. brick2

    brick2 New Member

    Messages:
    19
    Likes Received:
    2
    Trophy Points:
    3
    One more thing I can connect from windows to linux via putty no problems.

Share This Page