Second monitor only has black screen, Mint 17 KDE

Discussion in 'Desktop / X' started by CoLA, Jul 13, 2014.

  1. CoLA

    CoLA New Member

    Messages:
    6
    Likes Received:
    1
    Trophy Points:
    3
    I was trying out the KDE version of Mint 17 and found that my second monitor is always just a black screen with no background. I can move windows over to it but only the primary monitor shows the desktop background.

    Is there a way to fix this?

  2. pane-free

    pane-free Active Member

    Messages:
    357
    Likes Received:
    83
    Trophy Points:
    28
    It appears to be a bug in ubuntu (#160226) and compiz. Why not use the XFCE version? Not pretty enough?

    Welcome, CoLA!
  3. CoLA

    CoLA New Member

    Messages:
    6
    Likes Received:
    1
    Trophy Points:
    3
    I need my pretty effects! :D

    Must just be the KDE version, both monitors look fine in the Cinnamon flavor. I might just stick with that but it would be nice for this to work with the other one.
  4. JasKinasis

    JasKinasis Member

    Messages:
    69
    Likes Received:
    33
    Trophy Points:
    18
    I'm not sure that bug from 2007 is responsible.
    AFAIK KDE doesn't use compiz, but I could be wrong!

    @CoLA: I'm not a Mint user, so I couldn't give a definitive answer. But I am using Kubuntu ATM with no problems using multiple monitors.

    What happens when you go into the Display and Monitor page of the KDE Settings?
    From the main menu: Settings->System Settings->Display and Monitor.

    From there you should be able to see all monitors that are connected to your machine and set up the resolution, orientation etc of each monitor.
    That should hopefully solve your problem!

    Another idea:
    Is the 2nd monitor permanently connected to your machine? Or are you hot-plugging it after startup?
    When plugging a 2nd monitor/projector into my KDE laptop when my laptop is already running, sometimes I've noticed that a restart of X is required in order to get the 2nd monitor to work under KDE. This might be the issue you are encountering!
    There are a number of ways to restart X. The simplest is probably just to log out and log back in again!

    Otherwise, what graphics card are you running on your machine? Does it require proprietary drivers?
    If you are unable to get the monitor working from the KDE settings, and/or restarting X doesn't help, it could be a GFX driver bug... Other than that it could be a bug with Mint KDE. Again, I'm not a Mint user, so I can't give a definitive answer!
    Last edited: Jul 16, 2014

Share This Page