Screen not fitting in Gentoo

Discussion in 'General Linux' started by Kryyll, Jun 5, 2014.

  1. Kryyll

    Kryyll Active Member

    Joined:
    Dec 9, 2013
    Messages:
    112
    Likes Received:
    38
    I just installed a fresh copy of Gentoo on my desktop; however both the terminal and Xorg won't fit the screen. For example, imagine two boxes, one bigger and one smaller, the inner box is the terminal (or Xorg) and the outer box is just black. I tried changing the screen resolution in my boot loader but that just made the text smaller and more crisp looking. Obviously it has something to do with my graphics card (which is a Nvidia one). I installed the Nvidia driver (nouveau) but no dice. Any ideas?


    PS: The screen fit perfectly on my Manjaro system but doesn't fit with the Gentoo install drive. I also played with the screen settings on the screen itself.
     
  2. Kryyll

    Kryyll Active Member

    Joined:
    Dec 9, 2013
    Messages:
    112
    Likes Received:
    38
    Best Answer
    Victory! I found the source of the problem. Looks like I forgot to select the Nvidia drivers when I compile my kernel. I simply edited the menuconfig and recompile the kernel. I rebooted and the screen was too wide. However, that was easily fixed by adjusting the screen settings on the monitor. Thanks for the help!
     
    DevynCJohnson likes this.
  3. arochester

    arochester Super Moderator Staff Member

    Joined:
    Nov 23, 2012
    Messages:
    1,130
    Likes Received:
    372
  4. Eric Wang

    Eric Wang New Member

    Joined:
    Jun 6, 2014
    Messages:
    4
    Likes Received:
    2
    You can go to its homepage check
     
  5. Kryyll

    Kryyll Active Member

    Joined:
    Dec 9, 2013
    Messages:
    112
    Likes Received:
    38
    Eh, seems as though that file isn't even there. In fact, I have an X11 directory but thats all, no xorg.conf.d. I'll keep playing with it to see if I can get it
     
  6. Kryyll

    Kryyll Active Member

    Joined:
    Dec 9, 2013
    Messages:
    112
    Likes Received:
    38
    Best Answer
    Victory! I found the source of the problem. Looks like I forgot to select the Nvidia drivers when I compile my kernel. I simply edited the menuconfig and recompile the kernel. I rebooted and the screen was too wide. However, that was easily fixed by adjusting the screen settings on the monitor. Thanks for the help!
     
    DevynCJohnson likes this.

Share This Page