Screen goes black but computer not off

Discussion in 'General Linux' started by URDRWHO, Jun 25, 2014.

  1. URDRWHO

    URDRWHO Member

    Messages:
    94
    Likes Received:
    6
    Trophy Points:
    8
    This started a few days ago. I'll have the computer running, streaming some online radio, firefox is open, I leave the computer for a while, return and the screen is dark. Radio still streaming.
    None of the Ctrl-alt-del (F keys) will bring the screen back on and I need to do a hard re-boot.

    This is separate but could be part of the issue because it also just started happening ---

    I also noticed that Ctrl-alt-del no longer changed the desktop effects but shut off the screen. Ctrl-alt-F7 will bring it back. The same thing has happened to my wife's Acer

    Here is some I-Nex info about my laptop.

    Hm? I could swear that I had updated to
    Kubuntu 14.04 LTS

    NVIDIA Corporation NV17M [GeForce4 440 Go 64M]
    Total Memory prefetchable: 16M -
    Total Memory non-prefetchable: 128M - 512K -
    OpenGL Vendor: VMware, Inc.
    OpenGL Renderer: Gallium 0.4 on llvmpipe (LLVM 3.4, 128 bits)
    OpenGL Version: 3.0 Mesa 10.2.0-devel
    Server glx vendor: SGI
    Server glx version: 1.4
    Client glx vendor: Mesa Project and SGI
    Client glx version: 1.4
    GLX version: 1.4
    Present resolution: 1280x800 pixels (338x211 millimeters)
    minimum 320 x 200, current 1280 x 800, maximum 4096 x 4096



    =========================================================================================================================
    ___________________Board___________________
    Board Vendor: Compal
    Board Version: 32.42
    Board Name: 08A0
    Board Asset Tag:
    ___________________Bios____________________
    Bios Vendor: Hewlett-Packard
    Bios Version: F.35
    Bios Date: 04/28/2005
    _________________Chassis__________________
    Chassis Vendor: Compal
    Chassis Version:
    Chassis Type: 10
    Product Version: F.35
    _________________Product__________________


    =========================================================================================================================
    Distro Vendor: Ubuntu
    Distro Release: 14.04
    Desktop environment: KDE 4.13.2
    Window manager: KWin
    Window manager Theme: Aurorae
    GTK+ 2 Theme: oxygen-gtk
    GTK+ 3 Theme: Default
    GTK Icons: oxygen
    GTK Font: Ubuntu Regular
    Hostname: john-Pavilion-zv5200-PR465UA-ABA
    Deafult DM: /usr/sbin/lightdm
    Timezone: America/New_York
    GLX Version: 1.4
    X.Org Version: 1.15.1
    Wireless-tools: 30
    PPP: 2.4.5
    Net-tools: 1.60
    Arch: x86_64
    Binutils 2.24
    GCC Version: 4.8
    Linux C Library: 2.19
    GNU Make Version: 3.81
    Dynamic linker (ldd): 2.19


    =================================================== Machine =============================================================
    Machine: x86_64
    System name: Linux
    Nodename: john-Pavilion-zv5200-PR465UA-ABA
    Release: 3.13.0-30-generic
    Version: #54-Ubuntu SMP Mon Jun 9 22:45:01 UTC 2014
  2. URDRWHO

    URDRWHO Member

    Messages:
    94
    Likes Received:
    6
    Trophy Points:
    8
    I've turned off any energy screen settings and the screen will stay on full time. I'll see if there are any problems with the energy saving box unchecked.
  3. Yesyesloud

    Yesyesloud Active Member

    Messages:
    259
    Likes Received:
    128
    Trophy Points:
    43
    Screen blanking support seems buggy on your system, you could try switching video drivers to see which works better.
  4. URDRWHO

    URDRWHO Member

    Messages:
    94
    Likes Received:
    6
    Trophy Points:
    8
    I've thought of that but I am afraid to change drivers. When I have the driver management window, it doesn't find a video driver for me. Plus when I first installed Kubuntu I tried a Nvidia driver and couldn't get back into Kubuntu (if I remember).

    There is a box to check-mark that is current un-checked. Using non-free firmware for Linux kernal drivers from the Linux firmware non-free. Not sure what will happen if I check the box?

    Last night I made changes. I've added screen saver (activated at 1 minute) and have screen energy saver marked to start. The spacebar brings the computer back on and so does the mouse. I'll see how it works today.

  5. rstanley

    rstanley Member

    Messages:
    73
    Likes Received:
    43
    Trophy Points:
    18
    I would also go into the BIOS setup to see if there are any power settings there that can be adjusted or turned off.
  6. URDRWHO

    URDRWHO Member

    Messages:
    94
    Likes Received:
    6
    Trophy Points:
    8
    I may go there but I know that it all works fine in XP. On this HP there are not a lot of options in the BIO. It is (if I remember) a Phoenix BIOS.

    For now with the set-up I made last evening, everything is working as expected. The mouse, space bar, etc. wakes up the screen.

  7. Yesyesloud

    Yesyesloud Active Member

    Messages:
    259
    Likes Received:
    128
    Trophy Points:
    43
    If the screen blanks out, bios does not take part in this problem. Evidence points towards a driver issue. *buntus offer GUI options to load different drivers easily, although they also ease the process through command line.

    If you know how to delete your xorg.conf for default video configuration to take place (also unblacklist any module if needed), you may not worry that much about loading different drivers. Otherwise... Just go with the solution that feels more comfortable to you.
  8. URDRWHO

    URDRWHO Member

    Messages:
    94
    Likes Received:
    6
    Trophy Points:
    8
    I think you and I worked out a broadcom Wifi issue one time?

    My fix seemed to work but I came back about an hour ago and the computer screen would not wake up.

    I looked in the user/X11 folder and can't find an Xorg.config file.

    I'm going to leave the screen on all the time and see if it goes blank.



  9. ryanvade

    ryanvade Administrator Staff Member Staff Writer

    Messages:
    1,260
    Likes Received:
    428
    Trophy Points:
    83
  10. URDRWHO

    URDRWHO Member

    Messages:
    94
    Likes Received:
    6
    Trophy Points:
    8
    Hm? Is it true? "This is a bug in polkit in 14.04. As a workaround, you can"

    I found this in some of the links in the link you gave me. What do I do with it? DO I just open up the terminal and past this?

    They changed the suspend and hibernate rules to be under login1.

    Try the following:

    # cat /etc/polkit-1/localauthority/90-mandatory.d/disable-suspend.pkla
    [Disable suspend by default]
    Identity=unix-user:*
    Action=org.freedesktop.login1.suspend
    ResultActive=no

    [Disable suspend for all sessions]
    Identity=unix-user:*
    Action=org.freedesktop.login1.suspend-multiple-sessions
    ResultActive=no



  11. Yesyesloud

    Yesyesloud Active Member

    Messages:
    259
    Likes Received:
    128
    Trophy Points:
    43
    Screen blanking is different from system suspend and hibernate. Since you could still listen to music after the display powered off on its own, the system was not sleeping or hibernating, but screen blanking.

    There is no xorg.conf because foss drivers are loaded, probably by default if you didn't change anything. Try to load a proprietary nvidia driver. I guess you can do it on some tab of the update center, if I remember well. If the driver doesn't work and all you get is the CLI, delete xorg.conf and unblacklist any foss nvidia module.
  12. URDRWHO

    URDRWHO Member

    Messages:
    94
    Likes Received:
    6
    Trophy Points:
    8
    There are Nvidia drivers in the Package Manager. The question would be which one to use?

    There are Nvidia drivers in the Package Manager. The question would be which one to use?

    I found a site and invoked the commands, all went well without any error messages.

    Then I went to comments and people are having problems after re-starting. Now I'm afraid to re-start the computer.

    After the install this is the current setting but I have not rebooted.

    lspci -k | grep -iA2 vga
    01:00.0 VGA compatible controller: NVIDIA Corporation NV17M [GeForce4 440 Go 64M] (rev a3)
    Subsystem: Hewlett-Packard Company Device 006d
    Kernel driver in use: nouveau

    This is the site...............

    Oops I can't post links ---

    The site is howopensource

    Install NVIDIA GeForce driver in Ubuntu 14.04

  13. unixfish

    unixfish Member

    Messages:
    41
    Likes Received:
    23
    Trophy Points:
    8
    I have intermittently had the same issue; it seemed to come and go with versions of Ubuntu. I set my screen to not shut off in the power options, and I've had no problems since. It was happening again in 14.04.

    I have vanilla Intel video on a Dell D630. I thought for the longest time it was a hardware issue, but a lot of Google searches later, I just disabled screen shutoff and this resolved the issue.

    Yeah, it's a bit of a pain - I've had my 8 year old battery overheat recently, so I'm always cautious about leaving my system running unattended - and the screen always on just makes me a bit more paranoid. On a newer machine, or if I just replaced the battery, I would not be concerned.
  14. URDRWHO

    URDRWHO Member

    Messages:
    94
    Likes Received:
    6
    Trophy Points:
    8
    My laptop is always on AC these days so I don't worry about the battery issue. I don't like keeping the screen lit 24/7.

    So the problem comes and goes from build to build is odd.

    I just installed the Nvidia driver and wow it is an ugly screen resolution situation, everything is a bit hazy. Plus the best screen resolution I can get is 1024 X 768.

    In the Nvidia Server app there is minimal settings.

    Now I am wondering if I can get back to Neuvou using this --
    sudo apt-get remove --purge nvidia*

    Package manager show that nouveau firmware for Nvidia is still installed. When nouveau was the driver I could choose a higher resolution than 1024 X 768.

    Some things don't look very bad but other things look terrible.

    Last edited: Jun 27, 2014
  15. Yesyesloud

    Yesyesloud Active Member

    Messages:
    259
    Likes Received:
    128
    Trophy Points:
    43
    I know how you feel. Even thought it's possible to add new screen modes with xrandr, I had terrible issues enabling custom resolutions for quite a few legacy nvidia devices, tweaking absolutely all possible settings, from kernel to user space.

    Maybe you are lucky with your system though, as I have also been with a number of other nvidia gpus.

    First advice: test display blanking capabilities with the current driver and if it's working ok (screen turning back on after blanking out), make your way to new monitor resolutions through xrandr directly or ubuntu options.

    Second: as I said previously, if you want to reload nouveau, unblacklist it (generally from /etc/modprobe.d/blacklist file but could be in another depending on distro), then remove xorg.conf and be sure nouveau is properly installed. Also, you can use the gui options ubuntu and its derivatives offer to automate this process (picking nouveau/foss drivers on the Update center, usually).
    Last edited: Jun 28, 2014
  16. URDRWHO

    URDRWHO Member

    Messages:
    94
    Likes Received:
    6
    Trophy Points:
    8
    So an update.

    This morning I installed Nvidia drivers and didn't like the look. Purged all Nvidia stuff.

    Did a reinstall libgl1-mesa-dri libdrm2 libdrm-nouveau2 xserver-xorg-core

    Rebooted and now nouveau is back and things look fine. I am using a screen saver that isn't a blank screen.

    So far no blank screen lock up.

    I did an apt-get update apt-get upgrade and I see it wants to upgrade -
    libgbm1 libgl1-mesa-dri libopenvg1-mesa libxatracker2

    I'm not going to upgrade and see how things go for a few days. If no freezing, I'll upgrade and see how the upgrade goes.
  17. Yesyesloud

    Yesyesloud Active Member

    Messages:
    259
    Likes Received:
    128
    Trophy Points:
    43
    If you happen to come across this problem once more, try installing proprietary nvidia drivers again but setting up optimal resolution so that things will look ok. I am not sure if any of those libraries have effect over screen blanking, but it won't harm leaving them outdated for a good while, I guess.
  18. URDRWHO

    URDRWHO Member

    Messages:
    94
    Likes Received:
    6
    Trophy Points:
    8
    Today is the 5th day since adding proprietary drivers, then removing them to go back to nouveau and used the command reinstall libgl1-mesa-dri libdrm2 libdrm-nouveau2 xserver-xorg-core.

    I've completed updates and still no blank screen freezing problems.
  19. URDRWHO

    URDRWHO Member

    Messages:
    94
    Likes Received:
    6
    Trophy Points:
    8
    It has been 3 weeks and no problems. I feel that completing the reinstall libgl1-mesa-dri libdrm2 libdrm-nouveau2 xserver-xorg-core fixed the problem.
  20. URDRWHO

    URDRWHO Member

    Messages:
    94
    Likes Received:
    6
    Trophy Points:
    8
    Today 7/25/2014 -- It is back

    How odd because it is exactly a month since I first posted the problem. It went away after the fix but upon an update it came back.

    I came to the computer this morning and it was froze solid, had to reboot.

    I am set to do daily updates and it updates in the morning. So I am going to try and see what I updated yesterday on 7/24/2014.

    I updated this morning but no mesa stuff updated which --- I suspect as before that they are the problem.

    I like to keep updated but I am thinking of backing off on the daily updates or trying to set the system to only update security issues.

    /var/log/apt/

    Start-Date: 2014-07-24 07:56:43
    Upgrade: libegl1-mesa:amd64 (10.3.0~git20140721.01c21c45-0ubuntu0sarvatt~trusty, 10.3.0~git20140723.fb237ba7-0ubuntu0sarvatt~trusty), libopenvg1-mesa:amd64 (10.3.0~git20140721.01c21c45-0ubuntu0sarvatt~trusty, 10.3.0~git20140723.fb237ba7-0ubuntu0sarvatt~trusty), libegl1-mesa-drivers:amd64 (10.3.0~git20140721.01c21c45-0ubuntu0sarvatt~trusty, 10.3.0~git20140723.fb237ba7-0ubuntu0sarvatt~trusty), libgl1-mesa-dri:amd64 (10.3.0~git20140721.01c21c45-0ubuntu0sarvatt~trusty, 10.3.0~git20140723.fb237ba7-0ubuntu0sarvatt~trusty), libglapi-mesa:amd64 (10.3.0~git20140721.01c21c45-0ubuntu0sarvatt~trusty, 10.3.0~git20140723.fb237ba7-0ubuntu0sarvatt~trusty), libgles2-mesa:amd64 (10.3.0~git20140721.01c21c45-0ubuntu0sarvatt~trusty, 10.3.0~git20140723.fb237ba7-0ubuntu0sarvatt~trusty), libgl1-mesa-glx:amd64 (10.3.0~git20140721.01c21c45-0ubuntu0sarvatt~trusty, 10.3.0~git20140723.fb237ba7-0ubuntu0sarvatt~trusty), libxatracker2:amd64 (10.3.0~git20140721.01c21c45-0ubuntu0sarvatt~trusty, 10.3.0~git20140723.fb237ba7-
    0ubuntu0sarvatt~trusty), libwayland-egl1-mesa:amd64 (10.3.0~git20140721.01c21c45-0ubuntu0sarvatt~trusty, 10.3.0~git20140723.fb237ba7-0ubuntu0sarvatt~trusty), libgbm1:amd64 (10.3.0~git20140721.01c21c45-0ubuntu0sarvatt~trusty, 10.3.0~git20140723.fb237ba7-0ubuntu0sarvatt~trusty)
    Last edited: Jul 25, 2014

Share This Page