Problems with sendmail

Discussion in 'Mail Server' started by laurentv, Aug 14, 2013.

  1. laurentv

    laurentv Member

    Messages:
    30
    Likes Received:
    2
    Trophy Points:
    8
    Hello,

    I have several messages in my log
    No MAIL/EXPN/VRFY/ETRN during connection to MTA

    Can not find a solution

    Any ideas?


    My config
    Fedora release 13
  2. Rob

    Rob Administrator Staff Member

    Messages:
    575
    Likes Received:
    224
    Trophy Points:
    43
  3. grim76

    grim76 Active Member Staff Writer

    Messages:
    177
    Likes Received:
    48
    Trophy Points:
    28
    Also can we see your sendmail config?
  4. laurentv

    laurentv Member

    Messages:
    30
    Likes Received:
    2
    Trophy Points:
    8
    egrep -v "^dnl|^$" /etc/mail/sendmail.mc
    divert(-1)dnl
    include(`/usr/share/sendmail-cf/m4/cf.m4')dnl
    VERSIONID(`setup for linux')dnl
    OSTYPE(`linux')dnl
    define(`confLOG_LEVEL', `9')dnl
    define(`confDEF_USER_ID', ``8:12'')dnl
    define(`confTO_CONNECT', `1m')dnl
    define(`confTRY_NULL_MX_LIST', `True')dnl
    define(`confDONT_PROBE_INTERFACES', `True')dnl
    define(`PROCMAIL_MAILER_PATH', `/usr/bin/procmail')dnl
    define(`ALIAS_FILE', `/etc/aliases')dnl
    define(`STATUS_FILE', `/var/log/mail/statistics')dnl
    define(`UUCP_MAILER_MAX', `2000000')dnl
    define(`confUSERDB_SPEC', `/etc/mail/userdb.db')dnl
    define(`confPRIVACY_FLAGS', `authwarnings,novrfy,noexpn,restrictqrun')dnl
    define(`confAUTH_OPTIONS', `A')dnl
    define(`confTO_IDENT', `0')dnl
    FEATURE(`no_default_msa', `dnl')dnl
    FEATURE(`smrsh', `/usr/sbin/smrsh')dnl
    FEATURE(`mailertable', `hash -o /etc/mail/mailertable.db')dnl
    FEATURE(`virtusertable', `hash -o /etc/mail/virtusertable.db')dnl
    FEATURE(redirect)dnl
    FEATURE(always_add_domain)dnl
    FEATURE(use_cw_file)dnl
    FEATURE(use_ct_file)dnl
    FEATURE(local_procmail, `', `procmail -t -Y -a $h -d $u')dnl
    FEATURE(`access_db', `hash -T<TMPF> -o /etc/mail/access.db')dnl
    FEATURE(`blacklist_recipients')dnl
    EXPOSED_USER(`root')dnl
    DAEMON_OPTIONS(`Port=smtp, Name=MTA')dnl
    FEATURE(`accept_unresolvable_domains')dnl
    LOCAL_DOMAIN(`localhost.localdomain')dnl
    MAILER(smtp)dnl
    MAILER(procmail)dnl
  5. grim76

    grim76 Active Member Staff Writer

    Messages:
    177
    Likes Received:
    48
    Trophy Points:
    28
    Can we see the logs as well?
  6. laurentv

    laurentv Member

    Messages:
    30
    Likes Received:
    2
    Trophy Points:
    8
    Aug 18 03:39:41 smtp sendmail[19256]: r7I1df0K019256: [x.x.x.x] did not issue MAIL/EXPN/VRFY/ETRN during connection to MTA
    Aug 18 03:39:52 smtp sendmail[19266]: r7I1dpAg019266: [x.x.x.x] did not issue MAIL/EXPN/VRFY/ETRN during connection to MTA
    Aug 18 03:41:53 smtp sendmail[19278]: r7I1fqdv019278: [x.x.x.x] did not issue MAIL/EXPN/VRFY/ETRN during connection to MTA

    x.x.x.x : my webserver
  7. Rob

    Rob Administrator Staff Member

    Messages:
    575
    Likes Received:
    224
    Trophy Points:
    43
    Is your webserver connecting to mail w/ monitoring tools at all? ie: is it connecting to check if mail is up w/o sending any commands after making the connection?
  8. laurentv

    laurentv Member

    Messages:
    30
    Likes Received:
    2
    Trophy Points:
    8
    sendmail is used only as a mail relay
    and web servers hosting website under CMS SPIP sending mail via this relay
    Well I use Nagios to monitor the server, but I know his IP address is different from my web servers.
  9. Rob

    Rob Administrator Staff Member

    Messages:
    575
    Likes Received:
    224
    Trophy Points:
    43
    Ok - I wouldn't worry about it - from what I understand, its basically saying that the web server IP is connecting to the mail server, but then not sending any commands.. Is there anything on there that you can think of that would be doing this?
  10. laurentv

    laurentv Member

    Messages:
    30
    Likes Received:
    2
    Trophy Points:
    8
    No, but I'm looking
  11. laurentv

    laurentv Member

    Messages:
    30
    Likes Received:
    2
    Trophy Points:
    8
    postfix is installed on web servers.
    in the log file / var / log / maillog (webserver), I have no record of communication with the relay server when errors with MTA ... appear
    postfix checks relay ?

    thank you for your answers

Share This Page