Problem with rsync

Discussion in 'General Linux' started by kippez, Feb 18, 2013.

  1. kippez

    kippez New Member

    Joined:
    Feb 18, 2013
    Messages:
    2
    Likes Received:
    0
    Hello!

    I've got an laptop with windows installed. Booted Sys Rescue CD and mounted the windows partition.
    I want to copy /mnt/windows/windows/csc with rsync and are running this command:
    "rsync -a --progress /mnt/windows/windows/csc /mnt/usbminne/". (usbminne = usb drive)
    My problem are that many files and directories contains swedish letters, and this directories and files will not be copied to my usb drive.


    Anyone got an solution for this?
     
  2. Rob

    Rob Administrator Staff Member

    Joined:
    Oct 27, 2011
    Messages:
    607
    Likes Received:
    271
    Hrm.. I googled a little bit and have maybe two options for you..

    First, try adding --iconv to your rsync command which should be able to convert between character sets..

    If that doesn't work, try mounting the windows partition with '-o utf16':
    mount -t blah -o utf16 /dev/blah /dev/mountpoint
     
  3. kippez

    kippez New Member

    Joined:
    Feb 18, 2013
    Messages:
    2
    Likes Received:
    0
    Thanks. I did solv this problem by mounting the usb drive with mount -o utf8 /dev/device /mnt/name.
     
  4. Rob

    Rob Administrator Staff Member

    Joined:
    Oct 27, 2011
    Messages:
    607
    Likes Received:
    271
    Ah, great to hear!
     

Share This Page