Problem changing os boot order

Discussion in 'Getting Started' started by Michael Surgeon, Dec 9, 2013.

  1. Michael Surgeon

    Michael Surgeon New Member

    Joined:
    Dec 9, 2013
    Messages:
    1
    Likes Received:
    0
    I am very new to Linux. I recently installed Elementary OS along side of Win7. No problem with install and liking Elementary.
    I wanted Win7 to be the default startup OS and found this link http://howto.cnet.com/8301-11310_39...hange-the-boot-order-of-a-dual-boot-linux-pc/ explaining how to change the boot order using the using the command line method. I ran "sudo vi /etc/default/grub" . The problem was that I couldn't change the boot number in the terminal.
    I'm not sure what happened when I quit the terminal, but now when I run "sudo vi /etc/default/grub" I get the following


    E325: ATTENTION
    Found a swap file by the name "/etc/default/.grub.swp"
    owned by: root dated: Sat Dec 7 10:47:29 2013
    file name: /etc/default/grub
    modified: YES
    user name: root host name: mike-Satellite-L505D
    process ID: 5330
    While opening file "/etc/default/grub"
    dated: Fri Dec 6 22:57:29 2013

    (1) Another program may be editing the same file. If this is the case,
    be careful not to end up with two different instances of the same
    file when making changes. Quit, or continue with caution.
    (2) An edit session for this file crashed.
    If this is the case, use ":recover" or "vim -r /etc/default/grub"
    to recover the changes (see ":help recovery").
    If you did this already, delete the swap file "/etc/default/.grub.swp"
    to avoid this message.
    "/etc/default/grub" 34 lines, 1238 characters
    Press ENTER or type command to continue

    Anyone know how to correct whatever I did wrong?
    Thanks.
     
    Last edited: Dec 9, 2013
  2. syamprasadkr

    syamprasadkr New Member

    Joined:
    Sep 3, 2015
    Messages:
    1
    Likes Received:
    0
    Same issue here. Considering this was posted in 2013, did you find a solution?
     
  3. alicia reyes

    alicia reyes New Member

    Joined:
    Sep 8, 2015
    Messages:
    6
    Likes Received:
    2
    I had this problem as well, a friend solve it...
     
  4. George Mulak

    George Mulak New Member

    Joined:
    Oct 5, 2015
    Messages:
    20
    Likes Received:
    5
    You have the change the boot order in the Grub menu. Use google and search:
    How to change the boot order of a dual-boot Linux PC from cnet article. They have both the graphical and command line how to.

    Let me know if that works.
     
  5. RussG

    RussG New Member

    Joined:
    Oct 9, 2015
    Messages:
    4
    Likes Received:
    0
    you can remove the swap file
    #rm -i grub.conf.swp
    #sudo vi grub.conf
    shift+r to replace
    change the boot number
    press escape
    shift+ ;
    wq
    this write and quit the config file.
     

Share This Page