Partial update error 12.04LTS

Discussion in 'Ubuntu' started by netwar, Jun 17, 2013.

  1. netwar

    netwar New Member

    Messages:
    19
    Likes Received:
    0
    Trophy Points:
    1
    Hello everyone,
    I primarily use FreeBSD UNIX so I can navigate command line fairly well but I dont know all the ins-and-outs of ubuntu(Just a preface in case some horribly obvious mistake is what has happened).
    My ubuntu box just this morning for no reason at all popped up the update manager saying that there was an error updating and would I like to preform a partial update.Before i tried the partial update i just wanted to check to make sure i couldn't fix it because in the past the default update manager has been a little mental.

    the output from:sudo dpkg --configure -a

    dpkg: dependency problems prevent configuration of wine1.6-i386:i386:
    wine1.6-i386:i386 depends on wine1.6:any (= 1.6~rc2-0ubuntu1~ppa1).
    dpkg: error processing wine1.6-i386:i386 (--configure):
    dependency problems - leaving unconfigured
    dpkg: dependency problems prevent configuration of wine:
    wine depends on wine1.6; however:
    Package wine1.6 is not installed.
    dpkg: error processing wine (--configure):
    dependency problems - leaving unconfigured
    dpkg: dependency problems prevent configuration of wine1.5-i386:i386:
    wine1.5-i386:i386 depends on wine1.6-i386; however:
    Package wine1.6-i386:i386 is not configured yet.
    dpkg: error processing wine1.5-i386:i386 (--configure):
    dependency problems - leaving unconfigured
    dpkg: dependency problems prevent configuration of wine1.6-amd64:
    wine1.6-amd64 depends on wine1.6:any (= 1.6~rc2-0ubuntu1~ppa1).
    dpkg: error processing wine1.6-amd64 (--configure):
    dependency problems - leaving unconfigured
    dpkg: dependency problems prevent configuration of wine1.5-amd64:
    wine1.5-amd64 depends on wine1.6-amd64; however:
    Package wine1.6-amd64 is not configured yet.
    dpkg: error processing wine1.5-amd64 (--configure):
    dependency problems - leaving unconfigured
    Errors were encountered while processing:
    wine1.6-i386:i386
    wine
    wine1.5-i386:i386
    wine1.6-amd64
    wine1.5-amd64




    the output from: sudo apt-get install -f

    Reading package lists... Done
    Building dependency tree
    Reading state information... Done
    Correcting dependencies... Done
    The following extra packages will be installed:
    wine1.6
    Suggested packages:
    dosbox:any
    The following NEW packages will be installed:
    wine1.6
    0 upgraded, 1 newly installed, 0 to remove and 0 not upgraded.
    5 not fully installed or removed.
    Need to get 0 B/1,206 kB of archives.
    After this operation, 6,235 kB of additional disk space will be used.
    Do you want to continue [Y/n]?

    After agreeing

    (Reading database ... 703947 files and directories currently installed.)
    Unpacking wine1.6 (from .../wine1.6_1.6~rc2-0ubuntu1~ppa1_amd64.deb) ...
    dpkg: error processing /var/cache/apt/archives/wine1.6_1.6~rc2-0ubuntu1~ppa1_amd64.deb (--unpack):
    trying to overwrite '/usr/bin/wine64-preloader', which is also in package wine1.6-amd64 1.6~rc2-0ubuntu1~ppa1
    dpkg-deb: error: subprocess paste was killed by signal (Broken pipe)
    Errors were encountered while processing:
    /var/cache/apt/archives/wine1.6_1.6~rc2-0ubuntu1~ppa1_amd64.deb
    E: Sub-process /usr/bin/dpkg returned an error code (1)

    I haven't updated in the past four days so i have no idea why this has happened. any help is appreciated.
  2. Dave67

    Dave67 New Member

    Messages:
    13
    Likes Received:
    1
    Trophy Points:
    1
    Okay it seems that you have versions of wine which depend on each other and 1.6 has dependency issues.

    My suggestion is use the software package center to install wine if you need it. new version is 1.7.x Or if you do not need it remove it. use the below to search for this guide and I can not post a link to new to the forum.

    what-is-the-correct-way-to-completely-remove-an-application
  3. ryanvade

    ryanvade Administrator Staff Member Staff Writer

    Messages:
    1,388
    Likes Received:
    454
    Trophy Points:
    83
    you may want to run a
    Code:
    sudo apt-get install -f
  4. Dave67

    Dave67 New Member

    Messages:
    13
    Likes Received:
    1
    Trophy Points:
    1
    He already ran that command see below the first paragraph

    Code:
    the output from: sudo apt-get install -f
    I suggested this because he has dependency issues with the paa packages must no have a repository enabled or added for the dependencies needed.

Share This Page