NVIDIA GT 750M black screen

Discussion in 'Desktop / X' started by Azelk, May 7, 2014.

  1. Azelk

    Azelk New Member

    Messages:
    11
    Likes Received:
    5
    Trophy Points:
    3
    I've been attempting to resolve this issue for days, with no success. I'm fairly new to linux. I don't know anything about reinstalling the kernel (Although it sounds easy from what I've read). The window manager I'm currently using is KDE. I installed the nvidia drivers with pacman -S nvidia, then tried using startx. The screen goes black and my GPU fan comes on at full speed, then the laptop reboots after a few seconds. I also tried installing the proprietary drivers from NVIDIA's website with the same results. I've tried using nvidia-xconfig and bumblebee. The Xorg.0 log file has the entry
    Code:
    Screens found, but none have a valid configuration
    or something similar to that.


    I would have posted this on the Arch Linux forum but the verification is seemingly impossible in my state.
  2. ryanvade

    ryanvade Administrator Staff Member Staff Writer

    Messages:
    1,567
    Likes Received:
    501
    Trophy Points:
    113
  3. ryanvade

    ryanvade Administrator Staff Member Staff Writer

    Messages:
    1,567
    Likes Received:
    501
    Trophy Points:
    113
    You say laptop..so does this system have an Intel graphics card along with the Nvidia chip? If so the issue is Optimus which can very easily fixed.
    To find out:
    Code:
     lspci | grep -i --color 'VGA'
    P.S. Not trying to be mean or anything but if you are new to Linux you should try a more user friendly system. Ubuntu 14.04 LTS, Manjaro, Mint, a few others are easier for new users.
    Abrar Faiyaz likes this.
  4. Azelk

    Azelk New Member

    Messages:
    11
    Likes Received:
    5
    Trophy Points:
    3
    The result is
    Code:
    VGA compatible controller: NVIDIA Corporation GK107M [GeForce GT 750M] (rev a1)
    Last edited: May 7, 2014
  5. ryanvade

    ryanvade Administrator Staff Member Staff Writer

    Messages:
    1,567
    Likes Received:
    501
    Trophy Points:
    113
    Okay then. This is what I would do:
    1. reinstall the base Arch system.
    2. install KDE , nvidia, and (if 64bit) lib32-nvidia-libgl
    3. after all that is installed enable kdm
    Code:
    sudo systemctl enable kdm.service
    or without sudo if you are the root user
    4. reboot
    5. login via kdm.

    Again though, you may want to use a more user friendly system. :)
  6. Azelk

    Azelk New Member

    Messages:
    11
    Likes Received:
    5
    Trophy Points:
    3
    I still get the same result.
  7. ryanvade

    ryanvade Administrator Staff Member Staff Writer

    Messages:
    1,567
    Likes Received:
    501
    Trophy Points:
    113
    what exactly did you do?
  8. Azelk

    Azelk New Member

    Messages:
    11
    Likes Received:
    5
    Trophy Points:
    3
    I wiped the root partition, then used these commands:
    Code:
    pacstrap -i /mnt base (Reboot)
    pacman -S kde nvidia
    systemctl start kdm.service
  9. ryanvade

    ryanvade Administrator Staff Member Staff Writer

    Messages:
    1,567
    Likes Received:
    501
    Trophy Points:
    113
    What is the model of the laptop?
  10. Azelk

    Azelk New Member

    Messages:
    11
    Likes Received:
    5
    Trophy Points:
    3
    Lenovo y510p
  11. ryanvade

    ryanvade Administrator Staff Member Staff Writer

    Messages:
    1,567
    Likes Received:
    501
    Trophy Points:
    113
    According to this post:
    https://bbs.archlinux.org/viewtopic.php?id=164747

    The issue may be the backlight being too low.

    What I would try is using the backlight keys to try and up the brightness. If that does not work take a look at this file:
    /sys/class/backlight/acpi_video0/brightness


    0 is lowest while 24 is highest.

    Also, is there anything in the journal

    Code:
    journalctl -b
    Code:
    dmesg 
    and the file ~/.xsession-errors


    and /var/log/Xorg.log

    Would you mind booting up an Ubuntu live cd? If Ubuntu loads the desktop, take a look at the
    'About this Computer' program in the top right menu. I still think your laptop has dual graphics.
    [​IMG]
    Last edited: May 9, 2014
    Akronix likes this.
  12. ryanvade

    ryanvade Administrator Staff Member Staff Writer

    Messages:
    1,567
    Likes Received:
    501
    Trophy Points:
    113
  13. Azelk

    Azelk New Member

    Messages:
    11
    Likes Received:
    5
    Trophy Points:
    3
    My laptop has SLI. I didn't think that mattered.
    Abrar Faiyaz likes this.
  14. ryanvade

    ryanvade Administrator Staff Member Staff Writer

    Messages:
    1,567
    Likes Received:
    501
    Trophy Points:
    113
  15. ryanvade

    ryanvade Administrator Staff Member Staff Writer

    Messages:
    1,567
    Likes Received:
    501
    Trophy Points:
    113
  16. Azelk

    Azelk New Member

    Messages:
    11
    Likes Received:
    5
    Trophy Points:
    3
    I can't get it working without SLI right now
  17. Azelk

    Azelk New Member

    Messages:
    11
    Likes Received:
    5
    Trophy Points:
    3
    That fixed it. Thanks
    ryanvade likes this.
  18. Abrar Faiyaz

    Abrar Faiyaz New Member

    Messages:
    7
    Likes Received:
    0
    Trophy Points:
    1
    Can You exactly guide what solved your problem ? I have Lenovo y510p laptop facing the same problem of getting the graphics fan running at a very high speed
    after installing nvidia driver .A proper step by step guide would be very much helpful!@Azelk
  19. Abrar Faiyaz

    Abrar Faiyaz New Member

    Messages:
    7
    Likes Received:
    0
    Trophy Points:
    1
    Can u help? I'm frustrated with this issue...tried more than 7 times installing and removing driver... and feel like goin on without a proper display...i just want a proper guide now...tht will work at once @ryanvade
  20. ryanvade

    ryanvade Administrator Staff Member Staff Writer

    Messages:
    1,567
    Likes Received:
    501
    Trophy Points:
    113
    Does your laptop have Nvidia Optimus graphics? (both Intel and Nvidia)

    If so take a look at this:
    http://www.linux.org/threads/nvidia-optimus-on-linux.4415/
  21. Azelk

    Azelk New Member

    Messages:
    11
    Likes Received:
    5
    Trophy Points:
    3
    That's the same model I own. Try using this kernel parameter.
    Code:
    rcutree.rcu_idle_gp_delay=1
    ryanvade likes this.

Share This Page