Nvidia GeForce 210 card enormous dispalay in RHEL6.4

Discussion in 'Linux Hardware' started by rahulvishwakarma, Aug 13, 2013.

  1. rahulvishwakarma

    rahulvishwakarma New Member

    Messages:
    4
    Likes Received:
    1
    Trophy Points:
    3
    Hi to all,

    I have RHEL 6.4 and NVIDIA GeForce 210 graphics card. After disabling nouveau and installing driver
    NVIDIA-Linux-x86_64-319.17.run
    display is enormous and one inch right sided. I did like this :-

    Code:
    # cd /lib/modules/$(uname -r)/kernel/drivers/gpu/drm/nouveau
    # mv nouveau.ko nouveau.ko.bak
    # cd /boot
    # mv initramfs-$(uname -r).img initramfs-$(uname -r).img.nouveau
    # dracut initramfs-$(uname -r).img $(uname -r)
    ... wait...
    # shutdown -r now

    Do (*) again.

    After gonig to runlevel 3 :-

    wherever you stored you driver installer.

    Code:

    Code:
    # ./NVIDIA-Linux-x86_64-319.17.run

    I followed the guide, responde yes or okay when applicable.

    When I see the prompt again,

    Code:
    # shutdown -r now

    Now I should have a nice GNOME 3 desktop waiting for me to login.

    But This was not happened. There was only 848x468 max resolution
    nothing was clear.

    And this card is wonking properly in Win 7 at resolution 1360x768

    Please tell me what should I do next to resolve this problem.

    I also tried adding vga=792 to its Grub options for vga mode of 1024x768
    resolution and 16M colors. but nothing was happned except CLI changed to
    high resolution and GUI was same enormous.


    Thanx in advance.
  2. ryanvade

    ryanvade Administrator Staff Member Staff Writer

    Messages:
    1,260
    Likes Received:
    428
    Trophy Points:
    83
    Rob likes this.
  3. rahulvishwakarma

    rahulvishwakarma New Member

    Messages:
    4
    Likes Received:
    1
    Trophy Points:
    3
    yes, Nvidia driver is running and is looking like this desktoplinux.png , in RHEL 6.4 this is enormous. Because this is is only 848x480 resolution. how to correct it. link doesn't helped me.
    ryanvade likes this.
  4. ryanvade

    ryanvade Administrator Staff Member Staff Writer

    Messages:
    1,260
    Likes Received:
    428
    Trophy Points:
    83
    There are several things that can be tried to work around this problem:

    • Add the parameter "resolution=1360x768" to the kernel line in grub.conf.
    • Add the parameter "video=1360x768" to the kernel line in grub.conf.
    • Modify and use the following xorg.conf file to allow your system to achieve the 1360x768 resolution necessary for hardware certification. To create an xorg.conf, refer How to create "xorg.conf" to configure X Windows on a system with no prior X configuration ?
    • Code:
      # This xorg.conf file has been designed for systems that support a resolution
      # of 1024x768 or greater, but only lower resolutions are listed in the
      # computer's System, Preferences, Display application. It assumes that X works
      # at low resolutions. It will allow you to achieve the 1024x768 resolution
      # necessary for hardware certification purposes if you save it as xorg.conf,
      # place it in the /etc/X11 directory and restart X. Please read the other
      # comment lines in this file and follow their directions to prepare the
      # file for use.
      
      Section "Monitor"
          Identifier  "Monitor0"
          ModelName    "LCD Panel 1360x768"
      # The HorizSync and VertRefresh lines below are designed for a generic LCD
      # monitor. They should also work for modern CRT monitors. If you know your
      # monitor's values, replace the ones shown below with those values.
      # Otherwise, uncomment the next two lines and use them as-is.
      #    HorizSync    31.5 - 48.0
      #    VertRefresh  56.0 - 65.0
          Option        "dpms"
      EndSection
      
      Section "Device"
          Identifier  "Videocard0"
      # The Driver line below should contain the appropriate driver for your system.
      # You can find your driver by looking at the system's /var/log/Xorg.0.log file
      # for lines that begin with driver names, like these:
      #
      # This is an example of a system using the Matrox 'mga' driver
      # (II) MGA(0): initializing int10
      # (II) MGA(0): Primary V_BIOS segment is: 0xc000
      # (II) MGA(0): VESA BIOS detected
      # (II) MGA(0): VESA VBE Version 3.0
      #
      # This is an example of a system using the Aspeed 'ast' driver
      # (II) AST(0): initializing int10
      # (II) AST(0): Primary V_BIOS segment is: 0xc000
      # (II) AST(0): VESA BIOS detected
      # (II) AST(0): VESA VBE Version 3.0
      #
      # Replace the 'vesa' on the Driver line below (unless you are using the vesa
      # driver) with the proper driver for your system and then uncomment the line.
      #    Driver      "vesa"
      EndSection
      
      Section "Screen"
          Identifier "Screen0"
          Device    "Videocard0"
          Monitor    "Monitor0"
          DefaultDepth    24
          SubSection "Display"
                Viewport  0 0
                Depth    24
          EndSubSection
      EndSection
      
    • system'->'administration'->'display'->'display settings'
    SOURCE: https://access.redhat.com/site/solutions/40591
  5. ryanvade

    ryanvade Administrator Staff Member Staff Writer

    Messages:
    1,260
    Likes Received:
    428
    Trophy Points:
    83
  6. rahulvishwakarma

    rahulvishwakarma New Member

    Messages:
    4
    Likes Received:
    1
    Trophy Points:
    3
    Respected sir ryanvade,
    yesterday once I started my RHEL6.4 I found display of 1360x768 resolution , but after restarting computer all the things were reverted, how it was possible I don't know(that good display).
    I tried everything you told me. Blacklisting in grub.conf, and in /etc/modprobe/blacklist.conf

    written in /etc/X11/xorg.conf
    Section "Monitor"
    Identifier "Monitor0"
    VendorName "Samsung"
    ModelName "LCD Panel 1360x768"
    HorizSync 28.0 - 33.0
    VertRefresh 43.0 - 72.0
    Option "DPMS"
    EndSection

    lsmod gives this result :-

    [root@kaljayi ~]# lsmod | grep nvidia
    nvidia 9404959 28
    i2c_core 31084 2 i2c_i801,nvidia


    and nothing was changed.
    what should I do next.
  7. ryanvade

    ryanvade Administrator Staff Member Staff Writer

    Messages:
    1,260
    Likes Received:
    428
    Trophy Points:
    83
    hmmm. Maybe something like this:
    Code:
    Section "Screen"
        Identifier "Screen0"
        Device    "Card0"
        Monitor    "Monitor0"
        DefaultDepth    24
        SubSection "Display"
            Viewport  0 0
            Depth    24
            Modes  "1280x800"
        EndSubSection
    EndSection
    
    This one is tricky..
  8. ryanvade

    ryanvade Administrator Staff Member Staff Writer

    Messages:
    1,260
    Likes Received:
    428
    Trophy Points:
    83
    I think this is GNOME not the system.
    Could you check in
    System->Administration->Display
    AND
    System->Preference->Screen
  9. rahulvishwakarma

    rahulvishwakarma New Member

    Messages:
    4
    Likes Received:
    1
    Trophy Points:
    3
    sir finally I installed CentOS 6.4 and did as follows
    Code:
    #vim /etc/modprobe.d/blacklist.conf
    I appended this line :
    blacklist nouveau
    :wq
    
    #vim  /boot/grub/grub.conf
    I appended in line of kernel
    rdblacklist=nouveau
    :wq
    
    then
    # cd /boot
    #mv initramfs-version.img  initramfs-version.img.bak
    
    #dracut initramfs-$(uname -r).img $(uname -r)
    
    #init 6
    
    after that going to runlevel 3
    Code:
    #./NVIDIA-Linux-x86_64-319.17.run
    #init 6
    
    after that everything was okay, but after rebooting 3-4 times again same problem ,
    enormous display and to recover it complete format requires. Is there any hardware related problem i.e. in graphics card. In windows also sometimes screen goes black for a second with a alert sound, like it is updating something.

Share This Page