Nvidia Drivers for Mint

Discussion in 'Getting Started' started by iClopTooMuch, Dec 14, 2013.

  1. iClopTooMuch

    iClopTooMuch New Member

    Messages:
    1
    Likes Received:
    1
    Trophy Points:
    3
    Alright, so here's the situation:
    I have installed (and reinstalled many times) Linux Mint 16 (I think that's the correct one, it's the newest version). I have also tried this with Ubuntu. Whenever I start up the computer, I have to run nomodeset=1 in the boot commands in order to see anything. This is because of drivers (or rather, lack of) for my graphics card, which is an Nvidia GeForce GT 755M. When I try to install the drivers necessary to make it so I do not have to boot into nomodeset, they don't work. When I go back to nomodeset, the desktop is now completely screwed and is permanently in fallback mode. On Ubuntu, there simply are not any icons, and all I see is a wallpaper.
    I'm really anxious to try Linux but I'm about to throw the computer against the wall because I can't figure this out.
    tl;dr i cant install nvidia drivers without screwing over the OS

    DevynCJohnson likes this.
  2. Videodrome

    Videodrome Active Member

    Messages:
    180
    Likes Received:
    73
    Trophy Points:
    28
    I'm trying to remember how MINT might be handled by X Window. Can you check to see if there is a file called /etc/X11/xorg.conf while in the Fallback mode? You might be able to edit the display driver to the generic "vesa".

    If this works right, it will not get you fully running on Nvidia, but hopefully undo the borked desktop and have you running on the generic driver.

    It's also possible you're fighting against a generic Nvidia driver called Nouveau.

    Might be worth trying directions like this if you can start over. Good luck. Also, I'm a CrunchBang user. Hopefully, some MINT Nvidia users can chime in, but I remember a similar problem from when I tried MINT on old hardware.

    http://community.linuxmint.com/tutorial/view/1277

    sudo add-apt-repository ppa:xorg-edgers/ppa
    sudo apt-get update
    sudo apt-get install nvidia-current nvidia-settings

    Next step remove nouveau

    apt remove --purge xserver-xorg-video-nouveau libdrm-nouveau1
    DevynCJohnson likes this.
  3. lobo

    lobo Active Member

    Messages:
    130
    Likes Received:
    74
    Trophy Points:
    28
    Boot with nomodeset and do the following
    Code:
    # echo blacklist nouveau > /etc/modprobe.d/nouveau-blacklist.conf
    Reboot and you should not need to specify nomodeset.

    Then install the nvidia proprietary driver.

Share This Page