Noob question: Problem with svn and multible apache instances

Discussion in 'General Linux' started by Tom43, Jan 11, 2014.

  1. Tom43

    Tom43 New Member

    Messages:
    2
    Likes Received:
    1
    Trophy Points:
    3
    Hello Linux-experts,


    Some days ago I bought a little NAS-box with ARM controller etc.
    Because I wanted to get additional functionality it would be nice to have Debian, but fan control and things make this quite difficult.
    Therefore I installed Debian minbase with debootstrap and chroot on the hdd.
    First thing I want to add is Subversion.
    The problem now is that there is something running on Port 80 (Checked with netstat), I suppose apache.

    My questions are:
    • Is it necessary to get a second instance of apache running on the debian chroot? I suppose I don't need Webinterface because I just want to upload over network with some SVN client.
    • If yes, how can I manage? I tried to start apache2 and he tells me its not possible due to Port 80 already in use and shuts down

    Sorry for my imprecise phrases but I'm not familiar with that stuff!

    Thanks a lot for your help!!
    DevynCJohnson likes this.
  2. DevynCJohnson

    DevynCJohnson Well-Known Member Staff Member Staff Writer

    Messages:
    1,295
    Likes Received:
    1,033
    Trophy Points:
    113
    Here is a long web-page, but your question about running multiple instances of Apache should be answered - http://wiki.apache.org/httpd/RunningMultipleApacheInstances

    As far as the ports conflict, if the link above does not solve that issue, maybe making some changes in the config files will help.

    Alternately, you could run two different HTTP daemons - Apache and something else.

    EDIT: The above link does discuss using different ports and how to do so. You may find the webpage I found quite helpful.
    Haider92 likes this.
  3. Tom43

    Tom43 New Member

    Messages:
    2
    Likes Received:
    1
    Trophy Points:
    3
    Thanks for your advice!
    I just tried to run on port 444 because 443 and 80 are in use and I only need https connection.
    But if I'm running:
    /etc/init.d/apache2 restart
    No error message is shown but when running:
    /etc/init.d/apache2 reload
    There's shown:
    Reloading web server config: apache2 not running
    Also the side isn't available.
    Perhaps someone could revise my config, I have no plan of it...

    Code:
    /etc/apache2/ports.conf:
        NameVirtualHost *:444
    
        <IfModule mod_ssl.c>
                Listen 444
        </IfModule>
    
        <IfModule mod_gnutls.c>
                Listen 444
        </IfModule>
    
    /etc/apache2/sites-enabled/000-default:
        <VirtualHost *:444>
               ...
    </VirtualHost>
    
    /etc/apache2/sites-available/default-ssl:
        <IfModule mod_ssl.c>
        <VirtualHost _default_:444>
      ...
    
    /etc/apache2/sites-available/ssl.nsa325-v2:
        <VirtualHost *:444>
          ...
    </VirtualHost>
    
    Thanks a lot!!!

Share This Page