No right-click menu on the desktop of Gnome, Debian

Discussion in 'Desktop / X' started by vijoslx11111, Dec 29, 2013.

  1. vijoslx11111

    vijoslx11111 New Member

    Messages:
    2
    Likes Received:
    1
    Trophy Points:
    1
    When I right-click anywhere on the desktop, there's no right-click menu. It seems OK when I use other programs such as file manager, terminal and Iceweasel. I use Debian 7.3.0, downloaded from the official website.


    Does anyone know how to handle it?
    DevynCJohnson likes this.
  2. DevynCJohnson

    DevynCJohnson Well-Known Member Staff Member Staff Writer

    Messages:
    1,158
    Likes Received:
    983
    Trophy Points:
    113
    You need to set the file manager to manage the desktop. I do not know how this is done in Debian. I did it before in Ubuntu using Ubuntu Tweak. Specifically, what is happening is the desktop (right now on your system) is just the wallpaper, but no upper layer (file manager).
    Haider92 likes this.
  3. Cyber-Berserker

    Cyber-Berserker Active Member

    Messages:
    232
    Likes Received:
    136
    Trophy Points:
    43
    A GUI's behaviour can be adjusted by altering the preferences. Of course, the exact procedure is different for different GUIs. So that brings up the question; Which GUI are you using? Gnome? I am guessing you installed with CD1, as opposed to KDE-CD1, XFCE-CD1 or LXDE-CD1, and therefore, have Gnome. I have never used Gnome 3, but I believe an additional package must be installed before being able to significantly customise. I believe the package is called Gnome Tweak Tool.
  4. Diomoid

    Diomoid New Member

    Messages:
    1
    Likes Received:
    1
    Trophy Points:
    1
    You can set the file manager to manage the desktop in Gnome by going to:
    Applications (menu at the top left) -> System tools -> Preferences ->Advanced Settings -> Desktop -> and turn on "Have the file manager handle the desktop".
    DevynCJohnson likes this.

Share This Page