Netflix is now viewable on linux (workaround)

Discussion in 'Linux Audio / Video' started by supersonic1949, Aug 7, 2014.

  1. supersonic1949

    supersonic1949 New Member

    Messages:
    3
    Likes Received:
    0
    Trophy Points:
    1
    Hello! I am supersonic1949.
    I have been working, and have been able to run Netflix in Firefox! This is what you will need:
    • Mozilla Firefox
    • Linux OS
    • Wireless Broadband Internet Connection

    Let's Get Started!
    Please Note that i am using Ubuntu, so if you have another Linux, Post in the comments.
    Start Linux & access the terminal by pressing Ctrl/Alt/T
    Type these commands:
    1. sudo add-apt-repository ppa: pipelight/stable *
    2. sudo apt-get update
    3. sudo apt-get install --install-recommends pipelight-multi
    4. sudo pipelight-plugin --update
    * there is no space between : and pipelight/stable


    For a systemwide silverlight installation type:
    sudo pipelight-plugin --enable silverlight


    You will also need a user agent overrider to access netflix player.
    To install, Go to Mozilla Addons, search for User Agent Overrider and click Add to firefox and/or install anyway
    To watch Netflix, the overrider needs to be set to emulate Windows / Firefox 29.
    Wait until silverlight installs BEFORE opening Mozilla Firefox.
    After installation, open Mozilla Firefox, Go to Netflix, Sign In, and test out silverlight.

    If it doesn't work, you will have to do this over again! If you experience any errors, post your error & linux distro in the comments.

    Thank you for reading.
    I hope this helped you! :D
  2. Richard Rodriguez

    Richard Rodriguez Member

    Messages:
    72
    Likes Received:
    14
    Trophy Points:
    8
    I already us Netflix thru Wine, but i though i would try this too, here is what i got

    "E: Unable to locate package pipelight-multi"
  3. supersonic1949

    supersonic1949 New Member

    Messages:
    3
    Likes Received:
    0
    Trophy Points:
    1
    you forgot to do step 1!!! Dont skim through!!!
  4. Richard Rodriguez

    Richard Rodriguez Member

    Messages:
    72
    Likes Received:
    14
    Trophy Points:
    8
    nope, didn't forget to do step 1

    it is clearly marked with 1. right?
  5. arochester

    arochester Well-Known Member

    Messages:
    853
    Likes Received:
    273
    Trophy Points:
    63
    Finally: Native Netflix Playback on Linux
  6. supersonic1949

    supersonic1949 New Member

    Messages:
    3
    Likes Received:
    0
    Trophy Points:
    1
    There Is no space between : and p or else it would have put :p there is also no *
  7. Richard Rodriguez

    Richard Rodriguez Member

    Messages:
    72
    Likes Received:
    14
    Trophy Points:
    8
    I copied your post, you did put a space between the ": and the P"

    but I will retry, thanks
  8. rosawoodsii

    rosawoodsii New Member

    Messages:
    3
    Likes Received:
    0
    Trophy Points:
    1
    I realize this is an old thread, but it's relevant. I've gotten through step 3, but the terminal now says "configuring ttf-mscorefonts-installer", has a bunch of license information, and at the bottom <Ok>. I've tried hitting "enter", clicking on "ok", all to no avail. The page has been sitting there for at least 1/2 hour, and I'm not sure how to agree and move on. Suggestions? Do I have to start over if I quit now, or just start from step 3?

    I'll be glad to attach a screen shot if someone instructs me how to do that.
  9. rosawoodsii

    rosawoodsii New Member

    Messages:
    3
    Likes Received:
    0
    Trophy Points:
    1
    so I didn't wait for a reply, just closed the terminal window and rebooted later. That was a mistake. I ran
    sudo apt-get install --install-recommends pipelight-multi
    and got the following message:
    E: dpkg was interrupted, you must manually run 'sudo dpkg --configure -a' to correct the problem

    so I typed
    sudo dpkg --configure -a pipelight-multi

    and it said
    dpkg: error: --configure --pending does not take any non-option arguments

    dpkg --help does not help, because I don't know what I'm supposed to be doing.

    Any help gladly received.
  10. rosawoodsii

    rosawoodsii New Member

    Messages:
    3
    Likes Received:
    0
    Trophy Points:
    1
    Anyone? Still waiting for a reply. Please!
  11. arochester

    arochester Well-Known Member

    Messages:
    853
    Likes Received:
    273
    Trophy Points:
    63
    The command is just
    Code:
    sudo dpkg --configure -a
    You don't add anything to it.
  12. Prince

    Prince New Member

    Messages:
    7
    Likes Received:
    5
    Trophy Points:
    3
    very nice

Share This Page