Need to kill install or it kills me

Discussion in 'Getting Started' started by URDRWHO, Feb 25, 2014.

  1. URDRWHO

    URDRWHO Member

    Messages:
    86
    Likes Received:
    6
    Trophy Points:
    8
    If I only install the suggested Nvidia driver everything works fine. It is when I go back and install the Broadcom driver.....errrr that is when I get the problem.

    Last edited by a moderator: Feb 27, 2014
  2. URDRWHO

    URDRWHO Member

    Messages:
    86
    Likes Received:
    6
    Trophy Points:
    8
    I know --- I know.

    It was late, a bit of wine....I was just ranting.

    The people that make the drivers are addicted to MS and don't care.

    How I get the drivers in question? I go to the Ubuntu Additional Drivers icon, click on it, the search begins and it will show the Nvidia and Broadcom drivers to install.

    What happens is that the Broadcom won't finish the download process and then the software index gets broken.

  3. Cyber-Berserker

    Cyber-Berserker Active Member

    Messages:
    232
    Likes Received:
    136
    Trophy Points:
    43
    In that case, if the nVidia driver works, use it. The Broadcom driver may not be compatible with your specific hardware or the driver in Ubuntu's repository could have a bug. Unless you need it, forget about it.
  4. URDRWHO

    URDRWHO Member

    Messages:
    86
    Likes Received:
    6
    Trophy Points:
    8
    That is what I decided. I just won't have WiFi but I really don't need it. I have this thing that I always want to get things working as they should work. I'm like that on cars, my used cars are always 100% or darn close to it. People see me working on my cars and think there is always something wrong. Nope it is just me trying to keep things perfect.

    This is the broadcom package that Ubuntu finds for my system.

    This package contains Broadcom 802.11 Linux STA wireless driver for use with Broadcom's BCM4311-, BCM4312-, BCM4313-, BCM4321-, BCM4322-, BCM43224-, and BCM43225-, BCM43227- and BCM43228-based hardware.
    Last edited: Feb 27, 2014
  5. MikeyD

    MikeyD Active Member

    Messages:
    219
    Likes Received:
    105
    Trophy Points:
    43
    Broadcom devices have always been tricky with Linux. The only real problems I had were with my broadcom card.

    I had a similar problem when trying to do a kernel update to 3.10 in Arch Linux my whole PC would freeze:
    https://bbs.archlinux.org/viewtopic.php?id=169707
    May not be helpful in your situation though unless you want to try an earlier kernel release, but I'd check Ubuntu bug report for any known bugs related to your device.

    Do you know the model of the broadcom device?

    I don't know how up to date this list is, but it may help:
    http://wireless.kernel.org/en/users/Drivers/b43/devices
  6. GrumpyOldMan

    GrumpyOldMan Active Member

    Messages:
    115
    Likes Received:
    41
    Trophy Points:
    28
    Well, if the issue is Wireless, you could try ndiswrapper. That will allow you to wrap a Windows ndis driver in an execution environment, and run it on a linux system.

    I set up a Tinycore package to install a windows driver for an Atheros1111-based wireless, rigged so it comes up and running at boot time.

    It's not the greatest solution, but it met our needs...
  7. URDRWHO

    URDRWHO Member

    Messages:
    86
    Likes Received:
    6
    Trophy Points:
    8
    I think that is what I had to do the last time I was trying ubuntu on the laptop.

    Now I'm trying to turn off that darn drum sound at start-up. It has made me jump too many times. Apparently *again) you need to run commands. I feel like I am back in DOS days. :)

    Apparently they really want you to hear those drums!

    "There are many things I dont like in Ubuntu and one of them is the login sound. That's why right after I installed Ubuntu 12.04 Precise Pangolin on my laptop to test it, the very first thing I did was to try to turn off the login sound. However, things now are different from what I was accustomed to. When I opened the Startup Application Preferences to disable the login sound ( as I used to do in the old versions of Ubuntu), all I saw was a blank window. The reason for this is that the login sound option is hidden on the Startup Application Preferences by default but you can make it visible again easily. Just open the terminal and type the following command to edit the login sound script:"

    sudo gedit /usr/share/gnome/autostart/libcanberra-login-sound.desktop

    [Desktop Entry]
    Type=Application
    Name=GNOME Login Sound
    Comment=Plays a sound whenever you log in
    Exec=/usr/bin/canberra-gtk-play --id="desktop-login" --description="GNOME Login"
    OnlyShowIn=GNOME;Unity;
    AutostartCondition=GSettings org.gnome.desktop.sound event-sounds
    X-GNOME-Autostart-Phase=Application
    X-GNOME-Provides=login-sound
    X-GNOME-Autostart-enabled=false
    NoDisplay=true
  8. ryanvade

    ryanvade Administrator Staff Member Staff Writer

    Messages:
    1,143
    Likes Received:
    388
    Trophy Points:
    83
  9. ryanvade

    ryanvade Administrator Staff Member Staff Writer

    Messages:
    1,143
    Likes Received:
    388
    Trophy Points:
    83
    I do wish that Canonical would put a setting somewhere that would allow you to turn the login sound on/off. Or maybe that Ubuntu Tweak could get that feature.
  10. URDRWHO

    URDRWHO Member

    Messages:
    86
    Likes Received:
    6
    Trophy Points:
    8
    I do know that several years ago I had Ubuntu on the laptop in question and the wireless was working. I don't use wireless much on it and I'm going to stay with what I have - no wireless.

    I'm really kind of liking it with the KDE desktop I added today. It suits me better than the big icons on the Ubuntu desktop.

    http://news.softpedia.com/news/How-to-Install-KDE-SC-4-9-on-Ubuntu-12-04-LTS-284410.shtml
  11. ZZs

    ZZs Active Member

    Messages:
    130
    Likes Received:
    49
    Trophy Points:
    28
    Being this is a laptop and you one day may need wireless I'd say install it. To install it you need to download the appropriate firmware package for your model. During the firmware installation the appropriate driver will automatically be installed.

    You can find your model by going into terminal and typing:
    lspci -k or
    lspci | grep BCM

    You can now confirm the needed firmware package from Ubuntu's support site but it will probably be this one:
    sudo apt-get install bcmwl-kernal-source
    reboot

    If its not here are two links that should help you through it:
    https://help.ubuntu.com/community/WifiDocs/Driver/bcm43xx
    http://askubuntu.com/questions/55868/how-to-install-broadcom-wireless-drivers-bcm43xx
  12. URDRWHO

    URDRWHO Member

    Messages:
    86
    Likes Received:
    6
    Trophy Points:
    8

    Thanks. This is what I get.

    02:02.0 Network controller: Broadcom Corporation BCM4306 802.11b/g Wireless LAN Controller (rev 03)

    I'll need to think about trying it again. I went through two installs because of trying to install the drivers and currently I have everything the way I want it. Hm?????

    In the morning I will track down the exact driver.
  13. ryanvade

    ryanvade Administrator Staff Member Staff Writer

    Messages:
    1,143
    Likes Received:
    388
    Trophy Points:
    83
    You have the third revision of the 4306 card. So you need the b43 driver.
    http://wireless.kernel.org/en/users/Drivers/b43

    there is a table down at the bottom of the page with each chipset/revision and the current support status.
    4306 rev 1/2 need b43-legacy
    4306 rev3 needs b43.

    Basically the Kernel has the appropriate kernel modules but not the firmware because it is licensed.
    For Ubuntu/Debian:
    Code:
    sudo apt-get install firmware-b43-installer
    Last edited: Feb 27, 2014
  14. URDRWHO

    URDRWHO Member

    Messages:
    86
    Likes Received:
    6
    Trophy Points:
    8
    I'll use your script to get the driver. Thanks.

    I just found an old Ubuntu link that was way down in the favorites of my Chrome files. I think I followed it back then to get my WiFi working. Looking at the date of the posts, it is not a new issue.

    http://ubuntuforums.org/archive/index.php/t-828553.html
    Last edited: Feb 28, 2014
  15. labrat

    labrat Active Member

    Messages:
    104
    Likes Received:
    41
    Trophy Points:
    28
    I would suggest not following that guide - instead follow ryanvade's instructions to get the b43 driver and read the information in the link he posted.

    As a general rule:

    - Avoid WL (broadcom-sta) unless your device is not supported by b43 or one of the other drivers.

    - You really don't want ndiswrapper unless there is absolutely no other alternative - this is because it's often not the best solution, can give inferior performance and often you have to use old win9x drivers with it.
  16. URDRWHO

    URDRWHO Member

    Messages:
    86
    Likes Received:
    6
    Trophy Points:
    8
    On the KDE desktop I installed there is a menu to control media sound and there is a slider for the Event sounds. I have mine muted.

    Looking at this KDE desktop makes me realize that I do not like Ubuntu Unity...not one bit.
  17. URDRWHO

    URDRWHO Member

    Messages:
    86
    Likes Received:
    6
    Trophy Points:
    8

    No I don't plan on following that old thread and will use ryanvade's instructions. I only posted to show that the Broadcom problem has existed for a long, long time.
  18. labrat

    labrat Active Member

    Messages:
    104
    Likes Received:
    41
    Trophy Points:
    28
    The broadcom situation is very simple:

    - They produce their own driver, but not all devices are supported - particularly older 802.11g devices and anything earlier. The driver is referred to as wl / broadcom-sta

    - The FOSS broadcom (non affiliated) drivers are included in the kernel. There are a few different drivers, most notably, brcmsmac/brcm80211 and b43/b43-legacy. They support a lot of devices - including many which are supported by the wl / broadcom-sta driver but usually not the newest.

    - The brcmsmac/brcm80211 driver requires proprietary firmware (blobs) to be loaded to the device in order for it to function - this firmware is included in the Linux kernel.

    - The b43/b43-legacy driver requires proprietary firmware (blobs) to be loaded to the device in order for it to function - this firmware has to be extracted from the broadcom-sta / wl driver. This firmware is not included in the Linux kernel and cannot be redistributed due to licensing (unlike e.g. brcm80211 firmware and ralink, realtek, atheros and iwlwifi firmwares).

    - The firmware for b43/b43-legacy is extracted using the tool b43-fwcutter - though some distros automate this via the package manager / scripting (including downloading wl, "cutting" out the firmware and installing it to /lib/firmware).
    Last edited: Feb 28, 2014
    Cyber-Berserker likes this.
  19. Cyber-Berserker

    Cyber-Berserker Active Member

    Messages:
    232
    Likes Received:
    136
    Trophy Points:
    43
    Nice post. Very informative.

Share This Page