Missing icons?

Discussion in 'Desktop / X' started by ryanvade, Dec 10, 2013.

  1. ryanvade

    ryanvade Administrator Staff Member Staff Writer

    Messages:
    1,398
    Likes Received:
    454
    Trophy Points:
    83
    Hello everyone,

    I performed a fresh install of Arch on my laptop and I am trying to get everything working again. So far I have run into one issue..the bumblebee-indicator application settings.
    Code:
     bumblebee-app-settings
    Traceback (most recent call last):
      File "/usr/local/bin/bumblebee-app-settings", line 356, in <module>
        Appset = Applications_settings()
      File "/usr/local/bin/bumblebee-app-settings", line 91, in __init__
        self.build_app_list()
      File "/usr/local/bin/bumblebee-app-settings", line 186, in build_app_list
        iter=self.app_list.append(None, [categorie,None,None] + [self.icon_set.get_pixbuf(icon_name)] + 3*[False] + 3*[None] + [False, Config.to_configure_color])
      File "/usr/local/bin/bumblebee-app-settings", line 47, in get_pixbuf
        except : return self.icon_theme.load_icon(Config.default_icon_name, icon_size, 0)
    glib.GError: Icon 'application-x-executable' not present in theme
    I think the issue is a lack of icons called application-x-executable. However, I am not sure how to resolve this. Should I just make an icon and put it with the other icons? Does the size of the icon matter?


    Thanks for any suggestions.
    DevynCJohnson likes this.
  2. DevynCJohnson

    DevynCJohnson Well-Known Member Staff Member Staff Writer

    Messages:
    1,381
    Likes Received:
    1,094
    Trophy Points:
    113
    Reinstall all icon packages, window managers, desktop interface, etc. I am not sure specifically which GUI package would have that, so just reinstall all GUI packages. Obviously, updates can help (if available).
    Haider92 and ryanvade like this.
  3. lobo

    lobo Active Member

    Messages:
    130
    Likes Received:
    74
    Trophy Points:
    28
    Icons are usually stored in /usr/share/icons/ subdirectories. Have a look and see if it's missing.

    Or you could install/reinstall the various icon themes and see what happens...?

    The common ones are the tango icon theme, hicolor icon theme and gnome icon theme. If you install those three, most apps should have working icons.
    ryanvade and DevynCJohnson like this.
  4. ryanvade

    ryanvade Administrator Staff Member Staff Writer

    Messages:
    1,398
    Likes Received:
    454
    Trophy Points:
    83
    Thanks for the replys. Let me try some stuff..

    Using KDE 4.12 by the way with the Iceglass iconset.
  5. ryanvade

    ryanvade Administrator Staff Member Staff Writer

    Messages:
    1,398
    Likes Received:
    454
    Trophy Points:
    83
    Code:
    glib.GError: Icon 'gtk-missing-image' not present in theme
    ** Message: pygobject_register_sinkfunc is deprecated (AwnOverlay)
    Traceback (most recent call last):
      File "/usr/bin/awn-settings", line 1223, in <module>
        awnmanager = awnManagerMini()
      File "/usr/bin/awn-settings", line 1072, in __init__
        self.createMainMenu()
      File "/usr/bin/awn-settings", line 1137, in createMainMenu
        self.safe_load_icon('gtk-execute', size, gtk.ICON_LOOKUP_USE_BUILTIN),
      File "/usr/share/avant-window-navigator/awn-settings/awnClass.py", line 1061, in safe_load_icon
        icon = self.theme.load_icon('gtk-missing-image', size, flags)
    glib.GError: Icon 'gtk-missing-image' not present in theme
    Avant window manager...
  6. DevynCJohnson

    DevynCJohnson Well-Known Member Staff Member Staff Writer

    Messages:
    1,381
    Likes Received:
    1,094
    Trophy Points:
    113
    At this point, I am not sure what to do. It almost seems like your system is missing the default icons. If so, may be you need to find some way to reinstalled that portion of the system.

    Maybe you should reinstall all and any GTK packages. Notice that the error says "glib.GError: Icon 'gtk-missing-image' not present in theme".
    Haider92 and ryanvade like this.
  7. ryanvade

    ryanvade Administrator Staff Member Staff Writer

    Messages:
    1,398
    Likes Received:
    454
    Trophy Points:
    83
    Installing gnome-icon-theme may have fixed Avant but not Bumblebee-ui.

    So odd. o_O
    Last edited: Jan 8, 2014
  8. lobo

    lobo Active Member

    Messages:
    130
    Likes Received:
    74
    Trophy Points:
    28
    Can you install the gnome-icon-theme? It's probably a bug in "bumblebee-indicator" which is causing this, as it should be xdg compliant.

    It's common to have gtk icon/theme problems if you're running a bare system with just KDE installed. Also install some gtk themes and a theme switcher. I prefer gtk-chtheme for the latter.

    You can explicitly set your gtk-2 theme in ~/.gtkrc-2.0

    You may also find this to be of interest: https://wiki.archlinux.org/index.php/Uniform_Look_for_Qt_and_GTK_Applications
    DevynCJohnson likes this.

Share This Page