Mail server can send but not receive email

Discussion in 'Mail Server' started by ryanvade, Mar 24, 2014.

  1. ryanvade

    ryanvade Administrator Staff Member Staff Writer

    Messages:
    1,160
    Likes Received:
    392
    Trophy Points:
    83
    Hello everyone,

    I am setting up a personal email. The domain is from goddady and it is redirecting to my server. I have been able to send emails from the server to my gmail but not the other way around. Does anyone know of a reason?


    @Rob what do you think? What should the MX settings be on goddady?
  2. ryanvade

    ryanvade Administrator Staff Member Staff Writer

    Messages:
    1,160
    Likes Received:
    392
    Trophy Points:
    83
    Code:
    host -t mx X.info
    X.info mail is handled by 0 smtp.X.info.
    X.info mail is handled by 10 mail.X.info
  3. VitalkaDrug

    VitalkaDrug New Member

    Messages:
    18
    Likes Received:
    9
    Trophy Points:
    3
    Who is responsible for answers to DNS requests to your zone? Is it your server or goaddy server? That server and should contain the zone database with MX records for your mail server.
    ryanvade likes this.
  4. ryanvade

    ryanvade Administrator Staff Member Staff Writer

    Messages:
    1,160
    Likes Received:
    392
    Trophy Points:
    83
    I think Godaddy should be.
  5. VitalkaDrug

    VitalkaDrug New Member

    Messages:
    18
    Likes Received:
    9
    Trophy Points:
    3
    And does it have these records?
  6. ryanvade

    ryanvade Administrator Staff Member Staff Writer

    Messages:
    1,160
    Likes Received:
    392
    Trophy Points:
    83
    Yes. Mail, smtp, imap, pop,email are all pointing to the server.
  7. VitalkaDrug

    VitalkaDrug New Member

    Messages:
    18
    Likes Received:
    9
    Trophy Points:
    3
    I think you need to verify a connectivity to your server by these protocols.
    If connections are established then check your software logs for any errors.
    ryanvade likes this.
  8. ryanvade

    ryanvade Administrator Staff Member Staff Writer

    Messages:
    1,160
    Likes Received:
    392
    Trophy Points:
    83
    Just found this in the logs:
    Code:
    Mar 25 21:39:26 ryanvade amavis[1100]: Creating db in /var/lib/amavis/db/; BerkeleyDB 0.49, libdb 5.1
    Mar 25 21:40:20 ryanvade postfix/master[1572]: daemon started -- version 2.9.6, configuration /etc/postfix
    Mar 26 18:10:31 ryanvade postfix/smtpd[3636]: connect from mail-vc0-f170.google.com[209.85.220.170]
    Mar 26 18:10:33 ryanvade postfix/smtpd[3636]: A64BB2A094F: client=mail-vc0-f170.google.com[209.85.220.170]
    Mar 26 18:10:33 ryanvade postfix/cleanup[3647]: A64BB2A094F: message-id=<CANU8KuVFC7ozehXUgHjt-fpALbe-Z0Gay1+EDLs3Hgyd+qwLJw@mail.gmail.com>
    Mar 26 18:10:33 ryanvade postfix/smtpd[3636]: disconnect from mail-vc0-f170.google.com[209.85.220.170]
    Mar 26 18:10:33 ryanvade postfix/qmgr[1587]: A64BB2A094F: from=<ryanvader82@gmail.com>, size=8962, nrcpt=1 (queue active)
    Mar 26 18:10:33 ryanvade postfix/virtual[3650]: fatal: bad string length 0 < 1: virtual_mailbox_base =
    Mar 26 18:10:34 ryanvade postfix/master[1572]: warning: process /usr/lib/postfix/virtual pid 3650 exit status 1
    Mar 26 18:10:34 ryanvade postfix/master[1572]: warning: /usr/lib/postfix/virtual: bad command startup -- throttling
    Mar 26 18:11:35 ryanvade postfix/virtual[3671]: fatal: bad string length 0 < 1: virtual_mailbox_base =
    Mar 26 18:11:36 ryanvade postfix/master[1572]: warning: process /usr/lib/postfix/virtual pid 3671 exit status 1
    Mar 26 18:11:36 ryanvade postfix/master[1572]: warning: /usr/lib/postfix/virtual: bad command startup -- throttling
    Mar 26 18:12:36 ryanvade postfix/virtual[3679]: fatal: bad string length 0 < 1: virtual_mailbox_base =
    Mar 26 18:12:37 ryanvade postfix/master[1572]: warning: process /usr/lib/postfix/virtual pid 3679 exit status 1
    Mar 26 18:12:37 ryanvade postfix/master[1572]: warning: /usr/lib/postfix/virtual: bad command startup -- throttling
    
  9. VitalkaDrug

    VitalkaDrug New Member

    Messages:
    18
    Likes Received:
    9
    Trophy Points:
    3
    There are traces of successfully received mail message:

    But later I see errors:

    I think you have a mistake in your postfix configuration. Possibly the variable "virtual_mailbox_base" is not set.
    ryanvade and ZZs like this.
  10. ryanvade

    ryanvade Administrator Staff Member Staff Writer

    Messages:
    1,160
    Likes Received:
    392
    Trophy Points:
    83
    Right. I changed the permissions for /var/vmail and it seems to work now.

    Thank you @VitalkaDrug
    ZZs likes this.
  11. Angelbrown Leka

    Angelbrown Leka New Member

    Messages:
    10
    Likes Received:
    4
    Trophy Points:
    3
    @vitalka thanks for sharing the solution mate as there would be plenty of users who might be facing the similar problem. Now after reading this thread they would be able to find solution for their problem. :)

Share This Page