Lossless sound question (solved)

Discussion in 'Linux Audio / Video' started by Donald W. Grimes, May 10, 2014.

  1. Donald W. Grimes

    Donald W. Grimes New Member

    Messages:
    11
    Likes Received:
    4
    Trophy Points:
    3
    I've had a little trouble finding what I am looking for in regards to HD sound in linux. XBMC recently updated to 13.0 Git (standard install with Arch stable) and I lost the DTS Master Audio and Dolby True HD because of issues with pulse audio.

    I am considering a couple of options here, and would welcome feedback:


    1. Convert HD sound formats to flac, but still not clear if I'll get the same sound quality or what settings to use.

    2. Get rid of pulseaudio, without getting rid of Gnome

    3. Get rid of Gnome altogether, which I am otherwise a big fan of.

    4. Find some unknown workaround.

    Something else that I found interesting is that even when the receiver shows DTS HD or True HD, when I look at the signal information for audio input it still shows 48,000 kHz. I pay a great deal of attention to sound quality, and I still "think" it is playing in the HD format, but I want to know for sure.
  2. ryanvade

    ryanvade Administrator Staff Member Staff Writer

    Messages:
    1,260
    Likes Received:
    430
    Trophy Points:
    83
    Donald W. Grimes likes this.
  3. Donald W. Grimes

    Donald W. Grimes New Member

    Messages:
    11
    Likes Received:
    4
    Trophy Points:
    3
    I have been looking over this and got a little sidetracked with some tutorials I have been trying to hunt down. Appreciate the response.
  4. ryanvade

    ryanvade Administrator Staff Member Staff Writer

    Messages:
    1,260
    Likes Received:
    430
    Trophy Points:
    83
    Your issue is a bit odd since XBMC 13 has full pulseaudio support now. Really odd.

    I wonder if there is another reason for your problems.

    http://xbmc.org/xbmc-13-0-gotham-rises/
  5. Donald W. Grimes

    Donald W. Grimes New Member

    Messages:
    11
    Likes Received:
    4
    Trophy Points:
    3
    I'm not sure then. That link links to this

    of.http://wiki.xbmc.org/index.php?title=PulseAudio#PulseAudio_Output_Configuration

    which shows passthrough for the HD sound formats disabled with pulseaudio. That was the information that I had been going off of the get the standard definition passthrough working again. Before the update the option for HD passthrough was there, and now I don't see it.
  6. Donald W. Grimes

    Donald W. Grimes New Member

    Messages:
    11
    Likes Received:
    4
    Trophy Points:
    3
    Switched back to XBMC 12-2 and got the HD passthrough working again with no issues. It's not clear to me what the problem was but with this version doesn't have them.

Share This Page