Linux distros install but then don't complete boot

Discussion in 'Getting Started' started by tandlj, Nov 15, 2011.

  1. tandlj

    tandlj New Member

    Messages:
    2
    Likes Received:
    0
    Trophy Points:
    0
    I have installed several Linux distros (eg latest SuSE, Mint, Ubuntu, Kubuntu, Xubuntu, Fedora) in a PC which also runs Windows 7 as dual boot.

    All install OK and then reboot, displaying the Grub menu and then going nowhere (ie stopping on an empty, or coloured page, or one with a flickering prompt at the top left corner).


    The PC has the Gigabyte GA-MA785GPMT-UD2H board, an AMD Athlon II X4 620 2.6Ghz processor and 4GB memory.
    __________________
    Cheers, Joseph
  2. Rob

    Rob Administrator Staff Member

    Messages:
    565
    Likes Received:
    171
    Trophy Points:
    43
    Joseph,

    I don't have any experience w/ that particular hardware, but it's possible that you need to add some kernel parameters to help the system understand how to use it..

    Hit tab when you're at the grub screen and look at the current boot line. At the end, add a space then type in: nomodeset

    See if you can get it past the black screen with that.

    Also, does it get past the black screen with any of the live cds?
  3. enhu

    enhu New Member

    Messages:
    93
    Likes Received:
    4
    Trophy Points:
    0
    it usually prompt a grub error code when it somehow don't work. Its through that error code that you will find a solutions. so its unusual to have only black screen. :D

    what does nomodeset do?
  4. Rob

    Rob Administrator Staff Member

    Messages:
    565
    Likes Received:
    171
    Trophy Points:
    43
    It will help us to test if he's having a video hardware issue - setting nomodeset will tell the system to use older/generic type drivers for video so we can get X loaded - but may cause the system to run slower or not use the video card to its full potential.

    Once it's booted correctly into X, we can then try to figure out the correct video settings/drivers he may need..
  5. tandlj

    tandlj New Member

    Messages:
    2
    Likes Received:
    0
    Trophy Points:
    0
    Thank you.

    Adding 'nomodeset' made no difference and Live Ubuntu boots normally.

    I have since attempted to boot in recovery mode, where the process fairly quickly stopped at these lines:
    ACPI: Power Button [PWRF]
    ACPI: processor limited to max C-state 1

    Then, returning to the PC after a while and reviving the display with lifting and moving the mouse, the screen showed different lines:
    udevd: '/sbin/modprobe -bv pci [some numbers], terminated by signal 9 (killed)
    udevd: '/sbin/modprobe -bv acpi [some numbers], terminated by signal 9 (killed)
    udevd: PNP0700 -bv pci [some numbers], terminated by signal 9 (killed)
    and some more lines, all similar to this one:
    [602.375404] logitech 0003:0460:c517:input,hiddev0, hidraw 1:USB HID V1.10 Mouse[Logitech USB Receiver] on usb-0000:00:12.0-3/input1
    to which was added after a little while:
    INFO: rcu_sched_state detected stall on CPU0 (t=16219, jiffies)
    INFO: rcu_sched_state detected stalls on CPUs/tasks {0} (detected by 1, t=16219, jiffies)
    _______________
    Cheers, Joseph
  6. Skaperen

    Skaperen New Member

    Messages:
    2
    Likes Received:
    0
    Trophy Points:
    0
    You have said that the install process works OK. I assume that was running in graphical mode. That should mean your video card/chip is supported. But can you tell us what video card/chip it is? If you don't know, boot the Live Mode from the DVD you made, open a terminal, and do "lspci". Look for a line that has "vga" or "video". That should give more info for us.

    I would more suspect the dual boot setup is a problem. If you could temporarily swap the hard drive with an empty one and do a single boot install for a frame of reference, this can help. If it also fails to boot, then we focus on some aspect of the machine and/or distro. If it boots and runs OK then we focus on the dual boot configuration.

    Dual boot with Windows is often difficult. If setting up two hard drives in the machine is an option, with Linux on the 2nd drive, and selecting that drive in the BIOS boot selector if you have one, can get around some of the problems.

    The ultimate solution is two machines and a KVM box. We know you'll love Linux and want to use it a lot. But not everyone can give up Windows for many reason like doing work development at home, other users in the family, etc. Rebooting often gets tedious and annoying and you'll hate switching around.

    Short of two machines there is the virtual machine solution. There are choices of software (vmware, qemu, etc) and roles (Linux on Windows, Windows on Linux).
  7. Victor Leigh

    Victor Leigh Member

    Messages:
    209
    Likes Received:
    7
    Trophy Points:
    18
    I have faced this problem with some newer distros because of my old pc. What I did was add "noacpi noapic nolapic" to the end of the boot parameters. Try and see if it works.

Share This Page