libudev not installed??

Discussion in 'General Linux' started by Caio Gubel, Sep 13, 2013.

  1. Caio Gubel

    Caio Gubel New Member

    Messages:
    2
    Likes Received:
    0
    Trophy Points:
    1
    Hello

    I am trying to create a libusb compatible with my cross-compiled system. I tried to download and compile the source but in the configure procedure (see below) I got a problem:

    ./configure CC=mipsel-linux-uclibc-gcc --host=mipsel-linux --build=i686-pc-linux-gnu CFLAGS=-I/usr/include LDFLAGS=-L/usr/lib
    .....
    .....
    checking libudev.h usability... yes
    checking libudev.h presence... no
    configure: WARNING: libudev.h: accepted by the compiler, rejected by the preprocessor!
    configure: WARNING: libudev.h: proceeding with the compiler's result
    checking for libudev.h... yes
    checking for udev_new in -ludev... no
    configure: error: "udev support requested but libudev not installed"

    However when I check for libudev it is there:

    [root@localhost libusb-1.0.16-rc10]# yum install libudev-devel
    Loaded plugins: langpacks, refresh-packagekit
    Package systemd-devel-204-11.fc19.i686 already installed and latest version
    Nothing to do

    I also checked the files and they are there:


    [root@localhost /]# locate -r libudev*
    /opt/google/chrome/libudev.so.0
    /usr/include/libudev.h
    /usr/lib/libudev.so
    /usr/lib/libudev.so.1
    /usr/lib/libudev.so.1.3.5

    Can someone help me fix this? Any help would be wonderful!

    Thanks

    Caio

Share This Page