libQtGui.so.4

Discussion in 'General Linux' started by VishalM, Dec 6, 2013.

  1. VishalM

    VishalM New Member

    Messages:
    2
    Likes Received:
    0
    Trophy Points:
    1
    I am trying to launch an app from command line and I keep getting the following error:

    error while loading shared libraries: libQtGui.so.4: cannot open shared object file: No such file or directory

    I have verified the rpms and ran ldconfig.


    Please help!!
  2. lobo

    lobo Active Member

    Messages:
    130
    Likes Received:
    74
    Trophy Points:
    28
    That lib is part of qt4-x11 - it would help if you stated which distro you're running and which app you are trying to run...?
  3. VishalM

    VishalM New Member

    Messages:
    2
    Likes Received:
    0
    Trophy Points:
    1
    My apologies Lobo.
    SLED 10 SP4_P1 version 28 - Kernel
    I am trying to run an in house app that populate inventory forecast based on certain # of weeks history.

    I verified the following does exist on the Server
    libqt4-4.7.2-160.1
    libqt4-sql-4.7.2-160.1
    libqt4-sql-sqlite-4.7.2-160.1
    libQtWebKit4-4.7.2-160.1
    libqt4-x11-4.7.2-160.1
  4. lobo

    lobo Active Member

    Messages:
    130
    Likes Received:
    74
    Trophy Points:
    28
    Presumably you paid for SLED, which means paid support, why not use it...?

    Failing that, check that libQtGui.so.4 actually exists on your system.

    Also if you're running 64 bit and the in house app is 32 bit, install the ia32 libs.

Share This Page