Intel WiFi Link 1000BGN in Lubuntu.

Discussion in 'Getting Started' started by Murp, Aug 1, 2014.

  1. Murp

    Murp New Member

    Messages:
    24
    Likes Received:
    5
    Trophy Points:
    3
    Sorry for creating so many topics, heh.


    I'm running an Acer Aspire One Netbook with a Intel WiFi Link 1000BGN wifi adapter thingy inside it.

    I recently tried Linux Lite, which is based on Ubuntu, and it autodetected my Wifi card and I was able to get online no problems.

    I just tried Lubuntu, which is obviously also based on Ubuntu, and it did NOT autodetect my Wifi card. I'm not sure why.

    DuckDuckGoing lead me to this...
    http://wireless.kernel.org/en/users/Drivers/iwlwifi
    There's two potential drivers for the 1000BGN. Ctrl-F for "iwlwifi-1000-ucode" and you'll see them.

    I downloaded the files. Now, what do I do with them? And can I use them while running a Live USB or do I have to install the OS first?

    Edit: How bizarre.
    http://distrowatch.com/table.php?distribution=lite
    http://distrowatch.com/table.php?distribution=lubuntu
    These two distros have identical package lists. So how could my Wifi autodetect and run fine in Lite but not detect at all in Lubuntu? @_@
    Last edited: Aug 1, 2014
  2. WharfRat

    WharfRat Member

    Messages:
    34
    Likes Received:
    11
    Trophy Points:
    8
    It's most likely the kernel. I have two ASUSTek Computer, Inc. USB-N13 802.11n Network Adapter [Ralink RT3072] that worked flawlessly.

    However, I installed Mint Qiana with the 3.13. kernel and ssh sessions were very slow spitting out errors in the dmesg ring. I compiled an older 3.2 kernel and that remedied the problem.
  3. ryanvade

    ryanvade Administrator Staff Member Staff Writer

    Messages:
    1,333
    Likes Received:
    443
    Trophy Points:
    83
    ucode firmware blobs are placed in /usr/lib/firmware on most Linux distributions.

    The main driver is iwlwifi which is the Intel Wireless Linux driver. iwlwifi is included in the Linux kernel and should be autodetected. The .ucode files are part of the linux-firmware package. I cannot recommend downloading new versions of the ucode files. They should already be included with the linux-firmware package. you can check by looking in the /usr/lib/firmware directory.
    firmware.png
    The reason you see two versions of the ucode file is because of the wireless stack change that happened with the 3.2 kernel. One of the ucode files is for kernels prior to 3.2 the other 3.2 and newer. There is also the API change you have to deal with.

    Could you provide the output of lspci , uname -r, and iwconfig ?

    You may be affected by this bug:
    http://ubuntuforums.org/showthread.php?t=2219014

Share This Page