Intel 7260 Firmware not loaded

Discussion in 'Linux Networking' started by ryanvade, Jul 15, 2013.

  1. ryanvade

    ryanvade Administrator Staff Member Staff Writer

    Messages:
    1,260
    Likes Received:
    429
    Trophy Points:
    83
    Hello everyone, I could use some help. I just got an Intel 7260 Wireless AC Dual band wifi card for my laptop. I have been trying to get it to work, with no success.

    What I have tried:
    First off, the appropriate .ucode files are in /lib/firmware (iwlwifi-7260-7.ucode)
    I have tried using wireless-testing and 3.11.0-rc1 both of which are supposed to compatible with the new API level (6 --> 7).

    For some reason, the iwlwifi module does not seem to be using the firmware:
    modinfo iwlwifi
    filename: /lib/modules/3.11.0-rc1/kernel/drivers/net/wireless/iwlwifi/iwlwifi.ko
    license: GPL
    author: Copyright(c) 2003-2013 Intel Corporation <ilw@linux.intel.com>
    version: in-tree:
    description: Intel(R) Wireless WiFi driver for Linux
    firmware: iwlwifi-100-5.ucode
    firmware: iwlwifi-1000-5.ucode
    firmware: iwlwifi-135-6.ucode
    firmware: iwlwifi-105-6.ucode
    firmware: iwlwifi-2030-6.ucode
    firmware: iwlwifi-2000-6.ucode
    firmware: iwlwifi-5150-2.ucode
    firmware: iwlwifi-5000-5.ucode
    firmware: iwlwifi-6000g2b-6.ucode
    firmware: iwlwifi-6000g2a-5.ucode
    firmware: iwlwifi-6050-5.ucode
    firmware: iwlwifi-6000-4.ucode

    At first I got firmware issues:
    lspci
    0a:00.0 Network controller: Intel Corporation Device 08b1 (rev 63)
    0b:00.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL8111/8168 PCI Express Gigabit Ethernet controller ( rev 07)

    dmesg | grep intel
    [ 24.882215] Bluetooth: hci0 failed to open Intel firmware file: intel/ibt-hw-37.7.10-fw-1.80.2.3.d.bseq(-2)
    [ 24.883334] Bluetooth: hci0 failed to open default Intel fw file: intel/ibt-hw-37.7.bseq

    dmesg | grep iwlwifi
    [ 22.805255] iwlwifi 0000:0a:00.0: irq 46 for MSI/MSI-X
    [ 22.806873] iwlwifi 0000:0a:00.0: request for firmware file 'iwlwifi-7260-6.ucode' failed.
    [ 22.806876] iwlwifi 0000:0a:00.0: no suitable firmware found!
    and the wifi button would blink. Now I am not getting these issues but there is NO wifi.

    Does anyone have any suggestions?

    DevynCJohnson likes this.
  2. ryanvade

    ryanvade Administrator Staff Member Staff Writer

    Messages:
    1,260
    Likes Received:
    429
    Trophy Points:
    83
    This fixed it:
    #
    # Debugging Options
    #
    CONFIG_IWLWIFI_DEBUG=y
    CONFIG_IWLWIFI_DEBUGFS=y
    CONFIG_IWLWIFI_DEBUG_EXPERIMENTAL_UCODE=y
    CONFIG_IWLWIFI_DEVICE_TRACING=y
    CONFIG_IWLWIFI_P2P=y
    CONFIG_IWLEGACY=m
    CONFIG_IWL4965=m
    CONFIG_IWL3945=m
    wulftone and DevynCJohnson like this.
  3. wulftone

    wulftone New Member

    Messages:
    1
    Likes Received:
    0
    Trophy Points:
    1
    I had the same issue, with the same wifi card, but I just used 3.11-rc4 and threw the ucode into /lib/firmware and it worked.

    I am curious, though, what is the _oldest_ kernel we could use and still have our wifi function? I have a suspicion that the HD 4400 graphics is supported in earlier kernels, but not the wifi... though the i915 driver in kernel 3.11 is buggy. I'd rather have wifi than graphics, of course, but it would be nice to have both.
  4. ryanvade

    ryanvade Administrator Staff Member Staff Writer

    Messages:
    1,260
    Likes Received:
    429
    Trophy Points:
    83
    The oldest kernel that supports the 7260 is the 3.11-rc1...
    Last edited: Aug 16, 2013
    wulftone likes this.
  5. Aylen

    Aylen New Member

    Messages:
    1
    Likes Received:
    1
    Trophy Points:
    1
    Hi.

    Just curious on which file you edited to make the changes?

    Thanks.
    ryanvade likes this.
  6. ryanvade

    ryanvade Administrator Staff Member Staff Writer

    Messages:
    1,260
    Likes Received:
    429
    Trophy Points:
    83
    The kernel configuration file. The .config file.... I have attached a sample of my .config file for linux-3.11-rc5.

    Attached Files:

  7. Svartisen

    Svartisen New Member

    Messages:
    2
    Likes Received:
    0
    Trophy Points:
    1
    Thanks for the tip it worked for me, at least for kernel 3.11. But It did not work for 3.16. Why? When I compared both config files, the file for 3.16 did not have the lines:

    CONFIG_IWL4965=m
    CONFIG_IWL3945=m

    I tried two options of how to change them, but without positive results. I would be grateful for some tips. For the time being, I'm stuck with the 3.11 kernel.
  8. ryanvade

    ryanvade Administrator Staff Member Staff Writer

    Messages:
    1,260
    Likes Received:
    429
    Trophy Points:
    83
    3.16.3-1 is working fine for me. The kernel configuration options that apply are as following:
    Code:
    CONFIG_IWLWIFI=m
    CONFIG_IWLWIFI_LEDS=y
    CONFIG_IWLWIFI_OPMODE_MODULAR=y
    CONFIG_FW_LOADER=y
    
    You may want to update the firmware blobs on your system.
    http://git.kernel.org/cgit/linux/kernel/git/firmware/linux-firmware.git/

    which goes into /usr/lib/firmware
  9. Svartisen

    Svartisen New Member

    Messages:
    2
    Likes Received:
    0
    Trophy Points:
    1
    Could you change it for me (you'll find mine enclosed) or attach a proper file? I'm not sure which lines I should modify. Some of the ones you've posted appear in several places. Does it mean I will have to modify the kernel file each time I upgrade it?

    Attached Files:

  10. ryanvade

    ryanvade Administrator Staff Member Staff Writer

    Messages:
    1,260
    Likes Received:
    429
    Trophy Points:
    83

Share This Page