Installed Kubuntu 13.10 but like my 12.10 look better how do I

Discussion in 'General Linux' started by URDRWHO, Mar 9, 2014.

  1. URDRWHO

    URDRWHO Member

    Messages:
    94
    Likes Received:
    6
    Trophy Points:
    8
    I was wondering how to get back to the look of Kubuntu 12.10. The setting on Kubuntu 13.10 have a lot of tweaking (which is good) but I can't find something to match the 12.10.

    The panel color in 12.10 handled icons much better. The fonts in applications were much better. Some applications the menu fonts are so bad they are almost imperceptible.

    If I use the oxygen desktop theme, the fonts can be seen well (panel and apps) but not always. If the apps have dark colored fonts, they disappear with such a black theme. I use a widget clock and it get colored black (don't like it).

    It would be nice if there was FAQ that told what each and every setting does in the system/application appearance and the system/workplace appearance.

    For the most part I like Kubuntu 13.10.

  2. labrat

    labrat Active Member

    Messages:
    104
    Likes Received:
    42
    Trophy Points:
    28
    Best Answer
    Before you take the hasty step of messing with the wl driver (broadcom-sta), which may not even support your device, have another look at your dmesg:
    Code:
    [   23.088259] b43-phy0: Broadcom 4306 WLAN found (core revision 5)
    [   23.112013] b43-phy0: Found PHY: Analog 2, Type 2 (G), Revision 2
    [   23.136168] Broadcom 43xx driver loaded [ Features: PNL ]
    Code:
    [   23.898108] b43-phy0 ERROR: Firmware file "b43/ucode5.fw" not found
    [   23.898115] b43-phy0 ERROR: Firmware file "b43-open/ucode5.fw" not found
    [   23.898119] b43-phy0 ERROR: You must go to http://wireless.kernel.org/en/users/Drivers/b43#devicefirmware and download the correct firmware for this driver version. Please carefully read all instructions on this website.
    This should be enough to get the missing firmware installed:
    Code:
    # apt-get install firmware-b43-installer
    (in the multiverse repository)

    Unloading and loading b43 should be enough to get a working connection
    Code:
    # modprobe -r b43 ssb ; modprobe b43
    (pretty sure I posted something like this in this forum recently)
  3. labrat

    labrat Active Member

    Messages:
    104
    Likes Received:
    42
    Trophy Points:
    28
    It's KDE so you just configure it how you want...

    How did you get from one 'buntu release to the next? Reinstall or upgrade?
  4. URDRWHO

    URDRWHO Member

    Messages:
    94
    Likes Received:
    6
    Trophy Points:
    8
    Upgraded.

    I believe it has to do with the Nouveau driver that is now part of the kernel. Previously in 12.10 I was given the Nvidia driver to use but now Nouveau is the default. I tried to install Nvidia but it was nothing but problems.

    It looks a bit better now that I have anti-aliasing set. I've set many other things that has made it more palatable. The panel is icons are still a bit transparent.

    Plus I believe the Nouveau is slower than the Nvidia G-Force driver that I previously had in 12.10.

  5. labrat

    labrat Active Member

    Messages:
    104
    Likes Received:
    42
    Trophy Points:
    28
    nouveau has been around and part of the kernel, for a long time.

    nouveau is always the default, the nvidia driver is installed by the user. 'buntu provide a front end for installing proprietary drivers and you would have installed it from there.

    proprietary drivers, like the nvidia driver, often don't survive xorg or kernel upgrades let alone upgrades of the whole system - purging it and reinstalling it usually does the trick.

    Do you know what nvidia GPU you have? Something like this should show us some useful output:
    Code:
    $ lspci -k | grep -iA5 vga
  6. URDRWHO

    URDRWHO Member

    Messages:
    94
    Likes Received:
    6
    Trophy Points:
    8
    I thought I read that the problem with Nvidia was that the graphics being tied to the kernal. It was why I couldn't install Kubuntu without going to F6 and changing a setting so that the install would load in low graphics mode. What do I know? I only know what I read...I'm a bit of a Linux newbie.

    In 12.10 (or was it 12.04) when I went to additional drivers, the program went searching, the Nvidia driver was there to activate. In my Kubuntu 13.10 when I do a driver search, I get nothing about Nvidia, not one darn thing. I've read enough to decide that it is by design.

    Last night installing the Nvidia driver with some of the internet protocols I could not get it to accept the command to create a config file. What is that command xorg config or something like it. So I was stuck in low graphics mode. I didn't want to crash the entire system so from what I was reading, if I tried some more things there was a chance of crashing the entire system (black screens) so I went back to Nouveau.

    For a system that is supposed to be about open and choice.....choosing a particular graphics driver isn't very open.

    I copied and pasted your command line
    $ lspci -k | grep -iA5 vga

    I get command not found.

    I did use this
    $ lspci | grep VGA
    01:00.0 VGA compatible controller: NVIDIA Corporation NV17M [GeForce4 440 Go 64M] (rev a3)



    Last edited: Mar 11, 2014
  7. URDRWHO

    URDRWHO Member

    Messages:
    94
    Likes Received:
    6
    Trophy Points:
    8
    Just tried it again following this and it is starting in low graphics mode again.

    I want to us the darn driver for my card not some mongrel throw together driver.

    I go to additional drivers and it says "this driver is activated but not currently in use."

    I find many, many other people are in the same boat. Some say -- "You can't use it as long as the old driver is still loaded in the kernel.

    Crap! I purged nvidia like I did last night but now it is starting in low resolution. Apparently neauvou isn't working?????

    https://bugs.launchpad.net/ubuntu/ source/nvidia-graphics-drivers-173/ bug/772207
    Last edited: Mar 11, 2014
  8. Yesyesloud

    Yesyesloud Active Member

    Messages:
    257
    Likes Received:
    126
    Trophy Points:
    43
    With a lot of free beer comes great responsibility... You have to be a good drinker (o_O)

    Jokes apart, broken video drivers are not uncommon after system upgrades, specially with regard to proprietary modules.

    If you want to install proprietary nvidia drivers manually, you have to check the documentation for xorg and kernel versions compatibility. Remember to blacklist nouveau drivers (must be done) and remove any previous Nvidia drivers residues. Some overly careful users blacklist all nvidia drivers but the desired.

    Kernel parameters like nomodeset and noacpi may be needed, try adding it to Grub during boot to see if it helps - if it does, you rather make this change permanent later.

    In case you manage to install the driver through Ubuntu's software channels and it doesn't work, try blacklisting nouveau and adding those kernel parameters to Grub anyway.

    I know what you're passing through... I've had horrible headaches setting up decent drivers for Geforce 6200 on Lubuntu 13.10, a similar distribution.
  9. labrat

    labrat Active Member

    Messages:
    104
    Likes Received:
    42
    Trophy Points:
    28
    You're referring to kernel mode setting. The free drivers use this, the proprietary drivers do not.

    You need to enable repositories containing non free software in order to install the proprietary drivers. It's also possible that something changed, e.g. support for your hardware was dropped by nvidia...

    For proprietary drivers you need a very simple config just to tell xorg to use the driver:
    Code:
    Section "Device"
        Identifier  "Device0"
        Driver              "nvidia"	
    EndSection
    If you use "X -configure" you will get a huge config with too many options you don't need... I doubt any of this will help you however.

    You're merely being melodramatic.

    Works here.

    As I said earlier, support might have been dropped and that GPU is already a relic and is in legacy support for years.

    I'm pretty certain that means the legacy driver you need (~ v100.x) will not install on anything newer than xserver 1.12.x - 'buntu 13.10 includes 1.14.x - so probably no go...

    tl;dr You're probably stuck with nouveau.
    The "driver for your card" is the nouveau driver. If you feel that's a "mongrel" driver, then I would suggest not using GNU/Linux, as all of the other drivers on your system are developed similarly and are not official vendor drivers, but open source equivalents. This is why 99% of your hardware "just works" and you do not have to go trawling the web for drivers...

    Your GPU is simply not well supported anymore and with reference to nouveau there is no 3D support for it: http://nouveau.freedesktop.org/wiki/FeatureMatrix/
    (yours comes under NV10)

    There is also probably no real incentive for the nouveau project to complete work on the 3D features for older NV10/NV20 GPUs

    It won't be bound to the device if it's not the correct driver - which it isn't.

    You read a lot of that, I would suggest taking less notice.

    You can't use 173 with that GPU - 173 supports only the Geforce FX series at a minimum - so that bug report is irrelevant to you.

    You can check if nouveau is loaded
    Code:
    $ lsmod | grep nouv
    You can also try the lscpi -k command and see if the nouveau module is bound to the device - if it isn't then it's probably because it's still blacklisted (nvidia proprietary stuff still installed).

    nouveau should just work once you've removed all traces of the proprietary driver, but you won't get 3D support. This won't effect KDE - just disable display compositing.

    If you still want the proprietary driver, then you will need to revert to using 12.04 LTS which is apparently still supported until 2017...

    Or you could change distribution. Debian wheezy and Centos 6 should still support it as should some older and still supported Slackware releases.
    Last edited: Mar 11, 2014
  10. URDRWHO

    URDRWHO Member

    Messages:
    94
    Likes Received:
    6
    Trophy Points:
    8
    Yikes! I guess that put my ranting in its place.
    "If you feel that's a "mongrel" driver, then I would suggest not using GNU/Linux, a"

    The box that I am playing with is an old HP laptop with 2 gig of ram. I just get a bit out of shape when Linux goes bad on me.

    Before putting a distro on my main desktop....I need to be 100% certain of what I am doing.

    I am also missing an xorg.conf.

    When booting to kernel 3.5 I can set the screen resolution to 1280 x 800
    When booting to kernel 3.11 I can only set it to 1024 x 768.




    Last edited: Mar 12, 2014
  11. labrat

    labrat Active Member

    Messages:
    104
    Likes Received:
    42
    Trophy Points:
    28
    You shouldn't need an xorg.conf unless you are using a proprietary VGA driver, in which case the minimal example in my last post is enough.

    You need to get back to a clean starting point, do the following
    Code:
    # apt-get install aptitude
    Code:
    $ aptitude search ~invidia
    post output of the second one

    Also, did you ever install drivers directly from nvidia's website?
  12. URDRWHO

    URDRWHO Member

    Messages:
    94
    Likes Received:
    6
    Trophy Points:
    8
    I do not remember going to the site to install any drivers.

    This is what I received after the command --

    i A nvidia-304 - NVIDIA legacy binary driver - version 304.119
    i A nvidia-libopencl1-304 - NVIDIA OpenCL Driver and ICD Loader library
    i A nvidia-opencl-icd-304 - NVIDIA OpenCL ICD

    Until I get this figured out, I'm going to move the 3.5 kernel up to the default position in Grub.

    Last edited: Mar 12, 2014
  13. labrat

    labrat Active Member

    Messages:
    104
    Likes Received:
    42
    Trophy Points:
    28
    You need to get rid of that stuff... it's the 304 legacy driver and that one definitely doesn't support your GPU, that being installed is causing nouveau to be blacklisted - the two cannot coexist. nouveau may not be perfect (i.e. no 3D support for your GPU) but it supports your GPU - 304.x legacy doesn't.

    So it should be ok to turn that search into a purge and get rid
    Code:
    # aptitude purge ~invidia
  14. URDRWHO

    URDRWHO Member

    Messages:
    94
    Likes Received:
    6
    Trophy Points:
    8
    Will do. I know that I never manually blacklisted nouveau but maybe Nvidia being in the mix automatically blacklists it.

    Kernel 3.5 looks so much better with the high resolution icons / fonts, etc. I hope purging nividia restores the 3.11 kernel.

    I know I've purged using Nvidia but never ~invidia. I'm guessing that will find more nividia


    Last edited: Mar 12, 2014
  15. URDRWHO

    URDRWHO Member

    Messages:
    94
    Likes Received:
    6
    Trophy Points:
    8
    Using that wildcard in the nvidia purge was the ticket!!!!!!

    I can now boot into kernel 3.11.0-18 and get 1280 x 800 resolution. Icons look good, fonts are good. OpenGl Control Module is working, showing my [GeForce4 440 Go 64M].

    Good work labrat. Give yourself a big pat on your back!
    Last edited: Mar 12, 2014
  16. labrat

    labrat Active Member

    Messages:
    104
    Likes Received:
    42
    Trophy Points:
    28
    As I said in previous posts, the nvidia driver package blacklists the nouveau module (or disables KMS).

    Module blacklists are usually found in /etc/modprobe.d/ and the file ends with .conf

    e.g. blacklist.conf

    A typical stanza is e.g.
    Code:
    blacklist nouveau
    ~i means match installed "nvidia", so anything which is installed with "nvidia" in the name gets removed and purged. This is an aptitude thing.
    Well that's a bonus. The nouveau feature matrix does say that 3D support for NV10/NV20 is "mostly" done - but that can often mean that nothing works in my experience... so good it works.

    It's likely that removing the nvidia proprietary driver removed nvidia's libgl and replaced it with the standard mesa libgl, which is why your 3D is (at least partially) working again. you should also be getting kernel mode setting and the fbcon (native resoltuion framebuffer console) that goes with it.

    I would suggest sticking with nouveau at this point - you may be tempted to mess with nvidia proprietary drivers again, but I'd advise against it as you'll end up in the same situation.

    One last check which can be useful:
    Code:
    $ glxinfo | grep render
    Last edited: Mar 12, 2014
  17. URDRWHO

    URDRWHO Member

    Messages:
    94
    Likes Received:
    6
    Trophy Points:
    8
    I can gaurantee that I will not be trying the Nvidia install.

    Looks like I have a few items that failed using the command --

    libGL error: failed to create dri screen
    libGL error: failed to load driver: nouveau
    direct rendering: Yes
    GLX_MESA_multithread_makecurrent, GLX_MESA_query_renderer,
    OpenGL renderer string: Gallium 0.4 on llvmpipe (LLVM 3.4, 128 bits)
    GL_MESA_ycbcr_texture, GL_NV_blend_square, GL_NV_conditional_render,

    Failed to load nouveau?

    I have a notification that updates are available. Looking at them some are mesa-glx, mesa-dri and more of them. I see some xserver-xorg stuff.

    I'll do the update and then run the command again after the complete update.

    Did the update and the command returns the same string.

    Searched the modprobe.d folder and didn't see any blacklist for nouveau. There are blacklisted items but I don't know how they got added.


    Last edited: Mar 13, 2014
  18. labrat

    labrat Active Member

    Messages:
    104
    Likes Received:
    42
    Trophy Points:
    28
    You have direct rendering and gallium running on the llvmpipe (software rasteriser). There still appears to be some breakage with libgl however.

    A few more things to check:

    - Remove /etc/X11/xorg.conf if you haven't already done so

    - Have a look in /etc/modprobe.d/ for any references to nouveau - ensure that there are no options configured to disable KMS.

    - Do the updates and once they're done do

    Code:
    # apt-get reinstall libgl1-mesa-dri libdrm2 libdrm-nouveau2 xserver-xorg-core
    This will reinstall the relevant libs for mesa/drm and the xserver. This is a good idea because proprietary drivers can clobber (overwrite) files from these packages - though nowadays there are package installation/removal scripts which should take care of this.

    - Then provide the glxinfo output again

    - Also provide this one (important)
    Code:
    $ egrep 'WW|EE' /var/log/Xorg.0.log
  19. URDRWHO

    URDRWHO Member

    Messages:
    94
    Likes Received:
    6
    Trophy Points:
    8
    Do you mean removing the entire X11 folder or just xorg.conf?

    I don't have a plain xorg.conf.

    Anything that is a config file I have these:

    xorg.conf.backup
    xorg.conf.dist-upgrade - 201403062019
    xorg.conf.dist-upgrade - 201403070206
    xorg.conf.nvidia-xconfig-original
    XvMCConfig
    Xwrapper.config

    Out of the above I would think the nvidia would be a good one to delete but I'm not deleting anything until I know if it is or isn't the entire folder that I should delete???

    Looked at modprobe.d again and there isn't anything close to nouveau.

    I know that even though I choose composting type to be OpenGl that for some reason eventually it goes XRender. I don't think my video chipset plays well with OpenGL.

    I can't get this command to run

    # apt-get reinstall libgl1-mesa-dri libdrm2 libdrm-nouveau2 xserver-xorg-core

    Good or bad -- hope I didn't mess upp but I used this one

    sudo apt-get install --reinstall libgl1-mesa-dri libdrm2 libdrm-nouveau2 xserver-xorg-core

    Should mesa-glx have been in the above command line?

    sudo egrep 'WW|EE' /var/log/Xorg.0.log

    (WW) warning, (EE) error, (NI) not implemented, (??) unknown.
    [ 45.468] (WW) The directory "/usr/share/fonts/X11/cyrillic" does not exist.
    [ 45.468] (WW) The directory "/usr/share/fonts/X11/100dpi/" does not exist.
    [ 45.468] (WW) The directory "/usr/share/fonts/X11/75dpi/" does not exist.
    [ 45.468] (WW) The directory "/usr/share/fonts/X11/100dpi" does not exist.
    [ 45.468] (WW) The directory "/usr/share/fonts/X11/75dpi" does not exist.
    [ 45.471] Initializing built-in extension MIT-SCREEN-SAVER
    [ 45.700] (WW) Warning, couldn't open module nvidia
    [ 45.700] (EE) Failed to load module "nvidia" (module does not exist, 0)
    [ 45.750] (WW) Warning, couldn't open module nvidia
    [ 45.750] (EE) Failed to load module "nvidia" (module does not exist, 0)
    [ 45.753] (WW) Falling back to old probe method for vesa
    [ 45.753] (WW) Falling back to old probe method for modesetting
    [ 45.753] (WW) Falling back to old probe method for fbdev
    [ 46.612] (WW) evdev: Microsoft Microsoft Wireless Optical DesktopĀ® 2.10: ignoring absolut

    Last edited: Mar 13, 2014
  20. labrat

    labrat Active Member

    Messages:
    104
    Likes Received:
    42
    Trophy Points:
    28
    I meant just xorg.conf - do not remove /etc/X11

    I would suggest having a look in /etc/X11/xorg.conf.d/ and see if there are any .conf files there I say this because
    something is still trying to load the nvidia module.

    (also you should not need to run that grep command as root)

    It's falling back to xrender because of the libgl errors

    That command is good - I can't see why my command failed - unless you were not running it as root? (prefixing with sudo means running a command as root). You should no longer need to do "install --reinstall", "reinstall" should suffice - interesting if that doesn't work.

    Reinstall libgl1-mesa-glx also if you must.[/quote]
  21. URDRWHO

    URDRWHO Member

    Messages:
    94
    Likes Received:
    6
    Trophy Points:
    8
    I've deleted these, the only files that have any xorg.conf in the file names. Hope it reboots.

    I have a copy on the external drive, if it doesn't work I can go load the live CD and move the deleted files back.

    xorg.conf.backup
    xorg.conf.dist-upgrade - 201403062019
    xorg.conf.dist-upgrade - 201403070206
    xorg.conf.nvidia-xconfig-original

    Not sure why the command didn't work? After it didn't work I did a copy past and still no go.


    [/quote]

Share This Page