How to kill x server on ARCH?

Discussion in 'Desktop / X' started by Yesyesloud, Jan 24, 2014.

  1. Yesyesloud

    Yesyesloud Active Member

    Joined:
    Dec 13, 2013
    Messages:
    345
    Likes Received:
    180
    Hello... I switched to ARCH, and I am wondering how to kill the X server. I researched a lot, nothing has worked so far. Ctrl+alt+backspace won't do it. Ctrl+alt+f1 won't do a thing (it could at least help me kill X, but the command line won't show up). Killing it manually through a terminal emulator will only make it restart. Stopping the display manager service does nothing, oddly. Any advice? A Grub approach is welcome, but I'd like to be able to do it any time, not only during boot.

     
  2. ryanvade

    ryanvade Administrator Staff Member Staff Writer

    Joined:
    Aug 4, 2012
    Messages:
    1,868
    Likes Received:
    659
    Best Answer
    Are you using a login manager? (KDM, GDM, Lightdm, .....)
    Killing it with systemctl will also kill X.

    Edit your xorg.conf and add
    Code:
    Section "ServerFlags"
    Option "DontZap" "False"
    EndSection
    then restart. CTRL+ALT+Backspace should work now.

    Also:
     
  3. DevynCJohnson

    DevynCJohnson Well-Known Member Staff Member Staff Writer

    Joined:
    May 21, 2013
    Messages:
    1,635
    Likes Received:
    1,285
    If you are using a laptop, try including "fn" with Ctrl+alt+f1.

    Or, why not use this command with Root privileges - "init 3"
     
    Haider92 likes this.
  4. Yesyesloud

    Yesyesloud Active Member

    Joined:
    Dec 13, 2013
    Messages:
    345
    Likes Received:
    180
    Hey, Devyn, thanks. I've just tried ctrl+alt+fn+f1, lucklessly still. I have tried "init 3" before... It returns "Excess arguments"... This is odd :O
     
  5. DevynCJohnson

    DevynCJohnson Well-Known Member Staff Member Staff Writer

    Joined:
    May 21, 2013
    Messages:
    1,635
    Likes Received:
    1,285
    Evidently, Arch manages this much differently than other systems. If you figure it out, please share with us.

    Also, when you directly address someone, you can type "@" and then their username. This will then alert them even if they never participated in the thread.
     
    Haider92 likes this.
  6. Yesyesloud

    Yesyesloud Active Member

    Joined:
    Dec 13, 2013
    Messages:
    345
    Likes Received:
    180
    Alright, I'll do that from now on. Since you were in the thread already, I thought it was ok.

    I guess I'll have to prevent X from starting during boot.
     
  7. DevynCJohnson

    DevynCJohnson Well-Known Member Staff Member Staff Writer

    Joined:
    May 21, 2013
    Messages:
    1,635
    Likes Received:
    1,285

    Yeah, it is fine. I just wanted to make sure you knew.
     
    Haider92 likes this.
  8. ryanvade

    ryanvade Administrator Staff Member Staff Writer

    Joined:
    Aug 4, 2012
    Messages:
    1,868
    Likes Received:
    659
    Best Answer
    Are you using a login manager? (KDM, GDM, Lightdm, .....)
    Killing it with systemctl will also kill X.

    Edit your xorg.conf and add
    Code:
    Section "ServerFlags"
    Option "DontZap" "False"
    EndSection
    then restart. CTRL+ALT+Backspace should work now.

    Also:
     
  9. Yesyesloud

    Yesyesloud Active Member

    Joined:
    Dec 13, 2013
    Messages:
    345
    Likes Received:
    180
    Thanks, ryanvade, systemctl was able to stop the display manager service. I'll try the other suggestions later, hotkeys will come handy.
     

Share This Page