How to assign primary screen (Dual monitors question)?

Discussion in 'Desktop / X' started by just-a-guest, Jul 23, 2012.

  1. just-a-guest

    just-a-guest New Member

    Messages:
    2
    Likes Received:
    0
    Trophy Points:
    0
    Hi all. I've notebook with integrate(LVDS) screen and HDMI external monitor. At most cases I'm using HDMI screen, because it's bigger and more convenient. But all program, what I have to open apear on LVDS screen, it's annoying. And when I want to look stream video (such as youtube for example) and try to expand fullscreen -- it's jumping from HDMI to LVDS screen.
    I supposed that "xrandr --output HDMI-0 --primary" could help, and wasted many hours to find how to launch it before kdm. I even tried to compile program for launching my script and then starting kdm and paste it to "/etc/X11/default-display-manager"
    Finally I found that starting kde placed is in "/etc/kde4/kdm/Xsetup" and write there
    xrandr --output HDMI-0 --mode 1920x1080 --primary
    xrandr --output LVDS --mode 1366x768 --left-of HDMI-0


    Now I'm stuck because programs yet suppose LVDS primary screen. Is any ideas what to do?
    P.S.
    Sorry for bad english
    P.P.S.
    KDE settings for monitors don't allow to change LVDS from "absolute" to any other (right-of, left-of and etc.), so it sucks.
  2. Victor Leigh

    Victor Leigh Member

    Messages:
    209
    Likes Received:
    8
    Trophy Points:
    18
    I am using LXDE. It seems to have better controls for dual monitors. You can install LXDE on to your current os.
  3. just-a-guest

    just-a-guest New Member

    Messages:
    2
    Likes Received:
    0
    Trophy Points:
    0
    I figure out what's the reason of a problem. If I enter xrandr --output LVDS --right-of HDMI-0, then programs suppose HDMI primary screen. Seems programs prefer to start somewhere about 0x0 pixels. Ok, but why then "xrandr --output HDMI-0 --primary" do nothing? It's sad.

Share This Page