Great mobile internet - but WiFi...

Discussion in 'Linux Networking' started by Matesax, Mar 19, 2014.

  1. Matesax

    Matesax Member

    Messages:
    56
    Likes Received:
    11
    Trophy Points:
    8
    What can I do when our router have great connection with mobile internet, but Wi-Fi connection from my PC to this router working very bad? Signal quality is 76% - 86%, but site browsing is very lagging etc. (Connection sometimes fail, but bigger problem is low browsing (of websites) quality)... My brothers with Windows not have this problem.

    Adapter - USB TP-Link, PC - AMD64. Now I'm using latest version of Linux kernel - and it's WiFi tools.

    Thank you!

    Last edited: Mar 19, 2014
  2. labrat

    labrat Active Member

    Messages:
    104
    Likes Received:
    43
    Trophy Points:
    28
    Identify the hardware, search for the chipset, look for known problems, etc...
  3. GrumpyOldMan

    GrumpyOldMan Active Member

    Messages:
    149
    Likes Received:
    49
    Trophy Points:
    28
    Make sure there's not too many APs using the same channel...
  4. Matesax

    Matesax Member

    Messages:
    56
    Likes Received:
    11
    Trophy Points:
    8
    The TP-Link USB adapter changing channels in set spectrum...

    Simple situation: I had to wait an half hour - until then it was impossible to reload this page. In previous operating system WiFi failed once per 6-12 hours. But site browsing worked - little bad, but it worked... Now I cannot browsing pages without spending lot of hours. I must waiting, waiting and waiting for loading pages... (Funny story - Aptitude working very nice... :D I can download packages from APT repository...)

Share This Page