Google Voice Your PBX: Creating a Google Voice Profile

Discussion in 'Linux Networking' started by Eric Hansen, Dec 18, 2013.

  1. Eric Hansen

    Eric Hansen Moderator Staff Writer

    Messages:
    124
    Likes Received:
    87
    Trophy Points:
    28
    We set up FreeSWITCH and FusionPBX, but what good is it without any service? That's where we are now.

    For the rest of this guide we will assume two things:
    1. Your Google Voice number is (123) 456-7890
    2. Your personal/cell number is (555) 666-8888
    Replace anything that uses these above numbers with the actual values. Lets begin by first logging into FusionPBX.

    Before continuing though we need to make some changes to our Google Voice settings. Log in and click on the gears icon on the page, then go to Settings. First, make sure "Forwards calls to" is checked for Google chat. Next, click on "Calls" and turn call screening on.

    There's some reports that say call screening needs to be enabled for Google Voice to work with FreeSWITCH, some disagree. We'll support this just to save our butts.

    Step 1: Setting Up an XMPP Profile
    I'm using the "Extended" theme, though it doesn't matter much.

    Google Voice (and Google Talk) use XMPP as its server. Long story short, XMPP is a multi-purpose, modular (extendible) protocol. One of the extensions is called dingaling, which is intended for voice communications (telephony). This is what Google Voice uses and also makes it easy to integrate into various things.

    Go to Accounts->XMPP Manager. You'll see a screen full of nothing right now besides some text. Click on the little piece of paper with a "+" on it (you'll be clicking this a lot). You'll be asked for a profile name, extension, etc... Here's what you should fill in:
    • Profile name: gtalk
    • Username: your Google email address (i.e.: someone@gmail.com)
    • Password: above's password (i.e.: somePassword)
    • XMPP Server: talk.google.com
    • Default Extension: 123456790
    • Click "Advanced"
      • Context: public
      • SASL type: plain
    Click "Save". You'll be taken back to the XMPP Manager screen and there'll be nothing under status. This is because mod_dingaling isn't enabled by default.

    Step 2: Enabling mod_dingaling
    Go to System->Modules and scroll down to "Auto" section. In there you'll see "Dingaling". Click on the image with a small "e" on it on the far right to edit that item.

    Set enabled and default enabled both to true and save. Then on the module screen again scroll to the dingaling entry and click "Start". The page will refresh and dingaling will be loaded.


    Step 3: Checking Authentication
    There's a 50/50 chance you'll have this issue. To make sure you're able to authenticate to Google Voice go to Accounts->XMPP Manager. If "status" for the profile doesn't say "AUTHORIZED" make sure you entered all of the information properly. If its still saying that then make sure Google isn't blocking requests from a certain location/IP and that Google isn't wanting captcha. Both of these stopped me but once I corrected both I was able to connect just fine.

    Attached Files:

    • slide.jpg
      slide.jpg
      File size:
      26.2 KB
      Views:
      107,688
    Last edited: Dec 18, 2013

Share This Page