1. IMPORTANT - 11/13/2015: In light of a possible breach we have scrubbed all passwords. You will need to request a password reset through the site. Click here for more information.

ftp server on ubuntu

Discussion in 'General Server' started by reza, Aug 17, 2013.

  1. reza

    reza New Member

    Aug 17, 2013
    Likes Received:
    I am running Ubuntu as a guest OS via VMWare on my desktop. It's a Virtual Appliance from Turnkey Linux. I have been fighting with the FTP for some time. I have ProFTPd installed. At one point I was able to FTP in from my desktop using filezilla but was unable to install joomla because the joomla app could not ftp into the localhost, which is a step in the installation process on linux.

    I don't think the ftp service is even running as I do not see anything listening on port 21.

    root@lamp:~# sudo netstat -l
    Active Internet connections (only servers)
    Proto Recv-Q Send-Q Local Address Foreign Address State
    tcp 0 0 *:12320 *:* LISTEN
    tcp 0 0 *:12321 *:* LISTEN
    tcp 0 0 *:12322 *:* LISTEN
    tcp 0 0 localhost:mysql *:* LISTEN
    tcp 0 0 *:www *:* LISTEN
    tcp 0 0 localhost:smtp *:* LISTEN
    tcp 0 0 *:https *:* LISTEN
    tcp6 0 0 [::]:ssh [::]:* LISTEN
    udp 0 0 *:12321 *:*
    udp 0 0 *:*
    udp 0 0 localhost:ntp *:*
    udp 0 0 *:ntp *:*
    udp6 0 0 fe80::20c:29ff:feee:ntp [::]:*
    udp6 0 0 ip6-localhost:ntp [::]:*
    udp6 0 0 [::]:ntp [::]:*

    what is my next step? if i issue the start command nothing changes.

    here is my proftpd.conf file
    my site
    # /etc/proftpd/proftpd.conf -- This is a basic ProFTPD configuration file.
    # To really apply changes reload proftpd after modifications.

    # Includes DSO modules
    Include /etc/proftpd/modules.conf

    # Set off to disable IPv6 support which is annoying on IPv4 only boxes.
    UseIPv6 on

    ServerName "Debian"
    ServerType inetd
    DeferWelcome off

    MultilineRFC2228 on
    DefaultServer on
    ShowSymlinks on

    TimeoutNoTransfer 600
    TimeoutStalled 600
    TimeoutIdle 1200

    DisplayLogin welcome.msg
    DisplayChdir .message true
    ListOptions "-l"

    DenyFilter \*.*/

    # Use this to jail all users in their homes
    # DefaultRoot ~

    # Users require a valid shell listed in /etc/shells to login.
    # Use this directive to release that constrain.
    # RequireValidShell off
  2. nixsavy

    nixsavy Member

    May 21, 2013
    Likes Received:
    As you have installed proftpd, First of all check if service is running or not

    sudo /etc/init.d/proftpd status
    If its not running start as below:

    sudo /etc/init.d/proftpd start

Share This Page