Dual Monitor issue

Discussion in 'Linux Audio / Video' started by Mandapanda82, Jul 7, 2013.

  1. Mandapanda82

    Mandapanda82 New Member

    Messages:
    25
    Likes Received:
    0
    Trophy Points:
    1
    Not sure if this is the right place to ask this question, so I'll repost if need be.
    The problem that I'm having is running my two monitors. I have one Asus monitor and one HP monitor. In windows I have it set up that my Asus monitor is my primary screen and my HP is the other half and continuation of the first. I installed Linux on a secondary drive, booted in Linux and when every i tried to switch off of mirror mode and onto a similar setup my hp went dead and my ASUS only showed a cursor and I had to do a hard restart. I do not want to keep doing that. so if there a way to fix it, beside keeping it in mirror mode or the hp off. which by the way when i restart it it comes up in the setting with the hp monitor off. If you need specific makes of the monitors just let me know. Thanks in advice

  2. ryanvade

    ryanvade Administrator Staff Member Staff Writer

    Messages:
    1,239
    Likes Received:
    418
    Trophy Points:
    83
    Do you have up to date graphics drivers? If you are using Nvidia, in nvidia-settings you can switch correctly. In ATI there should be the same thing. Are the monitors both using DVI (or VGA)?
  3. WeAreGeek

    WeAreGeek Member

    Messages:
    38
    Likes Received:
    5
    Trophy Points:
    8
    What kind of graphics card(s) are you using?

    [edit: Apparently I was viewing a cached version of this thread, and didn't see the post above until I hit Post Reply]
  4. Mandapanda82

    Mandapanda82 New Member

    Messages:
    25
    Likes Received:
    0
    Trophy Points:
    1
    I'm using a Geforce GTX 650 graphics card with NVIDIA The ASUS has DVI display and the HP vs17 is running a VGA display because it is an older monitor as well. And I downloaded an update of the driver. But this was all done on the windows hard drive, I assume I have to do this on my Linux drive as well. I know that may sound like a stupid question, so keep in mind I'm new at the Linux and where would I get the driver for Linux ?
  5. WeAreGeek

    WeAreGeek Member

    Messages:
    38
    Likes Received:
    5
    Trophy Points:
    8
  6. Mandapanda82

    Mandapanda82 New Member

    Messages:
    25
    Likes Received:
    0
    Trophy Points:
    1
    I think I did that but when installed the drivers one it didn't fix the problem and two I didn't get the nvidia control panel that I got in windows. When I switched the HP monitor on and applied the setting the screen went dark and I had no controls. I was forced to do a hard restart and now I'm having a hard time getting into the bios to boot that Linux drive. So I'm having hard time checking if anything went really wrong, but so far my windows hard disk hasn't been effected.
  7. ryanvade

    ryanvade Administrator Staff Member Staff Writer

    Messages:
    1,239
    Likes Received:
    418
    Trophy Points:
    83
    Okay how are your monitors setup in the OS? You can check with nvidia-settings:
    in a command prompt run nvidia-settings as root. Then click on
    X Server Display Configuration. This is where you can enable and disable the extra monitors.

    For your GTX 650 you may want to use nvidia-319 and not the default nvidia-304. To get the 319 drivers:
    Assuming Ubuntu...
    Code:
    sudo add-apt-repository ppa:ubuntu-x-swat/x-updates 
    Code:
    sudo apt-get update && sudo apt-get install nvidia-319
    WeAreGeek likes this.
  8. Mandapanda82

    Mandapanda82 New Member

    Messages:
    25
    Likes Received:
    0
    Trophy Points:
    1
    no, i'm using Linux mint 15 on my desktop. But i'll check the setting once I boot in linux next time. but last time I did notice a change. instead of the hp monitor being default off it was on and set to primary and my primary was set as the secondary. i didn't play with any setting for fear it may mess up again. i wanted it to shut down properly this time.
  9. ryanvade

    ryanvade Administrator Staff Member Staff Writer

    Messages:
    1,239
    Likes Received:
    418
    Trophy Points:
    83
    That makes sense. The nvidia driver change...
    Anyway. For mint you do the same as above. Or you can use edgers instead of x-swats
    Code:
    sudo add-apt-repository ppa:xorg-edgers
  10. WeAreGeek

    WeAreGeek Member

    Messages:
    38
    Likes Received:
    5
    Trophy Points:
    8
    When you have installed the nvidia drivers in Linux, you should be able to launch nvidia-settings (I believe the menu item is called NVIDIA X Server Settings). With this tool you should be able to configure different multi-monitor setups.

    Mind you: nothing you do in windows effects things in Linux and vice versa.
  11. WeAreGeek

    WeAreGeek Member

    Messages:
    38
    Likes Received:
    5
    Trophy Points:
    8
    You needn't (and shouldn't) run nvidia-settings as root. Configuring it as a regular user works and that way it can't mess up your system.
  12. ryanvade

    ryanvade Administrator Staff Member Staff Writer

    Messages:
    1,239
    Likes Received:
    418
    Trophy Points:
    83
    Most of the time. If you can't save the .conf file any changes you made might not be saved. And then you have to re-run nvidia-settings.

    I guess it would be a good idea to check first though. Good point. :)
  13. Mandapanda82

    Mandapanda82 New Member

    Messages:
    25
    Likes Received:
    0
    Trophy Points:
    1
    I think I did it, I going to do a standard shut down and see if later today everything comes back like it should. But i think it worked.
  14. Mandapanda82

    Mandapanda82 New Member

    Messages:
    25
    Likes Received:
    0
    Trophy Points:
    1
    okay, so far so good. The monitor came up, but the setting hadn't seemed to save. So i checked and did a save, which may have been why it didn't work the last time. And the bios came up, but when linux was loading I did get a weird error. i didn't catch the whole thing but it seemed like something failed but then linux started up. Also i need a better short cut to choose which os to run during start up but i might have to put that question somewhere else.
  15. ryanvade

    ryanvade Administrator Staff Member Staff Writer

    Messages:
    1,239
    Likes Received:
    418
    Trophy Points:
    83
    If you want to view more information during boot, that error maybe, you can remove the 'quiet splash' from the kernel boot line in the grub.cfg file.
    OR, you could look at /var/log/boot.log , /var/log/kern.log, etc. dmesg also.

    The setting didn't change because the xorg.conf (/etc/X11/xorg.conf) was not saved. Which can only be done as root. However this is very dangerous if you don't know what you are doing.
  16. WeAreGeek

    WeAreGeek Member

    Messages:
    38
    Likes Received:
    5
    Trophy Points:
    8
    You can add the following command to your startup programs, in order to load your NVIDIA X Settings configuration at the start of your session:
    Code:
    sh -c '/usr/bin/nvidia-settings --load-config-only'

Share This Page