Creating access point problem

Discussion in 'Linux Networking' started by mihamobili, May 25, 2012.

  1. mihamobili

    mihamobili New Member

    Messages:
    1
    Likes Received:
    0
    Trophy Points:
    0
    Hello, I'm trying to create access point on Lenovo laptop with Edimax usb adaptor (EW-7811Un).

    I configured my hostapd.conf file:

    interface=wlan1 (wlan0 was computers wifi card)
    bridge=br0
    driver=nl80211
    ssid=test
    hw_mode=g
    channel=1
    auth_algs=3
    #ieee80211n=1

    wpa=3
    ignore_broadcast_ssid=0
    wpa_passphrase=mypassword
    wpa_key_mgmt=WPA-EAP
    wpa_pairwise=TKIP
    rsn_pairwise=CCMP

    and dhcpd.conf

    ddns-update-style none;
    ddns-updates off;
    default-lease-time 600;
    subnet 192.168.55.0 netmask 255.255.255.0{
    range 192.168.55.72 192.168.55.93;
    option subnet-mask 255.255.255.0;
    option broadcast-address 192.168.55.255;
    option routers 192.168.55.1;
    }

    So now when I start hostapd with these setups and try to connect to it with adroid mobile or other computer, it looks at first everything ok, but when it comes after the association it returns deauthenticated even though it wrote authenticated earlyer.


    wlan1: STA xx : xx : xx : xx : xx : xx IEEE 802.11: associated (aid 1)
    AP-STA-DISCONNECTED xx : xx : xx : xx : xx : xx
    wlan1: STA xx : xx : xx : xx : xx : xx IEEE 802.11: deauthenticated

    After debuging I got the error code 1=unspecifiedReason, Client associated but no longer authorized.

    Can anyone help me with this problem?

Share This Page