Copy and paste problem please help me

Discussion in 'Getting Started' started by DoraGototo, Aug 21, 2013.

  1. DoraGototo

    DoraGototo New Member

    Joined:
    Aug 21, 2013
    Messages:
    13
    Likes Received:
    4
    Do you guys use ctrl c and ctrl v to copy and paste ? I want to get it but I don't know how I just got Linux computer. Please help me!!!

     
  2. arochester

    arochester Super Moderator Staff Member

    Joined:
    Nov 23, 2012
    Messages:
    1,154
    Likes Received:
    380
    Yes, highlight the section and CtrlC and CtrlV.

    Or, highlight the section, and RIGHT click for a menu which included Copy and RIGHT click at the destination for a menu which includes Paste.
     
  3. DoraGototo

    DoraGototo New Member

    Joined:
    Aug 21, 2013
    Messages:
    13
    Likes Received:
    4
    I am doing it now like this but as clicking ctrl c and v is much more easier :(
    maybe its just my computer that doesnt' work with it...
     
  4. arochester

    arochester Super Moderator Staff Member

    Joined:
    Nov 23, 2012
    Messages:
    1,154
    Likes Received:
    380
    Can you highlight text with the mouse?
     
  5. Rob

    Rob Administrator Staff Member

    Joined:
    Oct 27, 2011
    Messages:
    608
    Likes Received:
    271
    Are you trying to copy/paste in a gnome terminal?

    You have to:

    ctrl-shift-c to copy
    ctrl-shift-v to paste

    You can re-map those to ctrl-c and ctrl-v, but probably don't want to because ctrl-c is used already as interrupt...

    If you're using your mouse to highlight the text anyway, it'll 'copy' it as you highlight it.. then click the mouse wheel to paste it in (in a gnome-term)
     
    Jeremy likes this.
  6. DoraGototo

    DoraGototo New Member

    Joined:
    Aug 21, 2013
    Messages:
    13
    Likes Received:
    4
    even my ctrl - shift-c and v aren't working... and I don't really understand how can this be fixed in terminal..
     
  7. Rob

    Rob Administrator Staff Member

    Joined:
    Oct 27, 2011
    Messages:
    608
    Likes Received:
    271
    What terminal are you using? Is there a Help --> About tab on it?
     
  8. DoraGototo

    DoraGototo New Member

    Joined:
    Aug 21, 2013
    Messages:
    13
    Likes Received:
    4
    How can I find out what am I using,sorry, /I never had Linux before and It is all new for me /
     
  9. Rob

    Rob Administrator Staff Member

    Joined:
    Oct 27, 2011
    Messages:
    608
    Likes Received:
    271
    No problem.. at the top of your terminal, does it have things like "file, edit, view, etc.."?
    gnome-terminal.png

    Click on 'Help' then go to 'about' .. to see what terminal you are using..
     
  10. DoraGototo

    DoraGototo New Member

    Joined:
    Aug 21, 2013
    Messages:
    13
    Likes Received:
    4
    Ok it says that is GNOME Terminal 3.6.0 . Hope this would help!
     
    ryanvade likes this.
  11. ryanvade

    ryanvade Administrator Staff Member Staff Writer

    Joined:
    Aug 4, 2012
    Messages:
    1,868
    Likes Received:
    659
    Then you are using the default GNOME terminal. ctrl + shift +c should copy and ctrl + shift + v should paste.

    Could you go to Edit --> keyboard Shortcuts and see what combination copy and paste are set to?

    EDIT: GNOME terminal 3.6.1 (Ubuntu 13.04) has ctrl + shift + c/v as copy/paste. This should not be different in 3.6.0. Back in 2011 gnome-terminal had a bug that prevented copy/paste from working. I think this has been fixed by now.
     
    DoraGototo likes this.
  12. DoraGototo

    DoraGototo New Member

    Joined:
    Aug 21, 2013
    Messages:
    13
    Likes Received:
    4
    I tried it but it is not working .It says that Paste is Ctrl V but Copy cant be changed to Ctrl C and any other combination I type is not working :(
     
  13. DoraGototo

    DoraGototo New Member

    Joined:
    Aug 21, 2013
    Messages:
    13
    Likes Received:
    4
    Also when I copy something with the mouse button and then do CTRL V paste it is not working either
     
    ryanvade likes this.
  14. ryanvade

    ryanvade Administrator Staff Member Staff Writer

    Joined:
    Aug 4, 2012
    Messages:
    1,868
    Likes Received:
    659
    Can you post a screenshot of the keyboard settings?
     
  15. DoraGototo

    DoraGototo New Member

    Joined:
    Aug 21, 2013
    Messages:
    13
    Likes Received:
    4
    okay here you go
     

    Attached Files:

  16. ryanvade

    ryanvade Administrator Staff Member Staff Writer

    Joined:
    Aug 4, 2012
    Messages:
    1,868
    Likes Received:
    659
    Copy is set to C and Paste is set to Shift + V...
    You might want to change them to Ctrl + Shift + C and Ctrl + Shift + V
     
  17. DoraGototo

    DoraGototo New Member

    Joined:
    Aug 21, 2013
    Messages:
    13
    Likes Received:
    4
    Guys , I found out that the the combinations with Ctrl don't work because I have already used it as a combination with which I change the languages . I don't know how to change that but I think that if I do then Ctrl C and V would both work.
     
  18. ryanvade

    ryanvade Administrator Staff Member Staff Writer

    Joined:
    Aug 4, 2012
    Messages:
    1,868
    Likes Received:
    659
    There should be a global keyboard shortcut program. I know that KDE has it built in, so GNOME probably does also.
     

Share This Page