changing SSH password prompt

Discussion in 'General Linux' started by yezrach, Feb 12, 2013.

  1. yezrach

    yezrach New Member

    Messages:
    6
    Likes Received:
    0
    Trophy Points:
    0
    Hi,

    I am trying to understand if i can modify and have ONLY the "password:" prompt to appear when ssh to my system.
    i tried to play with any env files (csh, tcsh, bash....) but i could not find where it might be configured.


    current:
    [root@msrv root]# ssh 0
    root@0's password:


    want it to be:
    [root@msrv root]# ssh 0
    password:

    current installed SSH rpms:

    openssh-3.6.1p2-33.30.14
    openssh-server-3.6.1p2-33.30.14
    openssh-clients-3.6.1p2-33.30.14


    thanks
    Y.
  2. hackinjack

    hackinjack New Member

    Messages:
    22
    Likes Received:
    2
    Trophy Points:
    0
    The only way to do this the way you ask is via downloading and modifying the source.

    However you could just display a banner with the hostname in before authentication. If you edit the /etc/ssh/sshd_config file, find the "Banner" directive. Remove the comment, then either change it to some file of your choice, or go and edit /etc/issue.net - which is the default Banner file.

    Once you have the banner text set up, restart the ssh daemon. The banner will now be displayed before the password prompt when users try to ssh in.

    Is that any use to you?
  3. yezrach

    yezrach New Member

    Messages:
    6
    Likes Received:
    0
    Trophy Points:
    0
    the banner wont help here, i already tried that:

    # ssh 0
    Red Hat Enterprise Linux AS release 3 (Taroon Update 5)
    password:
    Kernel \r on an \m

    root@0's password: (it sill shows the next).

    is there a way to recompile the Password.pm file after modifying the relevant lines in it?

    yezrach
  4. lmolinuz

    lmolinuz New Member

    Messages:
    1
    Likes Received:
    0
    Trophy Points:
    1
    Greetings...
    maybe is too late to help with it but... you don't need to recompile anything:

    with a text editor like nano or vi edit the config file /etc/ssh/sshd_config and look for the line:
    ChallengeResponseAuthentication

    if the parameter is yes:
    ChallengeResponseAuthentication yes

    you'll have the password prompt just like this:
    $ ssh user@host
    password: _


    and if the parameter is no:
    ChallengeResponseAuthentication no

    then you'll have the password prompt just like this:
    $ ssh user@host
    user@host's password: _


    save changes and restart ssh daemon:
    # /etc/init.d/ssh restart

    Note: this lines worked fine at Debian 4.0 "Etch", 5.0 "Lenny" and 6.0 "Squeeze"...
    Good luck and have a nice day everyone!

Share This Page