Cannot set up InnoDB support in MySQL due to "pthread_create returned 11" error

Discussion in 'Web Server' started by postcd, Aug 28, 2014.

  1. postcd

    postcd Member

    Messages:
    69
    Likes Received:
    6
    Trophy Points:
    8
    Hello,


    i cannot set up InnoDB support in MySQL due to "pthread_create returned 11" error . i would like to ask for help and advice here
    This is done on an OpenVZ VPS, Ubuntu 10.04 & CentOS

    I have downloaded
    http://dev.mysql.com/get/Downloads/MySQL-5.6/mysql-server_5.6.20-1ubuntu12.04_i386.deb-bundle.tar

    Which has an InnoDB support out-of-the-box. Then, i've tried three different package managers in 3 different distributives (you helped me in swapping between them) in order to install mysql-server-5.6. And only last effort succeeded. Mysql worked with InnoDB support, but only with --skip-grant-tables key. Then i tried to delete database with "rm /var/mysql/db" and mysql_install_database it again. After all operations a stable "pthread_create returned 11" error take place.

    Different combinations of different distributives and mysql versions (5.5/5.6) have the same behaivour..
    Last case I had just tried to update Ubuntu and it failed for me =(.

    I need only following commands to be executed correctly(ubuntu 10.04, lts):

    apt-get install update-manager-core
    do-release-upgrade
    wget http://dev.mysql.com/get/Downloads/MySQL-5.6/mysql-server_5.6.20-1ubuntu14.04_i386.deb-bundle.tar
    tar -xvf mysql-server_5.6.20-1ubuntu14.04_i386.deb-bundle.tar
    apt-get install <unpacked file name>.deb

    As a result, mysql database server 5.6 should be deployed on Ubuntu 14.04. doing "mysql -uroot" we can check a value in "show engines;" output. InnoDB support should be YES in it. Also, innoDB support can be checked many other ways.
  2. VitalkaDrug

    VitalkaDrug New Member

    Messages:
    25
    Likes Received:
    16
    Trophy Points:
    3
    Possibly you don't have enough free resources inside your OpenVZ container.'
    Look to your /proc/user_beancounters and check 'failcnt' counters.
    Probably some of them have not zero value.
    In this case you should increase required resources available for your VM.
    postcd likes this.

Share This Page