Cannot connect to wifi at home after upgrade to ubuntu 14.04

Discussion in 'Linux Networking' started by crusoe, Apr 22, 2014.

  1. crusoe

    crusoe New Member

    Messages:
    13
    Likes Received:
    5
    Trophy Points:
    3
    This really make me struggle , I have upgrade my dell xps13 9333 from ubuntu 13.10 to 14.04, now I could never connect to the wifi at home. The wifi card can see the wireless network, but cannot connect to it, sometimes it does, but if I ping some external server in the internet, it disconnected the wifi automatically, I have also tried the ubuntu gnome 14.04, it keeps asking the wifi's password, and still cannot connect to the internet. But the laptop can connect to the open wifi in my company, which make me crazy, I cannot figure out which part is wrong.


    Any one can help could be very appreciate.
    DevynCJohnson likes this.
  2. DevynCJohnson

    DevynCJohnson Well-Known Member Staff Member Staff Writer

    Messages:
    1,331
    Likes Received:
    1,070
    Trophy Points:
    113
    Okay, the problem seems to lie in the difference between the two Wifi networks. What type of wifi are they each using (802.11a, b, n, ab, g, ....)? Also, what kind of encryption (WEP, WPA, ...)?
  3. crusoe

    crusoe New Member

    Messages:
    13
    Likes Received:
    5
    Trophy Points:
    3
    The one I can connect does not have security, the one I cannot connect is WPA/WPA2 Personal.
  4. DevynCJohnson

    DevynCJohnson Well-Known Member Staff Member Staff Writer

    Messages:
    1,331
    Likes Received:
    1,070
    Trophy Points:
    113
    In your network settings, change the security to WPA or WPA2 for that particular network. If that still fails, try getting an update. This would be a software issue that is likely on your system.
  5. Jim Laughlan

    Jim Laughlan Active Member

    Messages:
    118
    Likes Received:
    65
    Trophy Points:
    28
    I'm having similar issues with this as well. It started with 12.04 and still is evident in 14.04. It would just up and disconnect and I have to turn off the radio and turn it back on. I checked the settings in iwconfig and the signal is about -28 dBm which is excellent with link quality of 70/70. I'm assuming its totally a driver issue. The radio is a Realtek RT8187.
  6. ryanvade

    ryanvade Administrator Staff Member Staff Writer

    Messages:
    1,260
    Likes Received:
    429
    Trophy Points:
    83
    Maybe this will help.
    https://help.ubuntu.com/community/WifiDocs/WirelessTroubleShootingGuide/Drivers
    I used to have this problem with a Realtek wireless chip on 12.04. Spent weeks trying to solve it via IRC, emai, G+ chats with developers. No one seemed to know how to fix it. Eventually I switched over to Intel wireless and the problem was sort of solved. (I just ignored the problem by switching cards)
  7. crusoe

    crusoe New Member

    Messages:
    13
    Likes Received:
    5
    Trophy Points:
    3
    I have tried to change the security, no luck, it doesn't work. It may be a driver problem because it works well in 13.10. I like the new 14.04 very much and want to use it, but seems I have to wait for some updates.:(
  8. crusoe

    crusoe New Member

    Messages:
    13
    Likes Received:
    5
    Trophy Points:
    3
    I will try it once I get home.
  9. DevynCJohnson

    DevynCJohnson Well-Known Member Staff Member Staff Writer

    Messages:
    1,331
    Likes Received:
    1,070
    Trophy Points:
    113
    Perhaps you should try reporting this as a bug on Launchpad and see what the Ubuntu developers say about it. I would assume you would report the bug specifically for "wpa_supplicant".
    ryanvade likes this.
  10. ryanvade

    ryanvade Administrator Staff Member Staff Writer

    Messages:
    1,260
    Likes Received:
    429
    Trophy Points:
    83
    Completely agree. The only way this software improves is to help the developers:
    https://launchpad.net/wpasupplicant
    DevynCJohnson likes this.
  11. DevynCJohnson

    DevynCJohnson Well-Known Member Staff Member Staff Writer

    Messages:
    1,331
    Likes Received:
    1,070
    Trophy Points:
    113
    Developers are not mind readers, so please everyone, report all bugs. I report all, every, and any bug I see. Most developers (in my experience, all of them) fix the bug as soon as they can (if they can figure out the cause) or they tell me what I can do to temporarily fix or avoid the bug.
  12. Jim Laughlan

    Jim Laughlan Active Member

    Messages:
    118
    Likes Received:
    65
    Trophy Points:
    28
    I did something out of the blue just for the heck of it....
    I went into the network settings and with the router I connect to I saw the BSSID and I went and "captured" it to save. So far going on 3 days, I have not dropped the router (of course it could be the jinx I'm hoping won't happen) and have had a solid connection. I'm wondering if that might be the problem solving question. we shall soon see.
    DevynCJohnson likes this.
  13. crusoe

    crusoe New Member

    Messages:
    13
    Likes Received:
    5
    Trophy Points:
    3
    It should be the driver problem, after installed the driver from dell's supporting site, it works. And I found it also resolved by some updates from ubuntu(pure install).

    And thanks for your suggestions, I will report bug next time if I met any problem like this.
    DevynCJohnson likes this.
  14. GregJohnson

    GregJohnson New Member

    Messages:
    1
    Likes Received:
    0
    Trophy Points:
    1
    Hi everyone, has there been any solution to this issue? I bought a Belkin N600 DB USB at first and after perusing literally 100's of posts, I gave up and returned it and bought another USB that was listed on a Ubuntu help site that ryanvade lists in an above post.

    I am running Ubuntu 14.04 on a 64-bit Dell Precision T7400. I have no wired connection to the computer. Only wireless. I'm currently connected using a Belkin N150 (F9L1001v1).

    I have this same issue with the network password continuously popping up. I can eventually get the wireless working if I open up the network settings window in the system settings. Sometimes if I click the name of my network from no check-mark to a check-mark showing (or from one showing to none, back to it being checked), then repeat that a few times I can eventually get it to connect.

    Clicking the slider bar on and off seems to do it sometimes as well... I shouldn't have to do this though.

    I will report it to launchpad as has been suggested above, but just wanted to let people know that the problem still exists, and you're not alone. This is a great community of people willing to help others. I have no doubt of that after reading through hundreds of posts in setting up my new linux box, setting up my graphics card, and in trying to set up a wireless connection. I love it though. The curve is steep, but you learn a lot.
    Last edited: Sep 29, 2014

Share This Page