Brother Printers and Linux

Discussion in 'General Computing' started by david martyn, Dec 19, 2013.

  1. david martyn

    david martyn New Member

    Messages:
    1
    Likes Received:
    0
    Trophy Points:
    1
    I own a brother printer and recently converted my laptop from Win8 to Ubuntu 13.10.
    While I am pretty pleased with the overall stability and speed of Ubuntu over Win8, I am having trouble installing the necessary software to operate my printer. When I try to install the software, I keep getting the following error message:

    Lintian check results for /media/david/My Passport/Utilities/Brother - Ubuntu/mfcj835dwlpr-3.0.1-1.i386.deb:
    E: mfcj835dwlpr: maintainer-address-missing Brother Industries, Ltd.

    I tried downloading and installing the software directly from brother's website instead of the copy I downloaded and stored on an outboard hard drive--and received the same error message.


    As an alternative, can I install the Windows software for the printer and use it via WINE?
  2. arochester

    arochester Super Moderator Staff Member

    Messages:
    909
    Likes Received:
    300
    Trophy Points:
    63
    This script seems fine: https://gist.github.com/kstevens715/5475443

    If you don't know how to run a script you could run the commands from line 11 to line 20 one-by-one in a Terminal.

    Tip: You do not need to type commands into the Terminal. Highlight the command written on the web page. Move your cursor anywhere in the Terminal and press your mouse wheel or mouse middle button. Automatic Copy and paste! No spelling mistakes! No Typos! No other errors!
  3. KenJackson

    KenJackson Active Member

    Messages:
    129
    Likes Received:
    28
    Trophy Points:
    28
    Welcome to Linux!

    I'm not sure about Ubuntu, but most Linux distros install CUPS for printer support. If it's installed and enabled, your laptop is running a web server that can only be reached from the laptop itself. It will allow you to configure the printer.

    Try opening clicking on this:
    localhost:631/admin

Share This Page