Artifacting with an ATI Radeon 9000/LXDE Debian

Discussion in 'Linux Hardware' started by Marlon, Jan 16, 2014.

  1. Marlon

    Marlon New Member

    Messages:
    23
    Likes Received:
    4
    Trophy Points:
    3
    Hi everyone,

    I think I've narrowed my configuration issues since my last, sprawling help request. Sound is running correctly from the front headphone jack (without the built-in speaker), and I'm hoping to divide and conquer the remaining few problems.

    The main one is that in LXDE (though not in Openbox, for some reason), I get consistent artifacts all over the terminal window when it moves or is overlapped. Minimizing and reopening clears it, but something must be not quite right. I sought help from the PPC Luddite, who's helped through his detailed blog and other answers already, but I'm not up to the task of following this direction:

    "Basically I think you have to create a xorg.conf file and
    play with some of its options, like disabling acceleration."

    If anyone can tell me how to do it, I'd appreciate that. The graphics card in question is a Radeon 9000 with 64MB, and as far as I understand, I need to configure this or get the right driver loaded. Thanks in advance.
    [​IMG]

  2. Marlon

    Marlon New Member

    Messages:
    23
    Likes Received:
    4
    Trophy Points:
    3
    Probably should have specified further: this is a PowerMac G4 MDD, dual booting with Debian Wheezy on the Linux side.
  3. Marlon

    Marlon New Member

    Messages:
    23
    Likes Received:
    4
    Trophy Points:
    3
    I've found what seems like useful info on the Ubuntu PowerPC FAQ page: https://wiki.ubuntu.com/PowerPCFAQ, in the section on yaboot parameters to configure if you encounter graphics problems, but it says I need to add a yaboot parameter after whatever I type at the yaboot prompt. I've been dual-booting, but I type only one letter, "l" at the yaboot prompt to select Linux, and then just enter to go into boot. Is this where I would enter the parameter that would control framebuffers?

  4. ryanvade

    ryanvade Administrator Staff Member Staff Writer

    Messages:
    1,342
    Likes Received:
    447
    Trophy Points:
    83
  5. frogfroggy

    frogfroggy New Member

    Messages:
    3
    Likes Received:
    3
    Trophy Points:
    3
    Hi,

    I have been through your pain and hopefully I can help you a little bit.

    For the solution of your graphic problem you have to set after you type

    Linux append="root=/dev/sda4 ro quiet splash"
    This should bring you to the command line interface (at least for me).

    Once your in the CLI you can then as root install the propietry drivers for your graphics card.

    Before installing the drivers, you have to add contrib and non-free to your sources.list


    Hopefully this is helpful. I found this out by searching and trying out. Im still learning Linux on PPC though.


    Take care.
    DevynCJohnson, Marlon and ryanvade like this.
  6. Marlon

    Marlon New Member

    Messages:
    23
    Likes Received:
    4
    Trophy Points:
    3
    Aha! Thanks, Froggy. It's good to know someone else has found this process tricky. I hadn't known there were proprietary drivers for the graphics card. I'm pretty sure I've got contrib and non-free in the sources.list, and I'm going to try your recommendation.

    Is it just "root=/dev/sda4 ro quiet splash" that I need to type at the second yaboot page, or also the "Linux append=" part?
  7. frogfroggy

    frogfroggy New Member

    Messages:
    3
    Likes Received:
    3
    Trophy Points:
    3
    Yes I think

    Linux append="root=/dev/sda4 ro quiet splash"

    if that does not work then just append. And once your in the CLI then you have to install your propietry drivers. There is a Atihowto site for debian if you look it up. Follow the instructions and I hope you will get a picture !
  8. Marlon

    Marlon New Member

    Messages:
    23
    Likes Received:
    4
    Trophy Points:
    3
    Thanks for the tip, but when I tried this in yaboot, it booted as usual, into the GUI, whereas I thought it was go into console mode(?) or CLI.

    I turned up this info on the Power PC FAQ section of wiki.ubuntu.com, specifically the section about configuring an xorg.conf file:
    "If you have an Apple computer then the section you want to keep will have radeon, ati, r128, nouveau or nv written in the Driver entry (what is written depends on your graphics card). There are no proprietary (non-free) drivers for ppc."

    So, I may be on the wrong track still, but the Ubuntu page suggests there are two approaches regarding graphics problems: setting a yaboot parameter and setting up an xorg.conf file. I don't have the type of huge problem they mention, like a blank or flickering screen, but the way terminal windows always have artifacting doesn't seem right, and I imagine anything using video would have issues as my system stands currently.

    I tried this "Linux video=ofonly" in yaboot, which didn't seem to make any difference, but I don't know how to set up an xorg.conf file.
    Linux video=ofonly
  9. frogfroggy

    frogfroggy New Member

    Messages:
    3
    Likes Received:
    3
    Trophy Points:
    3
    Hmm, honestly I do now know how to set up an xorg.conf. file. I would as someone else for that. But Im pretty surethere are non-free drivers for ppc. Well at least I installed them on my powermac G4.
    Once you were inthe GUI did you try to press ctrl+alt+F1 ? This should bring you to the terminal.
  10. Marlon

    Marlon New Member

    Messages:
    23
    Likes Received:
    4
    Trophy Points:
    3
    Thanks. Let me make sure I have this straight. I can get into console mode with ctrl-alt-F1; I've done it before. Then, I should install one of the drivers from this site, for example (having downloaded it first, before entering console mode)? http://support.amd.com/en-us/download
    Did this get your G4's graphics working correctly?
    Also, I'm still pretty inexperienced installing software in Debian, so I'm guessing I would just download the driver, CD to Download, and use aptitude install.
  11. Marlon

    Marlon New Member

    Messages:
    23
    Likes Received:
    4
    Trophy Points:
    3
    Thanks for the suggestion. Would this be used to make the configuration options permanent in yaboot? I'm still working on whether the next step is to create an xorg.conf file (a process I'm not really sure about), or change settings in yaboot.
    The ubuntu FAQ page says there are no proprietary drivers for PowerPC, but I'm hearing otherwise from FroggyFrog...
  12. ryanvade

    ryanvade Administrator Staff Member Staff Writer

    Messages:
    1,342
    Likes Received:
    447
    Trophy Points:
    83
    That page is for editing Yaboot if you need to.

Share This Page