Arch Distros and GRUB bugs?

Discussion in 'Arch' started by Videodrome, Jan 19, 2014.

  1. Videodrome

    Videodrome Active Member

    Messages:
    207
    Likes Received:
    79
    Trophy Points:
    28
    It seems like every flavor of Arch currently installs with GRUB errors. I initially tried Arch Bang and it would not boot. Even Arch Linux had problems and I had to Google for a fix to add to the CLI installation.

    Recently for the hell of it, I decided to try Bridge Linux which is like Arch prepackaged with desktop environments. Again, after installing it threw a strange error. Something about No Hibernation Device.

    I have used Kali Linux(Debian), but now I'm also very curious about Black Arch. I'm just wondering if I can install it without once again having a borked GRUB.


    I just wondered if any other experience Arch users could give me feedback on this issue. Especially if you already understand the source of the problem and know how to address it.
  2. ryanvade

    ryanvade Administrator Staff Member Staff Writer

    Messages:
    1,274
    Likes Received:
    431
    Trophy Points:
    83
    What command are you using to install Grub?

    From what I have experienced, the only issues with Grub on Arch Linux is Os-prober which is not really part of Grub anyway.
  3. Videodrome

    Videodrome Active Member

    Messages:
    207
    Likes Received:
    79
    Trophy Points:
    28
    This is my cheat sheet part for GRUB in Arch Linux. The bolded part references the "FIX" I use editing /etc/default/grub and inserting this line GRUB_DISABLE_SUBMENU=y. Of course, Arch Bang, Chakra, or Bridge Linux have added menu installers, so I'm not entirely sure how they put in GRUB. At one point I think I tried to wedge this into Arch Bang going in with Chroot, but it didn't work. Bridge Linux also threw an error. Something about Hibernation Device not selected?

    Install GRUB Bootloader (with Grub Fix)

    #pacman -S grub-bios os-prober

    (Grub Bug Fix)
    #nano /etc/default/grub
    [Insert this line toward the top]: GRUB_DISABLE_SUBMENU=y


    (Continue normal Grub Install)
    #grub-install --target=i386-pc --recheck /dev/sda
    #cp /usr/share/locale/en\@quot/LC_MESSAGES/grub.mo /boot/grub/locale/en.mo
    #grub-mkconfig -o /boot/grub/grub.cfg



    I'm wondering if these are sensitive to something I'm doing during the Partitioning. Maybe for an experiment, I'll try it only with a Root partition and no /home or swap.
  4. Videodrome

    Videodrome Active Member

    Messages:
    207
    Likes Received:
    79
    Trophy Points:
    28
    Well....

    I've used CrunchBang for a longtime so I'm still really curious about ArchBang. I managed to get through the funky setup they have for Pacman.

    I still cannot figure out GRUB, so I went with the Syslinux bootload option. So far it seems to be working very nicely on an old formerly WinXP Laptop. I'm just about to finish putting it on my Netbook.

    I'm not an expert on GRUB, but wondering if this would be an obstacle if I ever want to do a Multi-Boot.
  5. Kitkin15

    Kitkin15 New Member

    Messages:
    2
    Likes Received:
    1
    Trophy Points:
    1
    Whats the exact error code that you got?


    Also, when using Arch (Or any variation) You will need to change the GRUB per your layout. The majority of the configuring is just changing where your root partition is and where your kernel is located, the only error that's there with a new install can be fixed with the line you had above (GRUB_DISABLE_SUBMENU=y).

    Try and copy down the exact error you get when you use GRUB and ill see what needs to be done
  6. Videodrome

    Videodrome Active Member

    Messages:
    207
    Likes Received:
    79
    Trophy Points:
    28
    Okay, if I try GRUB again I'll post the error. I just wanted to update and say people who want to try this may have more luck with Syslinux.
  7. ZZs

    ZZs Active Member

    Messages:
    137
    Likes Received:
    50
    Trophy Points:
    28
    I don't know what the difference is between grub and grub-bios packages, but I used grub. I also used os-prober because I run other Linux os. I bypassed Syslinux and it worked fine on my laptop.
    #pacman -S grub os-prober

Share This Page