Allow Administrator account Read Write access to Root Folder

Discussion in 'Getting Started' started by mtbvfr, May 21, 2014.

  1. mtbvfr

    mtbvfr New Member

    Messages:
    1
    Likes Received:
    0
    Trophy Points:
    1
    Hi Everyone,

    2 nights ago, I finally installed Mint 16 KDE in Dual Boot mode, with Windows 8.1 Professional, on my Lenovo B590 Laptop.

    Thanks to all the tips and advice I found during my research, the install was successful. [​IMG]

    I wanted to allow the Administrator Account (my account) read/write/execute access to the Root (/) folder so that I don't have to manually modify, either via the Dolphin File Manager or Konsole (Terminal), the Ownership and/or Permissions for all the Child folders before I am able to create a new child folder etc.

    So, I tried the following.

    In the "Advanced Permissions" dialogue, I tried the "Add Entry..." button and then choosing the "Named user" option and selecting my Username from the "User" Drop Down List. However, I had no success with that.

    So, after some research I discoverd the "setfacl" and "getfacl" commands. In "Konsole as root", I entered "setfacl -R -m u:mtbvfr:rwx /".

    With the Root folder set as the "pwd" (Present Working Directory), I used "getfacl ." which produced the following.

    # file: .
    # owner: root
    # group: root
    user::rwx
    user:mtbvfr:rwx
    group::r-x
    mask::rwx
    other::r-x

    I can now create Folders and Files as I wish via Dolphin without having to user Konsole.

    However, I would like to know what the following 2 lines indicate.

    user::rwx
    mask::rwx

    What do they indicate?

    Looking at the "Advanced Permissions" dialogue, afterwards, displays the following.
    RootFolderAdvancedPermissions.png
    However, it wasn't until the next day when I wanted to download a package that I discovered a problem.

    Now, I can't start the following applications.

    "Konsole as root"
    Synaptic Package Manager
    Software Manager
    KDE Partition Manager

    The Application Name appears in the Taskbar and then disappears after some seconds.

    So, how do I fix the problem?


    How do I reverse what I did?

    Could I do the following to recover from this situation?

    1. Whilst using the Live USB environment, use "getfacl -R . > permissions.acl" whilst the "pwd"= Root.

    2. Return to the Installed environment and use "setfacl --restore=permissions.acl" or "sudo setfacl --restore=permissions.acl" ?

    Will entries in permissions.acl, that do not exist for the Installed Environment, be ignored without error?

    Also, can anyone advise me of a comprehensive manual/reference, with lots of different examples, for the Konsole/Terminal commands?

    Thanks, Michael.
  2. ZZs

    ZZs Active Member

    Messages:
    137
    Likes Received:
    50
    Trophy Points:
    28
    Create Folders under your home folder "~". "/" the root directory belongs to root permissions are set to keep the system protected and stable. It's best to stay out unless you need to make system changes as root.

    rwx = read, write, execute

    I change directory permissions with "chmod" I've never used "setfacl".

    This link is one of the best tutorials I came by its easy and progressive for all users. It will take you through BASH, you'll learn permissions and into scripting. Once you go through it things will make more sense. Definitely stay out of root "/".

    http://linuxcommand.org/learning_the_shell.php
    MikeyD and Amit_*nix like this.
  3. Amit_*nix

    Amit_*nix New Member

    Messages:
    18
    Likes Received:
    4
    Trophy Points:
    3
    Yes i think that will work as it will be taking a backup of all the permissions and then restoring the same over the "/" .

    Before doing so Please make sure you take backup of every data whatsoever in the box. Good luck

Share This Page