Administrator privileges.

Discussion in 'Member Introductions' started by invincible, Apr 19, 2012.

  1. invincible

    invincible New Member

    Messages:
    7
    Likes Received:
    0
    Trophy Points:
    0
    Hullo all!
    I'm new here, from Goa, and it certainly seems like a great place to learn.
    Just installed LinuxMint 12_64 today, dual boot with XP Home_32.
    This version of Linux is really very nice, highly usable. I've set a password
    during install that works fine in 'administrator' mode, where all files are
    visible. But there're certain work files on th drive that's mounted as 'windows'
    (had only a choice between 'windows' and 'dos' during install) that i want
    hidden, while th other files (music, etc) need to be accessible to anyone
    logging on with another profile (standard). But when i try to make Any kind of
    change, th system says that th password is Wrong! How is that?!
    Could this problem be solved somehow' have i messed up somewhere, is
    this a bug.

  2. Rob

    Rob Administrator Staff Member

    Messages:
    573
    Likes Received:
    187
    Trophy Points:
    43
    It sounds like its asking for the root (administrator in linux) password. Make sure you type it in the same way you did during install.
  3. pane-free

    pane-free Active Member

    Messages:
    353
    Likes Received:
    83
    Trophy Points:
    28
    My experience with Mint is that it can be touchy at times. Try the following --

    At the login screen with the graphical interface or GUI, go to Console and log in in text mode, instead.
    To do this, hit Ctrl-Alt-F2 (take your choice F1 to F6 -- you get back to the GUI by hitting Ctrl-Alt-F7).
    Once logged in with User name and its password, type in
    PHP:
    sudo passwd root
    First enter the User password again, then enter a new passwd for root (it asks for a UNIX password), twice.

    I create two users: one with full Administrator privileges; and a simple User which I make use of in hazardous environments and/or for surfing the net. Only use root when absolutely necessary and best used when not connected to internet.

    Ubuntuites jump all over me when I tell new users this info, but it is a matter of choice and being aware of risks.

    Best wishes and Welcome!
  4. scotty

    scotty New Member

    Messages:
    84
    Likes Received:
    3
    Trophy Points:
    0
    This happened to me, I did an install and set my root-password, on linux mint, then I tried to log in and it told me the password was wrong. No matter what I entered, it would enter it was always wrong.

    I couldn't change it because apparently I didn't even know what the password was. So I ended up creating a second admin account, setting an easy password to know I could log in, then logged in, deleted the other admin, and then changed my new password to something secured.

    That seemed to work!
  5. DaReaper

    DaReaper New Member

    Messages:
    184
    Likes Received:
    3
    Trophy Points:
    0
    Hello and Welcome to LinuxForum

    I can't seem to understand what actually where you trying to access, what's in my mind is that you're trying to access a file in Linux which is in a Windows mounted folder, but Linux is telling you that your password is wrong.

    I don't know why this is happening, cause usually every folder in linux is easily accessible unless protected. You should try to CD to that folder from the Terminal as Root and access it.

    Try to enter the exact password that you've set during login screen.
  6. invincible

    invincible New Member

    Messages:
    7
    Likes Received:
    0
    Trophy Points:
    0
    Thanks very much for th suggestions.
    What actually happened yesterday was that i had an unusual 7x330ml beer,
    went home, and formatted th comp.
    Now i have installed three drives all SATA (40, 80, 500). I'd XP Pro installed
    on th 40, with th 500 as th data drive, which had two partitions, one which
    had important files, of less than 10gb, while th 80 was disconnected.
    One day, recently, i formatted th 40, realised i was an idiot, then connected
    th 80 to load my XP Home original, and promptly got th 500 as 'dynamic' disc.
    Well, after a bit of 'research' on th 'net, i foud a method to convert it to
    'basic', which got me my main partition, full of media, while th data drive just
    vanished. I took it to another comp which had Pro installed, but it was still not
    visible, but then after more 'research' got a program (testdisk?), not sure
    which now, but got my important data back!
    But it annoyed me that a drive went missing. And that was th reason i'd
    installed Linux again. 'Again', because i've used Linux now and then, never very
    convinced about it's ease of use, though Ubuntu was certainly th best. So,
    after i installed LinuxMint12, and th partition still didn't appear, th situation
    kinda reacted with th beer.
    Now, i've XP Home on th 80, while i'm waiting to get extra cables so that i can
    connect th 40 to install LInuxMint12 (which seems Very impressive), and i'm
    sure i shall need your help shortly. Thanks, all.
  7. invincible

    invincible New Member

    Messages:
    7
    Likes Received:
    0
    Trophy Points:
    0
    Hullo.
    I've just finished installing LinuxMint12 on a separate disc,
    and it boots fine, etc, logged in as 'Administrator'.
    But i've a folder of data, that i lock when i use 'Windows', but, even
    though i didn't mount that partition (th folder's on a separate partition),
    it's still accessible in Linux. I could let others using th comp log on as
    'Guest', but i haven't managed to make th 500 gb drive with music, and
    movies, accessible through 'Guest', and everytime i try to log on as
    'Administrator' in th 'Guest profile, to modify sharing, it says th password
    is wrong! How can that be?! I've already 'shared' th appropriate folders
    as 'Administrator'.
    Is all this because of a bug that will be sorted out eventually, or is there
    something else i need to do to solve this?
  8. invincible

    invincible New Member

    Messages:
    7
    Likes Received:
    0
    Trophy Points:
    0
    Okay,
    i've re-read th suggestions given to me th first time,
    and i guess i've to follow them. Will let you guys know if i get th thing sorted. Thanks.
  9. invincible

    invincible New Member

    Messages:
    7
    Likes Received:
    0
    Trophy Points:
    0
    Thanks to all for th suggestions.
    Tried them, but i seem to now have TWO passwords, one for th
    'Administrator' user, and one for 'root'! But th folders under
    'windows' under 'File System' are not only still crossed off as
    inaccessible, they're also locked! One is th complete 500gb disk,
    while th other is an empty partition on th 80gb which has th
    XP Home (which incidentally i didn't mount during install, but
    is fully accessible - most annoying, and uncomfortable. There's
    also a 15gb partition for data on th 40gb with Linux, that's
    behaving similarly' i'm a little disillusioned, since i really
    liked this version of Linux).
    Needless to say, logged on as 'Guest' both th superlocked
    partitions are accessible, so one can't play any media through
    that user account. Is all is solvable so i remain on peaceful
    terms with LM12, or do i just wait for version 13.
    It would be really grand if there's a way round this nuisance.
  10. invincible

    invincible New Member

    Messages:
    7
    Likes Received:
    0
    Trophy Points:
    0
    Hullo all.
    I'm properly foxed; i've now followed all instructions given to me.
    But as i've explained above, th situation still is th same.
    Seems that not installing drives during install is th way to go. That'll
    likely be a problem again in th 'Guest' profile, where th 'Administrator'
    password would again be required.
    Ideally then, i would require a method to prevent th ability to mount
    a chosen drive in 'Administrator' profile. Is there a way to do this?
  11. dale

    dale Member

    Messages:
    115
    Likes Received:
    7
    Trophy Points:
    18
    I'm a little unsure where you are at now. Are you dual-booting?
  12. invincible

    invincible New Member

    Messages:
    7
    Likes Received:
    0
    Trophy Points:
    0
    Yes, th option was there, across discs, thankfully. Best part of th thing was,
    there was an option to choose which drive to install th bootloader on! It's
    therefore installed on th one with LM12, so that reinstalling Linux is not a
    problem, since reinstalling WXPH, programs, etc. always is. Now that's real cool.

Share This Page